Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-02-08 22:39:27

-iak-
Member
Registered: 2017-10-30
Posts: 68

Some apps not using theme's icon [SOLVED]

Hi there, I'm using Debian 10 with xfce 4.12.5, I applied a complete icon theme and everything works fine but some apps keep their standard icon, even if the theme has the icon for them. Is it possible to fix this? Thanks in advance,

Andrea

Last edited by -iak- (2020-02-09 00:53:33)

Offline

#2 2020-02-08 22:59:37

Aravisian
Member
Registered: 2019-08-17
Posts: 355

Re: Some apps not using theme's icon [SOLVED]

-iak- wrote:

Hi there, I'm using Debian 10 with xfce 4.12.5, I applied a complete icon theme and everything works fine but some apps keep their standard icon, even if the theme has the icon for them. Is it possible to fix this? Thanks in advance,

Andrea

Yes, it is possible. But certain things need to be known.
For example, many themes contain an icon called "additional drivers", yet the icon displayed for additional drivers is default, instead... Cause: The icon should be named "jockey."
So, while it may look like the icon theme contains the icons, they may be misnamed.

Offline

#3 2020-02-08 23:07:59

-iak-
Member
Registered: 2017-10-30
Posts: 68

Re: Some apps not using theme's icon [SOLVED]

Thank you Aravisian, I thought the reason was in the name. How do I know how the icons should be named?

Offline

#4 2020-02-08 23:13:28

Aravisian
Member
Registered: 2019-08-17
Posts: 355

Re: Some apps not using theme's icon [SOLVED]

-iak- wrote:

Thank you Aravisian, I thought the reason was in the name. How do I know how the icons should be named?

Other than looking at the default icons, I have not found a reliablemethod, myself. It is Very Annoying. Especially when I submit an icon theme and people complain...

I'd suggest asking in this thread about the specific icon names. Maybe some already know. And I can look up a few based on the references I have kept from trying to create icon themes, as well.

Offline

#5 2020-02-08 23:56:54

-iak-
Member
Registered: 2017-10-30
Posts: 68

Re: Some apps not using theme's icon [SOLVED]

Ok, cool. I'm looking for the Ardour and the Hydrogen icons right now, but I don't know exactly where to search.

Offline

#6 2020-02-09 00:35:01

MrEen
Member
Registered: 2019-04-19
Posts: 135

Re: Some apps not using theme's icon [SOLVED]

Don't know if this helps, but in /usr/share/applications the desktop files for those applications point to these icons on my older system:
Ardour=/opt/ardour/share/resources/Ardour-icon_512px.png
Hydrogen=h2-icon

Offline

#7 2020-02-09 00:53:01

-iak-
Member
Registered: 2017-10-30
Posts: 68

Re: Some apps not using theme's icon [SOLVED]

That actually helped, that string just needed to be edited with just "ardour". Thank you very much!

Offline

#8 2020-02-09 01:05:14

MrEen
Member
Registered: 2019-04-19
Posts: 135

Re: Some apps not using theme's icon [SOLVED]

Happy I could help.  A little surprised it was of any help at all, but still happy. wink

Offline

Board footer

Powered by FluxBB