Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-02-10 19:44:08

7a94b31cb16
Member
Registered: 2020-02-10
Posts: 3

GTK CSD issues

Hello smile
I'm new here and I love XFCE!
I have a few questions about GTK apps. When I drag a GTK window to the top to maximize it and drag it from top the window is bigger then it should be, until I release it. It seems that XFWM does not know that a GTK window area is bigger just because it handles shadow itself and the real window area is smaller so the shadow can be seen. Is this a bug or is it just a limitation in XFWM? One workaround is to disable shadows and margin with a custom gtk.css and have XFWM to handle the shadows. Is it possible to make XFWM draw shadows on both GTK apps and the rest? Will XFCE 4.16 fix the issue? Also I have used gtk3-nocsd but i kind of like CSD. Im using Manjaro.

Offline

#2 2020-02-10 22:41:31

Aravisian
Member
Registered: 2019-08-17
Posts: 355

Re: GTK CSD issues

This may be because those apps employ Margins in the .css which is not used by XFWM4.
I could be wrong.
So as you mention as a workaround, may not be a workaround, but the actual deal.

Offline

#3 2020-02-11 06:33:20

7a94b31cb16
Member
Registered: 2020-02-10
Posts: 3

Re: GTK CSD issues

Thanks for your answer

With this in gtk.css the window is sized like a normal window and the maximize problem is gone. But the only thing that is missing is the shadow.

* {
    transition: 0;
    box-shadow: none;
    margin: 0;
    padding: 0;
}
(I know * is for everything and I will find a way to apply it just for the window border)

It has to be a way to enable XFWM shadow on a GTK window. Everything works if I disable composition and then open a GTK app and enable composition again.

Offline

#4 2020-02-11 07:26:38

Aravisian
Member
Registered: 2019-08-17
Posts: 355

Re: GTK CSD issues

7a94b31cb16 wrote:

Thanks for your answer

With this in gtk.css the window is sized like a normal window and the maximize problem is gone. But the only thing that is missing is the shadow.

* {
    transition: 0;
    box-shadow: none;
    margin: 0;
    padding: 0;
}
(I know * is for everything and I will find a way to apply it just for the window border)

It has to be a way to enable XFWM shadow on a GTK window. Everything works if I disable composition and then open a GTK app and enable composition again.

I believe the compositor is what handles the Shadow.
With the snippet you quoted above, you may have some secondary troubles with resizing windows.
If you like to grab the edge of a window border to resize it on an as-needed-basis, then with margin set to 0, you will find nothing to grab.
If you want to apply it to just the window border, open your .css file and move that snippet to under
"decoration"
It should look like this

decoration  {
	transition: 0;
	box-shadow: none;
	margin: 0;
	padding: 0;
}
decoration:backdrop  {
	transition: 0;
	box-shadow: none;
	margin: 0;
	padding: 0;
}

As it is, your current snippet with * may disrupt all padding throughout the theme.
To answer your earlier question, yes: XFCE 4.16 may be ideal for you. Tentatively, the developers say it may be released this year.

That being said...
I have tried to replicate what you described in your O.P. and have utterly failed to do so. Given the information that you gave, I think my response is not likely too far off. Yet, I cannot see any reasonable issue, in fact, I could not notice any difference, at all.
Now, this may be due to me having different themes in my theme folder to cycle through than you do.
However, I really cannot imagine what theme could cause what you describe, either.

Could you please post Screenshots of what you are experiencing? That way, we can more easily suss out if I completely misunderstood your trouble and sent you down the wrong path.
Because setting the margin to zero may just be a bigger problem.

Last edited by Aravisian (2020-02-11 07:27:07)

Offline

#5 2020-02-11 18:19:21

7a94b31cb16
Member
Registered: 2020-02-10
Posts: 3

Re: GTK CSD issues

I made a video of the problem in a new install of manjaro 18.1 in virtualbox, no changes were made. As you can see when I drag the window from maximized state it is bigger then it should be. See the video here: https://vimeo.com/390791246

Thanks for the .css "decoration" smile I actually want no size grip area for windows i've removed it from XFWM as well.

Offline

#6 2020-02-11 19:41:42

Aravisian
Member
Registered: 2019-08-17
Posts: 355

Re: GTK CSD issues

7a94b31cb16 wrote:

I made a video of the problem in a new install of manjaro 18.1 in virtualbox, no changes were made. As you can see when I drag the window from maximized state it is bigger then it should be. See the video here: https://vimeo.com/390791246

Thanks for the .css "decoration" smile I actually want no size grip area for windows i've removed it from XFWM as well.

Well, that works out, then. Unusual- but that is what makes Linux great, when users can customize to their own needs without finding the ability lacking.

Please open your app menu and scroll down to "Settings" then scroll all the way down to Window Manager Tweaks (just below Window Manager).
Open that and then move to the Tab "Accessibility" and look to see if "Hide Window Frames When Maximized" is checked. If so, please uncheck it, then log out nad in.
Let's see if this helps.
While you are there, explore what Tweaks has to offer.
Watching the video, I am still having trouble seeing what you mean by "Bigger than it should be." Everything looks normal. When you move a window to the edges, "Window Snapping" will highlight around the window a bit to indicate its intentions- I wonder if that is what you are seeing.
I am used to it, so I may not notice it.
You may try turning window snapping off to test that.

Offline

Board footer

Powered by FluxBB