Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-02-11 20:41:45

BenXfce132
Member
Registered: 2018-01-18
Posts: 3

Terminal configuration auto completion and up arrow history

I have Linux Mint XFCE 19.3 on a number of machines and the terminals works so well. If you press TAB it shows auto complete options, and if you press up it repeats the last command. Love it.

Now, we have an Ubuntu 18.04 LTS server upon which the XFCE interface was added. The terminal there does not respond to these two keys. Tab simply adds a few spaces, and the up arrow key generates ^[[A.

I have googled this and found lots of references, but none of them work.

I have removed and reinstalled bash-completion. I have done this:  Open the Xfce Application Menu > Settings > Window Manager. Click on the Keyboard Tab. Clear the Switch window for same application setting. Tried other chortcuts: Control-Tab basically does the same as tab, moves a few spots to the right.

~/.bashrc just seems to have the usual stuff with auto complete at the bottom.

Control shift uparrow reexecutes the last command, but I want it on the command line to maybe fix a typo.

There is nothing ~/.inputrc and putting this in it has no effect:
"\e[A": history-search-backward
"\e[B": history-search-forward

The terminal seems to /bin/dash

I just cant get it work! Please help!

Offline

#2 2020-02-11 20:43:48

BenXfce132
Member
Registered: 2018-01-18
Posts: 3

Re: Terminal configuration auto completion and up arrow history

Ah I just figured it out, dash!=bash, so just enter: bash and then it works.

Offline

Board footer

Powered by FluxBB