Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-02-22 03:16:16

xaxazak
Member
Registered: 2016-08-04
Posts: 14

Disabling Monitor Auto-reconfiguration + Possible Patch

There are many posts about the problems with automatic monitor-reconfiguration upon detection of monitor changes (links at bottom).

Whenever I turn my monitors off XFCE reconfigures the displays, and when I turn them back on again, even if the auto-profile resets the displays correctly, my windows have all been moved around. I turn my monitors on and off many times per day (if I'm going to be away from them between say 5min and 1hr).

I've been putting up with it for a while, but now it's got worse. I'm now using a swivel monitor - I switch between portrait and landscape depending on what I'm doing. If I just use Settings->Display->Advanced->"Automatically enable profiles when new display[sic] is connected" it's going to be wrong around half the time (also, I can't figure out how to change the profile order when there are multiple profiles, they seem to be sorted by something in the profile).

---

There's a tiny patch (https://bugzilla.xfce.org/attachment.cgi?id=7992) I found at the bottom of (https://bugs.launchpad.net/ubuntu/+sour … ug/1716172) that gives an option to totally disable auto-detection, which I think would solve many people's problems, although it's for an earlier version.

If I were to adapt that to the current source:
- Do I need to completely rebuild XFCE to test it?
- Can I easily avoid messing with my current install?
- If I were to get it working with a proper UI option in Settings->Display, how likely would a patch be to get accepted? (I don't like having to use self-patched stuff as it breaks updates).

---

Related Posts:

https://forum.xfce.org/viewtopic.php?id=12226
https://bugs.launchpad.net/ubuntu/+sour … ug/1716172
https://www.reddit.com/r/xfce/comments/ … gnore_the/
https://forum.xfce.org/viewtopic.php?id=13546
https://forum.xfce.org/viewtopic.php?id=10951
...
And there's many more I've read before but closed, not too hard to google for others.

IMHO, this really needs to be fixed.


Thanks for all assistance.

Offline

Board footer

Powered by FluxBB