Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-08-16 13:03:50

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,381

Xfwm 4.14 Compositor Troubleshooting Guide

There have been numerous reported issues with the 4.14 release of xfwm related to transparency issues, compositing problems and blank screens. This post will provide some troubleshooting information to get the issue resolved.

There have been significant changes in the vblank code between 4.12 and 4.14 to help address and hopefully solve the screen tearing issues. xfwm4 now supports 3 vblank modes:

  1. glx or auto - this is the default. Anecdotally, this seems to work well with intel cards and some nvidia/ati cards

  2. xpresent - uses the xpresent libraries. Anecdotally, this seems to work well with newer ati/amd cards.

  3. off - this disables the vblank code. Anecdotally, this seems to work well with nvidia cards.

To test which vblank mode works best for your system, simply restart xfwm and specify as a parameter which vblank mode to use:

xfwm4 --vblank=MODE --replace

...where "MODE" is one of: auto, glx , xpresent , or off.

If this fixes your problem, you can make it permanent via a vblank_mode setting:

xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "MODE" --create

...where "MODE" is one of: "auto", "glx", "xpresent", "off".

Note: if nothing is specified, glx is used.

Last edited by ToZ (2019-10-14 11:36:26)

Offline

#2 2019-10-14 06:42:36

sushi
Member
Registered: 2019-04-22
Posts: 48

Re: Xfwm 4.14 Compositor Troubleshooting Guide

Hi ToZ,

Thanks for this guide !

Here I have a fourth mode > "auto" . Is there any command to know which mode is use by "auto" ?

Offline

#3 2019-10-14 11:33:47

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,381

Re: Xfwm 4.14 Compositor Troubleshooting Guide

Yes, you are right. "auto" is also valid and it uses the glx backend by default. I'll update my post.

Thanks.

Offline

#4 2019-10-14 12:25:45

sushi
Member
Registered: 2019-04-22
Posts: 48

Re: Xfwm 4.14 Compositor Troubleshooting Guide

My pleasure.

Thanks.

Offline

#5 2020-01-21 21:59:06

Racer-X
Member
Registered: 2020-01-21
Posts: 1

Re: Xfwm 4.14 Compositor Troubleshooting Guide

Changing vblank_mode from "auto" to "xpresent" resolved an issue for me.  I as experiencing very high CPU loads only when I plugged an external monitor into the VGA port on my netbook and used it as a second monitor. Switching from "auto" to "xpresent" resolved the CPU overload.

My configuration:

$ sudo inxi -G
Graphics:  Device-1: Intel Mobile 945GSE Express Integrated Graphics driver: i915 v: kernel 
           Display: server: X.Org 1.20.5 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: 1024x600~60Hz, 1400x1050~60Hz 
           OpenGL: renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 v: 1.4 Mesa 19.2.1 

Offline

#6 2020-03-09 15:02:05

ibob
Member
Registered: 2012-11-25
Posts: 9

Re: Xfwm 4.14 Compositor Troubleshooting Guide

Ran into a performance problem when upgrading from 18.04 to 19.10: high CPU for Xorg when doing GUI related actions to the point that mouse was freezing. Example, switching workspaces took ~1sec. The problem was resolved with the suggested configuration change.

$ sudo inxi -G
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel 
  Display: server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.2.8 

Offline

Board footer

Powered by FluxBB