Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-05-11 03:13:06

MasterPythoner
Member
Registered: 2020-03-30
Posts: 6

how to disable effect when hovering on xfce4-panel items

hello .
I want to disable this orange line (see the attached photo) when I hover on Date and time in the pannel . also on other panel's items .
I want also to disable tooltips when hovering .
Is this possible?
https://twitter.com/MasterPythoner/stat … 93/photo/1

Offline

#2 2020-05-11 11:44:52

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: how to disable effect when hovering on xfce4-panel items

It really depends on the version of Xfce and xfce4-panel that you are using. Can you post back:

xfce4-panel -V

...and also what Appearance (GTK) theme are you using?

I want also to disable tooltips when hovering .

Everywhere? Or just over the panel? See: https://forum.xfce.org/viewtopic.php?id=6348

Offline

#3 2020-05-11 12:48:56

MasterPythoner
Member
Registered: 2020-03-30
Posts: 6

Re: how to disable effect when hovering on xfce4-panel items

xfce4-panel 4.12.2 (Xfce 4.12)

Copyright (c) 2004-2011
	The Xfce development team. All rights reserved.

Please report bugs to <http://bugzilla.xfce.org/>.
WM Theme: BlueDay-Small
Theme: Canta-square [GTK2/3]
Icons: Elementary [GTK2/3]

and here is

inxi -Fxz

output :

System:    Host: master-pc Kernel: 4.15.0-43-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: IceWM 1.4.3.0~pre-20180217 Distro: Peppermint Nine
Machine:   Device: laptop System: LENOVO product: 33668DG v: ThinkPad Edge E530c serial: N/A
           Mobo: LENOVO model: 33668DG serial: N/A
           UEFI [Legacy]: LENOVO v: J0ET15WW (1.05 ) date: 08/02/2013
Battery    BAT0: charge: 11.5 Wh 40.8% condition: 28.2/40.4 Wh (70%)
           model: LGC 45N1049 status: Discharging
CPU:       Dual core Intel Core i5-3320M (-MT-MCP-) 
           arch: Ivy Bridge rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10376
           clock speeds: max: 3300 MHz 1: 1215 MHz 2: 1205 MHz 3: 1210 MHz
           4: 1216 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF119M [GeForce 610M] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile
           version: 4.2 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel 7 Series/C216 Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-43-generic
Network:   Card-1: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge bus-ID: 03:00.0
           IF: wlp3s0b1 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 0c:00.0
           IF: enp12s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (3.2% used)
           ID-1: /dev/sda model: WDC_WD5000LPVX size: 500.1GB
Partition: ID-1: / size: 29G used: 9.2G (34%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 6.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: N/A gpu: 38.0
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 211 Uptime: 8 min Memory: 1012.5/3544.2MB
           Init: systemd runlevel: 5 Gcc sys: 7.5.0
           Client: Shell (zsh 5.4.2) inxi: 2.3.56

I want to disable tooltips just only when I hover on panel .
disabling tooltips is my second priority . removing the yellow line under elements (when hovering) is more important for me.

Last edited by MasterPythoner (2020-05-11 12:50:16)

Offline

#4 2020-05-11 17:07:53

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: how to disable effect when hovering on xfce4-panel items

That particular theme, for the GTK2 component, uses the pixmap engine and asset files to create that affect. You will find the asset files in the gtk-2.0/assets folder of that theme. Specifically, it uses three png files:

- flat-button.png = this is the default no highlight image
- pathbar_button_active.png = the orange underline when the button is selected
- pathbar_button_prelight.png = the orange tint when you hover over a button

The easiest way is to copy over flat-button.png to over write the other two files.

I want to disable tooltips just only when I hover on panel .

I don't think this is possible with GTK2 - its an all or nothing.

Offline

#5 2020-05-12 13:12:00

MasterPythoner
Member
Registered: 2020-03-30
Posts: 6

Re: how to disable effect when hovering on xfce4-panel items

I did as you said . the line under date/time indicator , and active task button have been removed .... but the line under whisker menu and sound k-layouts , systray , and other plugins still remained .
p.s. I removed thumbnail cache and restarted the system ....
however u gave me the idea . I will try to fix this .

ToZ wrote:

I don't think this is possible with GTK2 - its an all or nothing.

alright I don't understand globally disabling tooltips how will affect the system . I don't think it is serious . let's give it a try .
how can I disable tooltips with GTK2?

Offline

#6 2020-05-12 17:16:17

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: how to disable effect when hovering on xfce4-panel items

MasterPythoner wrote:

how can I disable tooltips with GTK2?

echo "gtk-enable-tooltips = 0" >> ~/.gtkrc-2.0

Offline

Board footer

Powered by FluxBB