Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-05-18 13:23:54

860lacov
Member
Registered: 2020-05-10
Posts: 7

How to get rid of screen tearing?

arch
Lenovo t410 - intel integrated card - intel i5 m520

Device-1: Intel Core Processor Integrated Graphics vendor: Lenovo driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0046 
           Device-2: Lenovo Integrated Webcam [R5U877] type: USB driver: uvcvideo bus ID: 1-1.6:4 
           chip ID: 17ef:480f 
           Display: x11 server: X.Org 1.20.8 driver: modesetting alternate: fbdev,intel,vesa s-res: 1440x900 
           s-dpi: 96

I've tried

xfwm4 --vblank=MODE --replace

with off, glx, and xpresent (my current vblank mode)
glx and xpresent are better than off but there is screen tearing visible (especially in fast scrolling in firefox)

Can I do something else? Is it necessary to change compositor?

Offline

#2 2020-05-18 17:41:29

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,863

Re: How to get rid of screen tearing?

Is it just firefox that you get the tearing with after setting the compositor to xpresent (and restarting xfwm4)? If so, try disabling smooth scrolling in firefox preferences.

Offline

#3 2020-05-20 14:18:36

860lacov
Member
Registered: 2020-05-10
Posts: 7

Re: How to get rid of screen tearing?

ToZ wrote:

Is it just firefox that you get the tearing with after setting the compositor to xpresent (and restarting xfwm4)? If so, try disabling smooth scrolling in firefox preferences.

To be honest I'm not sure.
I don't use many applications with scrolling possibility smile

Don't know if this is important but in this video:
Screen Tearing Test
There is tearing too. Firefox smooth scrolling shouldn't impact on video (I think).

Offline

Board footer

Powered by FluxBB