Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-05-20 23:20:15

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 434
Website

Configuring lightdm's greeter

I have a laptop running Fedora 31 and Xfce 4/14, fully updated.  I'm trying to configure the greeter to use a custom background, but all I can get is a black background.  I've tried both lightdm-settings and lightdm-gtk-greeter-settings with the same results.  Does the image have to be in a specific location or file format?


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#2 2020-05-20 23:46:46

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 138

Re: Configuring lightdm's greeter

From the Arch wiki:

Changing background images/colors

You can set the background to a hex color or an image. Some greeters offer more robust background options like background selection from the login screen, random backgrounds, etc.
GTK greeter

You can use the lightdm-gtk-greeter-settings gui.

Users wishing to customize the wallpaper on the greeter screen need to edit /etc/lightdm/lightdm-gtk-greeter.conf and define the background variable under the [greeter] section. For example:

/etc/lightdm/lightdm-gtk-greeter.conf

[greeter]
background=/usr/share/pixmaps/black_and_white_photography-wallpaper-1920x1080.jpg

Note: It is recommended to place the PNG or JPG file in /usr/share/pixmaps since the LightDM user needs read access to the wallpaper file.

Offline

#3 2020-05-21 02:06:31

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 434
Website

Re: Configuring lightdm's greeter

Interesting: you're saying that neither GUI can change the background, even though both of them have a place where you can set the wallpaper, and I remember changing it in a GUI on a different machine.  And, I have managed to change it from the default for my distro to a blank, black screen.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#4 2020-05-21 02:42:31

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 138

Re: Configuring lightdm's greeter

I think it can be done in the greeter settings this but like the wiki post mentioned the image should be in /usr/share/pixmaps so it can be seen by the greeter.

Offline

#5 2020-05-22 01:40:01

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 434
Website

Re: Configuring lightdm's greeter

Well, that did work, so thanx, but it leaves me with a question.  The image was in ~/Pictures, and I know that /home is mounted at boot.  I wonder why the greeter couldn't find it until I put a copy in /usr/share/pixmaps.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#6 2020-05-22 10:31:39

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: Configuring lightdm's greeter

When lightdm runs the greeter, it runs it as the "lightdm" user. This user account, by default, does not have access to your home directory so it cannot see or use those images. If you look at your /var/log/lightdm.log file you'll see an entry where it starts the greeter and with which user account:

[+3.23s] DEBUG: Session pid=660: Started with service 'lightdm-greeter', username 'lightdm'

You could work around this if you granted the lightdm user access to your home directory.

Offline

Board footer

Powered by FluxBB