Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-04-26 04:35:16

anandv96
Member
Registered: 2020-04-26
Posts: 3

[SOLVED] pulseaudio - Output does not work without changing input port

I've just installed xubuntu 20.04 on my Dell Latitude 7480 laptop. Every time I plug in external devices to the 3.5mm jack, the audio output cuts off. In pavucontrol (pulse audio) the audio input device port changes to "Microphone (Plugged In)" automatically. To re-enable audio output, I have to manually change the input device port to "Headset Microphone (Plugged In)" or "Internal Microphone (Plugged In)", and then the output works as expected.

All 3 of these input device ports:  "Internal Microphone (Plugged In)", "Headset Microphone (Plugged In)", "Microphone (Plugged In)" are always available to select. But selecting  "Microphone (Plugged In)" results in no sound output through the connected audio device.
If no external device is plugged in, the internal speakers work as expected regardless of the input device selected because the just microphone input option changes to "Microphone (unplugged)".

I experienced this problem in ubuntu mate 20.04 as well. Has anybody experienced the same issue?

Is there a way that I can disable the audio input device from automatically changing, and keep it defaulted to 'internal mic'?  Or is there something else that's causing this?

screenshot of the pavucontrol tab in question: https://imgur.com/3P1bHap.png


edit: solved by disabling the port: https://askubuntu.com/questions/715016/ … pulseaudio

Last edited by anandv96 (2020-04-27 03:48:38)

Offline

#2 2020-04-26 04:58:30

MrEen
Member
Registered: 2019-04-19
Posts: 187

Re: [SOLVED] pulseaudio - Output does not work without changing input port

You could see if commenting this out in /etc/pulse/default.pa makes any difference:

load-module module-switch-on-connect

Offline

#3 2020-04-26 10:47:52

anandv96
Member
Registered: 2020-04-26
Posts: 3

Re: [SOLVED] pulseaudio - Output does not work without changing input port

MrEen wrote:

You could see if commenting this out in /etc/pulse/default.pa makes any difference:

load-module module-switch-on-connect

I tried this, and disabling port switch on connect, but this enables and disables both input and output.

So now every time I plug in new headphones, I have to change the output from internal speakers to plugged in headphones. Still equally cumbersome sadly. Is there anything that I can do to only keep the input constant?

Offline

#4 2020-04-26 21:29:29

MrEen
Member
Registered: 2019-04-19
Posts: 187

Re: [SOLVED] pulseaudio - Output does not work without changing input port

Back with your original situation, at the bottom of /etc/pulse/default pa add something like this:

set-default-source alsa_input.pci-0000_00_14.2.analog-stereo
set-source-port 0 analog-input-internal-mic

Get the name (alsa_input.pci-0000_00_14.2.analog-stereo) and card number (0) by running pacmd list-sources in the terminal.

Offline

#5 2020-04-27 03:47:08

anandv96
Member
Registered: 2020-04-26
Posts: 3

Re: [SOLVED] pulseaudio - Output does not work without changing input port

MrEen wrote:

Back with your original situation, at the bottom of /etc/pulse/default pa add something like this:

set-default-source alsa_input.pci-0000_00_14.2.analog-stereo
set-source-port 0 analog-input-internal-mic

Get the name (alsa_input.pci-0000_00_14.2.analog-stereo) and card number (0) by running pacmd list-sources in the terminal.


This didn't work for me either. It set the default port, but the port changed each time because the faulty port "Microphone" still had priority over the internal microphone.

So instead what I did was disable the redundant input port: https://askubuntu.com/questions/715016/ … pulseaudio

This meant that the input ports only switched between the properly working input ports of: Internal Microphone or Headset Microphone. Now the problem is fixed! Another possible solution for people could be to change the port priority without disabling the port outright.

Offline

#6 2020-04-27 20:14:06

MrEen
Member
Registered: 2019-04-19
Posts: 187

Re: [SOLVED] pulseaudio - Output does not work without changing input port

Hey, nice solution!  Well done. smile

Offline

#7 2020-05-23 17:25:27

DKEBeck88
Member
Registered: 2020-05-23
Posts: 5

Re: [SOLVED] pulseaudio - Output does not work without changing input port

anandv96 wrote:
MrEen wrote:

Back with your original situation, at the bottom of /etc/pulse/default pa add something like this:

set-default-source alsa_input.pci-0000_00_14.2.analog-stereo
set-source-port 0 analog-input-internal-mic

Get the name (alsa_input.pci-0000_00_14.2.analog-stereo) and card number (0) by running pacmd list-sources in the terminal.


This didn't work for me either. It set the default port, but the port changed each time because the faulty port "Microphone" still had priority over the internal microphone.

So instead what I did was disable the redundant input port: https://askubuntu.com/questions/715016/ … pulseaudio

This meant that the input ports only switched between the properly working input ports of: Internal Microphone or Headset Microphone. Now the problem is fixed! Another possible solution for people could be to change the port priority without disabling the port outright.

Hi - I'm having the exact same problem with Xubuntu 20.04 on a Dell XPS 15 9550.  However, when I add ".backup" to analog-input-headphone-mic.conf and log out and back in, all input devices are disabled.  I would love to get where you are, where internal and headset mics are still available.  What file did you add ".backup" to in order to get to your solution?  I attempted instead to increase the priority of the internal mic like you also suggested, but all that did was change the order that the mics are listed in the input tab of the audio mixer.

Offline

#8 2020-05-23 17:38:36

MrEen
Member
Registered: 2019-04-19
Posts: 187

Re: [SOLVED] pulseaudio - Output does not work without changing input port

I suspect anandv96 added .backup to analog-input-mic.conf for their issue as the "Microphone (Plugged In)" was the unfriendly option.

Offline

#9 2020-05-25 13:51:33

DKEBeck88
Member
Registered: 2020-05-23
Posts: 5

Re: [SOLVED] pulseaudio - Output does not work without changing input port

MrEen wrote:

I suspect anandv96 added .backup to analog-input-mic.conf for their issue as the "Microphone (Plugged In)" was the unfriendly option.

That's actually what I thought at first and so first tried that.  Unfortunately, that didn't seem to change anything at all.

Offline

#10 2020-05-25 14:33:50

MrEen
Member
Registered: 2019-04-19
Posts: 187

Re: [SOLVED] pulseaudio - Output does not work without changing input port

Try deleting PulseAudio's config files in ~/.config/pulse if you haven't already. Either run pulseaudio -k after that, or log out/in.

Offline

#11 2020-05-25 17:42:13

DKEBeck88
Member
Registered: 2020-05-23
Posts: 5

Re: [SOLVED] pulseaudio - Output does not work without changing input port

MrEen wrote:

Try deleting PulseAudio's config files in ~/.config/pulse if you haven't already. Either run pulseaudio -k after that, or log out/in.

So we're on the same page, should I try this after renaming analog-input-mic.conf to analog-input-mic.conf.backup, or before?

Offline

#12 2020-05-25 20:00:59

MrEen
Member
Registered: 2019-04-19
Posts: 187

Re: [SOLVED] pulseaudio - Output does not work without changing input port

I'd do both. Test after the first attempt to see if that alone was all you needed.

Offline

#13 2020-05-26 01:01:43

DKEBeck88
Member
Registered: 2020-05-23
Posts: 5

Re: [SOLVED] pulseaudio - Output does not work without changing input port

MrEen wrote:

I'd do both. Test after the first attempt to see if that alone was all you needed.

Alright - got it all straightened out.  Deleting all the files in ~/.config/pulse alone didn't change anything, and deleting all files in ~/.config/pulse and adding .backup to analog-input-mic.conf didn't change anything, but deleting all files in ~/.config/pulse and adding .backup to analog-input-headphone-mic.conf straightened everything out.  My sound toggles between speakers and headphones seamlessly when I plug and unplug headphones in the jack, and the two other mic input options (headset, internal) are still there and work perfectly.  Thanks a ton!

Offline

#14 2020-05-26 01:31:12

MrEen
Member
Registered: 2019-04-19
Posts: 187

Re: [SOLVED] pulseaudio - Output does not work without changing input port

You're welcome. smile

Offline

Board footer

Powered by FluxBB