Xfce Forum

Sub domains

You are not logged in.

#1 2020-11-01 17:56:19

Registered: 2020-11-01
Posts: 1

Symlinks and Thunar / File Manager

First time posting. Please be gentle smile

Thunar is not handling symlinks for me. When I double-click on a symlink, I get an "Open With" window and an invitation to select the application that should be used to open "symbolic link". I've tried selecting Thunar and File manager, but the selection makes no difference to the dialog behaviour: I just get asked again what application should be used to open "symbolic link". I therefore cannot use any symlink in the GUI. Command line behaviour is fine and the symlinks behave as expected.

This issue has been noted recently here https://forum.xfce.org/viewtopic.php?id=12158 and here https://forum.xfce.org/viewtopic.php?id=13774. Neither have been solved (despite one being labelled as such). I'm raising a new topic to give those issues some renewed visibility and also in the hope that there is a solution.

I'm running XFCE 4.14 / Manjaro Linux 20.1.2

Anyone else had this problem and is there a fix?



#2 2020-11-11 21:42:34

Registered: 2014-07-28
Posts: 763

Re: Symlinks and Thunar / File Manager

Hello and welcome to the forum, sorry for the delay!

Did you try the approach suggested by ToZ in your 2nd link?

ToZ wrote:

Go to Settings Manager > Mime Type Editor and in the filter box, enter "symlink".  You should see something like:

inode/symlink     Default     Open folder with Thunar

You can click on the last field and it will drop down some options like choose an app, reset to default, etc.


Board footer

Powered by FluxBB