Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-02-20 10:44:11

u666sa
Member
Registered: 2019-11-13
Posts: 43

Someone plz revirew XFCE4-HARDWARE-MONITOR-MONITOR-PLUGIN

Guys.. I'm biting my elbows on Arch. I can no longer use hardware monitor plugin. Author has stopped maintaining it, AUR dropped it because of it. It is not compatible with xfce4.16 since there are different panel and ui libraries. Plugin in was to be rewritten. Those of you on ubuntu can still use it, but it's just a matter of time, another year, and this will also concern you.

Please, someone rewrite this plugin.

Offline

#2 2021-02-20 19:10:08

mint4all
Member
From: out of sight
Registered: 2018-08-21
Posts: 167

Re: Someone plz revirew XFCE4-HARDWARE-MONITOR-MONITOR-PLUGIN

Greetings!

Fwiw: I share your frustration caused by useful plugins / features being dropped. FYI: a rundown of where this plugin's maintenance level stands is posted @ https://repology.org/project/xfce4-hard … n/versions

Looks like your only alternative is to explore using "Conky", but I am a complete noob when it comes to that. Alas, because my level of C-lang expertise is beyond rusty (no diamonds there), I can't help you at all. Perhaps porting over to Python or "Rust" might work, but I am unclear as to the developers' policy re. the use of other languages (read: dependencies) within the context of Xfce4...

Sorry for not being of much help.

Cheers, m4a


Linux Mint 18.3, 19.3, 20.0 -- xfce 4.12 & 4.14... Apple IMAC 11,3 -- Dell Precision T1500 Desktops -- Toshiba Satellite, Dell Inspiron & HP Pavilion Laptops -- Family & Community Support re. Linux

Offline

Board footer

Powered by FluxBB