Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-12-06 21:20:11

doodloo
Member
From: London
Registered: 2015-09-11
Posts: 54

Problems with Xubuntu 20.10

Good evening,

I've installed Xubuntu 20.10 today, and there are a few things that don't work as expected. One of them seems to be related with Xubuntu.
The brightness keys of my laptop don't work any more - even though the "brightness notifications" change appear properly when pressing them.

When adjusting the brightness via command line (Eg. `xrandr --output DP-2 --brightness 0.5`) it seems to be adjusting some form of software brightness, but the physical light behind the LCD panel doesn't really seem to change.

EDIT: After closer inspection, it seems that there's a change in behaviour with the graphics driver (nvidia proprietary). With the same versions (450 and 455) of the driver as I was using before I'm not offered the choice between integrated and discrete graphics - and when using the Nouveau driver, the brightness works...

Any idea please?

Thanks,
Doodloo.

Last edited by doodloo (2021-02-22 19:09:09)

Offline

#2 2021-01-02 17:43:49

doodloo
Member
From: London
Registered: 2015-09-11
Posts: 54

Re: Problems with Xubuntu 20.10

Bumpidy bump? smile

Offline

#3 2021-01-02 18:00:48

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,844

Re: Problems with Xubuntu 20.10

This is probably more related to the kernel and the video driver than Xfce.

As per https://forums.developer.nvidia.com/t/l … ode/160292. does creating the file /etc/X11/xorg.conf.d/21-nvidia-brightness.conf with the contents:

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

...and rebooting help?

Offline

#4 2021-01-02 18:04:36

alcornoqui
Member
Registered: 2014-07-28
Posts: 808

Re: Problems with Xubuntu 20.10

And if that doesn't work, maybe take a look at Ubuntu's wiki on backlight troubleshooting and report back.

Good luck!

Offline

#5 2021-01-03 11:37:37

doodloo
Member
From: London
Registered: 2015-09-11
Posts: 54

Re: Problems with Xubuntu 20.10

Guys, thanks a lot for taking the time. This is very valuable information, and I didn't try any of this yet.
I will report back tomorrow once I have tried.

Thanks again!

Offline

#6 2021-01-03 11:46:30

doodloo
Member
From: London
Registered: 2015-09-11
Posts: 54

Re: Problems with Xubuntu 20.10

Hello again Alcornoqui and ToZ,

I just gave a quick try to ToZ's solution first, and it worked.
Just a few notes for anyone who might be in the same situation:
- On my distribution, `/etc/X11/` did not contain a `xorg.conf.d` folder. I had to create it.
- Interestingly, `/etc/X11` also doesn't contain a `xorg.conf` file. Maybe that's the main difference between before and now. I didn't have to create one.

If you're unsure, here are the steps to do what ToZ suggested:

sudo mkdir -p /etc/X11/xorg.conf.d
sudo touch /etc/X11/xorg.conf.d/21-nvidia-brightness.conf
sudo vim /etc/X11/xorg.conf.d/21-nvidia-brightness.conf
# At this point, copy-paste ToZ's snippet in your editor - save the file and reboot.

Thanks a lot guys.

Last edited by doodloo (2021-01-03 11:46:57)

Offline

#7 2021-02-22 19:16:21

doodloo
Member
From: London
Registered: 2015-09-11
Posts: 54

Re: Problems with Xubuntu 20.10

I'm re-opening this topic, something has gone wrong.
After being happy with this solution for a while, I realised that my GPU wasn't actually available to the system. The `nvidia-settings` tool gave absolutely no options, except for switching between "Performance", "On-Demand", "Power Saving" (Respectively nvidia, hybrid, intel I think), but these making no difference at all. OpenGL application were running at around 6fps.
So I started fiddling around and read that I had to try different combinations of:
- Disabling Secure Boot.
- forcing my graphic adapter to "Discreete" in my bios.
...and all other sorts of shenanigans.

In the end, I noticed that:
- If I disable secureboot, and have the BIOS settings to "Discreete", I get GPU acceleration - the `nvidia-settings` tool however doesn't allow to switch anymore, but the panel shows lots of information and options for the GPU. However, brightness doesn't work.
- If I enable secure boot, it sometimes works, sometimes doesn't.
- I've tried to have the `21-nvidia-brightness.conf` file with all of these combinations, it just doesn't fix anything when the GPU actually seems to work.

I'm a bit confused now - I guess what I'd like is to have access to the GPU, and the brightness to work on hardware...

Note that I'm uninstalling - rebooting - installing the drivers every time I make a change just to be sure that it generates whatever certificates it needs for Secure Boot etc... I purge and install packages `nvidia-driver-460 nvidia-utils-460 nvidia-prime nvidia-settings`.

At this point I'm mainly confused about what is possible, what I can and can't get, or if there are fixes.

@ToZ last time you had a solution that immediately worked so I'm guessing that you actually understand the thing much more than I do, maybe you'll spot something that I'm asking that is not possible? Or something that I'm doing wrong?

Thanks a lot!

Offline

#8 2021-03-13 13:27:17

doodloo
Member
From: London
Registered: 2015-09-11
Posts: 54

Re: Problems with Xubuntu 20.10

Bumpidy bump? smile

Offline

#9 2021-03-13 13:52:08

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,844

Re: Problems with Xubuntu 20.10

doodloo wrote:

@ToZ last time you had a solution that immediately worked so I'm guessing that you actually understand the thing much more than I do, maybe you'll spot something that I'm asking that is not possible? Or something that I'm doing wrong?

Unfortunately, I don't have an nvidia card to be able to assist (nor experience with dual nvidia/intel cards). I've seen numerous forum posts about nvidia backlight issues and have read that the "EnableBrightnessControl=1" is an option.

I'm wondering if you'd get better assistance at either the nvidia forums or your distro's forums.

Offline

#10 2021-03-13 14:34:17

doodloo
Member
From: London
Registered: 2015-09-11
Posts: 54

Re: Problems with Xubuntu 20.10

Cool. Thanks for the info @ToZ! I'll give it a go this week, and I'll report back here if I find something interesting.

Last edited by doodloo (2021-03-13 14:34:37)

Offline

Board footer

Powered by FluxBB