Xfce Forum

Sub domains

You are not logged in.

#26 2021-08-22 18:19:20

From: Canada
Registered: 2011-06-02
Posts: 9,053

Re: [SOLVED] shortcuts doesn't work

Anti virus wrote:

solved => when I got into keyboard layout,I put English first,then my language
Was this a bug?

Possibly this bug?


#27 2021-08-25 02:16:33

From: right by Jesus, our Saviour
Registered: 2013-06-15
Posts: 697

Re: [SOLVED] shortcuts doesn't work

for security with X there is the ~/.Xauthority file and the xauth command.  i assume xdotool has to establish authenticity and authority over the X protocol connection (limited by xhost) like any other X app must.  but is that good enough?

i did read this in the xdotool man page:

Sending keystrokes to a specific window uses a different API than simply typing to the active window. If you specify 'xdotool type --window 12345 hello' xdotool will generate key events and send them directly to window 12345. However, X11 servers will set a special flag on all events generated in this way (see XEvent.xany.send_event in X11's manual). Many programs observe this flag and reject these events.

i think that answers what i saw happen.


#28 2021-08-26 16:20:19

Anti virus
Registered: 2021-08-15
Posts: 17

Re: [SOLVED] shortcuts doesn't work

Thank you all


#29 2021-11-18 05:43:51

Registered: 2020-01-07
Posts: 31

Re: [SOLVED] shortcuts doesn't work

I was having this issue too. At first it seemed like only the inputs would be ignored when I was on XScreen 0.1 or 0.2 but then it started ignoring them on 0.0. I tried the xdotool key Ctrl+Alt+t on XS 0.1 and nothing happened then I did a xfsettingsd --replace and everything started working again for a short while. Sadly I've added a cronjob to constantly run xfsettingsd --replace &.

Last edited by nPHYN1T3 (2021-11-18 11:27:01)


Board footer

Powered by FluxBB