Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-09-16 10:37:45

DemocracyIsPrivacy
Member
Registered: 2021-09-16
Posts: 4

Manjaro Xfce and Inkscape? Grub error: denied, cryptodisk not found

Hi, I'm a freedom software advocate/volunteer in Australia.

I tried to open a new account on the Manjaro forums first but when I click the red Create Account button nothing happens, even with manjaro.org javascript enabled. So I'm here.

I'm not the most technically-minded person, please bear with me.

An HP Intel system with 8GB of various RAMs and a 1TB Hitachi SSD. When I try to boot with the encryption password at the black, grub loader screen with the UUID, I get:

error: access denied
error: no such cryptodisk found
error: disk 'cryptouuid/<UUID>' not found
entering rescue mode....
grub rescue>

• The UUID presented appears to NOT have changed since past (working) UUIDs, I have ways of remembering parts of it. This is what makes me think the keyfile has been corrupted though I'm not sure how to check this, see below.

What I was doing before this happened might be the smoking gun (and why I think Inkscape may have caused this):
----------------------

• Months earlier I needed something very big and was now at 90% disk usage (yes, I know this is not a good position to be in and you want a minimum of a third free wherever possible)...
• Fast-foward to the day before yesterday, I had taken a screendump of a small part of the screen (Ctrl+Shift+PrintScrn) and selected Copy to Clipboard, this worked well. Kudos Xfce team.
• I then brought Inkscape to focus, to paste the image, this is when something went VERY WRONG.
• Inkscape has always gotten progressively worse the longer it is left open but this time it actual froze the o/s,
. - I could move the mouse,
. - A browser window that refreshes every 10 seconds was still visibly refreshing
. - The mouse cursor would not change based on context,
. - Nothing responded to mouse clicks or keyboard,
. - No discernible change in unusual med-high fan noise.
• Waited about 8 minutes
• Concerned about the excessive fan noise I held the power button for 5 seconds to power off and immediately turned it back on,
• Aforementioned grub failure.
• Fan noise occasionally very high during grub password input

I leave my Inkscape open for weeks at a time, because I do design between other tasks. Sometimes Inkscape is open for over a month, I operate as a node in a network so the machine tends to be on all the time. On this occasion inkscape had only been open for about a week.

I'd like this post to also act as an open letter to Inkscape. I may have been slightly behind on updating Inkscape so if this issue (memory or other leak) has been solved in recent months then please disregard this but over the years I have used Inkscape across a number of distros and all of them seem to suffer with this Inkscape issue. It manifests itself as lag when the program is bought back into focus. It doesn't matter whether the open file is a few kilobytes or 20 megabytes. The lag presents itself. I've decided to speak up about this now on this forum because it seems to have finally caused more harm than just the usual time wastage.

A buffer overflow in the wrong place, perhaps?

I love Inkscape and would never suggest anyone stop using it. Having said that my experience leads me to strongly believe Inkscape has a serious zero-day vulnerability/leak. I'm only saying this after years of experience with the software and I don't want to make it sound like I'm blaming the Inkscape team because I think they are wonderful. I'm just imploring my fellow Inkscapers to consider a to prompt to close Inkscape every 12 hours when it is open, until the bug is identified and fixed.

I should also state that I consider myself a Person of Interest to certain entities because I do also dedicate significant efforts to helping others identify injustice and how to reject and limit it. Eg. I have been threatened after a public event where I spoke, just one example. So I can't say I'm not concerned that there's a possibility the system has been targeted by Australia's Identify and Disrupt Bill, recently rushed into law here.

Things tried (in order):
-----------

• Rebooted so many times to re-enter the password, its not even funny.
• Read multiple posts related to this at forum.manjaro.org
• Read other online sources
• Unplugged the system and waited 30 seconds for the green LED to die down,
• Delicately dusted the inside of the computer (while staying grounded), signified the first time the PC has ever been opened in fact, judging by the warranty sticker! It was a bit dusty.
• Did the HDD tests from the BIOS using two tests:
. - one that was instant
. - one that took two minutes (both appear to have completed successfully)
• Tried to access the partition after booting from a live USB
. * Thunar shows the two partitions and '10 GB Encrypted' and '990 GB Encrypted'
. . - when I try to access them (both) the passphrase never works
. * GParted (p/w 'manjaro') shows
. . - /dev/sda1 : [Encrypted] : Size 914.54 GiB : Used 914.54 GiB : Unused 0.00 B : boot
. . - /dev/sda2 : [Encrypted] : Size 8.48 GiB : Used 8.48 GiB : Unused 0.00 B :
. . - unallocated : unallocated : Size 2.67 MiB : Used --- : Unused --- :
. * `lsblk --fs` shows
. . - NAME : FSTYPE : FSVER : LABEL : UUID : FSAVAIL : FSUSE% : MOUNTPOINT
. . - loop0 : squashfs : 4.0 :  :  : 0 : 100% : /run/miso/sfs/livefs
. . - loop1 : squashfs : 4.0 :  :  : 0 : 100% : /run/miso/sfs/mhwdfs
. . - loop2 : squashfs : 4.0 :  :  : 0 : 100% : /run/miso/sfs/desktopfs
. . - loop3 : squashfs : 4.0 :  :  : 0 : 100% : /run/miso/sfs/rootfs
. . - sda : : : : : : :
. . - –sda1 : crypto_LUKS : 1 : : <UUID> : : :
. . - –sda2 : crypto_LUKS : 1 : : <DIFFERENT_UUID> : : :
. . - sr0 : iso9660 : Joliet Extension : MANJARO_XFCE_2003 : <The specific 2020 release> : 0 : 100% : /run/miso/bootmnt

Are there any in-built recovery tools I can delicately try? What to try with the grub recovery prompt?

I do have backups but the last two weeks of work is important. I don't think I ever backed up the HDD encryption key file because I only backup files in the $HOME folder.

Thanks for reading.

EDIT: Please help me feel dumb. Tell me that one simple thing that I should try. Its very late now and I'm going to research grub rescue tomorrow.

Last edited by DemocracyIsPrivacy (2021-09-16 15:48:09)

Offline

#2 2021-09-16 19:33:47

CwF
Member
Registered: 2018-01-28
Posts: 189

Re: Manjaro Xfce and Inkscape? Grub error: denied, cryptodisk not found

Clarify!
Typically grub comes up first, then after selection we would see the prompt to decrypt ?
You suggest some other order. Is there no unencrypted boot partition, I don't see one?

you may need to load luks

grub rescue> insmod luks

if this returns a 'grub_calloc' failure then maybe grub was updated incorrectly?

Offline

#3 2021-09-20 18:18:25

DemocracyIsPrivacy
Member
Registered: 2021-09-16
Posts: 4

Re: Manjaro Xfce and Inkscape? Grub error: denied, cryptodisk not found

Thanks CwF for your response,

There are the usual two prompt-to-decrypt lines before the aforementioned "error: access denied" line. Namely:

Attempting to decrypt master key...
Enter passphrase for hd0,msdos1 (UUID-containing-bits-that-I-remember):

There is no "selection" screen typically, though.

CwF wrote:

Is there no unencrypted boot partition, I don't see one?

There's just the two partitions. 10GB and 990GB as shown in the O/P. Its been rebooting fine until this issue.

Is there something special that I need to do after `insmod luks'. It seems to complete successfully, ie. there are no complaints, you could say, it just gives me a fresh "grub rescue>" line.

The `cryptomount hd0,msdos1' command seems to work, even without loading the luks module. It asks me to attempt to enter the passphrase as expected but alas no matter how many times or how many different passwords I try, I'm always presented with just a single line:

error: access denied

This response seems even more peculiar than the "no disk found". It suggests that I'm getting the p/w wrong, which can't be right.

I've tried entering commands that https://www.gnu.org/software/grub/manual/grub/grub.html says I should have. Basic commands like `sleep', `reboot' and `search' but "grub rescue" is maybe different to (standard) "grub" because I just get Unknown command 'whatever'

Reading documentation for grub is difficult. It's late here, I'm going to be so out of sorts tomorrow it's not funny.

As before if you have any idea please help. I'm feeling more desperate each hour I spend on this.

Offline

#4 2021-09-21 14:13:35

CwF
Member
Registered: 2018-01-28
Posts: 189

Re: Manjaro Xfce and Inkscape? Grub error: denied, cryptodisk not found

I suppose the primary key is corrupted somehow, heard of that, never seen it. Mounting on a another install or live system the only option.

Offline

#5 2021-09-21 18:11:20

DemocracyIsPrivacy
Member
Registered: 2021-09-16
Posts: 4

Re: Manjaro Xfce and Inkscape? Grub error: denied, cryptodisk not found

'"CwF" wrote:

I suppose the primary key is corrupted somehow[. H]eard of that, never seen it.

Confirming my about suspicion. Wonder if there's a way to go back through previous versions of a  file on the partition? Or whether there is any error correction for it that I can harness. A broken key doesn't seem like something that would normally be permitted to occur, even from inkscape pooping itself. I will try to understand from documentation if something can be done.

'"CwF" wrote:

Mounting on (...) another install or live system the only option.

'Mounting' sounds like I might be able to access the contents but if the Primary Key is corrupted I doubt I'll be able, right? For the O/P, I tried to open the partition from a live Thunar, but no p/w attempts worked.

Thanks CwF.

If anyone has extra ideas feel free to send them through. I've done a sizeable amount in the time since the backup so I won't give up too easily..... computers........ love and hate em. Any hackers that are responsible for attacks that might look like this, please just die. People don't need this.

Offline

#6 2021-10-04 15:19:17

DemocracyIsPrivacy
Member
Registered: 2021-09-16
Posts: 4

Re: Manjaro Xfce and Inkscape? Grub error: denied, cryptodisk not found

There's an interesting resource at https://michaelabrahamsen.com/posts/grub-boot-repair/

He suggests...

# STEP 1: boot into live cd

# create rescue folder
sudo mkdir -p /rescue/boot

# in this case the root partition was encrypted
sudo cryptsetup open --type=luks vg0-root /dev/sda5
sudo mount /dev/mapper/vg0-root /rescue/boot
sudo mount /dev/sda1 /rescue/boot

sudo mount --bind /dev /rescue/dev &&
sudo mount --bind /dev /rescue/dev &&
sudo mount --bind /dev/pts /rescue/dev/pts &&
sudo mount --bind /proc /rescue/proc &&
sudo mount --bind /sys /rescue/sys


# chroot 
sudo chroot /rescue
grub-install /dev/sda
grub-install --recheck /dev/sda
update-grub

sudo umount -a

# STEP 2: run the rescue utility
# From the Boot-Repair live cd
sudo mkdir -p /rescue/boot

sudo cryptsetup open --type=luks vg0-root /dev/sda5
sudo mount /dev/mapper/vg0-root /rescue/boot
sudo mount /dev/sda1 /rescue/boot

# at this point you have the encrypted volumes mounted. Now run the Boot Repair utility

I'm not fully in tune how he came up with some of the inputs to the commands. Just reading the man page of cryptsetup, has lead me to think that either inkscape has corrupted the start (?) of the disk where, the key is kept, or I'm a victim or an attack that is locking me out.

Will be exploring backup of the LUKS key for taking a closer look at it and/or for future reference.

Offline

Board footer

Powered by FluxBB