Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-09-21 02:40:12

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Login screen

I recently updated my Ubuntu 21.04, and with that to xfce 4.16. Since then I've not been able to change the lightdm login screen. It is stubbornly a green background with a ugly "circle" icon in the middle. It works ... but, damn, it's ugly.

I've checked a few things and I am definitely running lightdm. So, in the xfce4 settings program I have used the "Lightdm-gtk+ Greeter Settings" program, but it changes nothing.

So, what to use? Is there a text file somewhere to hack?

Offline

#2 2021-09-21 10:49:28

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: Login screen

Let's confirm the display manager. Can you post back the results of:

grep '/usr/s\?bin' /etc/systemd/system/display-manager.service

If it does reply as lightdm, can you post back the contents of /etc/lightdm/lightdm.conf (this is the configuration file for lightdm)? Lets see what "greeter-session" is set to.

Offline

#3 2021-09-21 16:39:29

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Re: Login screen

Yes, last week I went though those files and didn't see anything that made sense to me. So, here it all is:

bob$ grep '/usr/s\?bin' /etc/systemd/system/display-manager.service
ExecStart=/usr/sbin/lightdm

[09:31 AM ~] bob$ cat /etc/lightdm/lightdm.conf
[Seat:*]
allow-guest=false
greeter-hide-users=false
greeter-show-manual-login=true

No greeter. Hmmm, I have some greeter files in /etc/lightdm, namely

ls -R
.:
lightdm.conf  lightdm.conf.d  lightdm-gtk-greeter.conf  slick-greeter.conf  users.conf

./lightdm.conf.d:
50_budgie-desktop.conf  90-arctica-greeter.conf  91-arctica-greeter-mate.conf

Hope this makes sense to you!

BTW, how do you make sections of code on this forum? I see nothing about any kind of formatting at all.

Offline

#4 2021-09-21 20:12:41

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: Login screen

Mellowbob wrote:

Yes, last week I went though those files and didn't see anything that made sense to me. So, here it all is:

bob$ grep '/usr/s\?bin' /etc/systemd/system/display-manager.service
ExecStart=/usr/sbin/lightdm

Yes, it is lightdm.

[09:31 AM ~] bob$ cat /etc/lightdm/lightdm.conf
[Seat:*]
allow-guest=false
greeter-hide-users=false
greeter-show-manual-login=true

No greeter. Hmmm, I have some greeter files in /etc/lightdm, namely

Strange. You should have a:

greeter-session=lightdm-gtk-greeter

...in the "[Seat:*]" section. I believe this is needed if you have more than one greeter installed.

BTW, how do you make sections of code on this forum? I see nothing about any kind of formatting at all.

You would use [ c o d e ] [ / c o d e ] tags (no spaces). See: https://forum.xfce.org/help.php#bbcode

Offline

#5 2021-09-21 21:17:05

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Re: Login screen

Thanks, much better.

But ... I still can't seem to change anything from the new default. I now have the proper conf file:

bob$ cat lightdm.conf
[Seat:*]
allow-guest=false
greeter-hide-users=false
greeter-show-manual-login=true
greeter-session=lightdm-gtk-greeter

And there is a lightdm-gtk-greeter file:

bob$ cat lightdm-gtk-greeter.conf
[greeter]
background = /usr/share/backgrounds/Wall_with_door_on_Gozo_by_Matthias_Niess.jpg
theme-name = Bluebird
font-name = Ubuntu 13

But, this doesn't seem to be read. Should it perhaps be in the lightdm-conf.d directory? I think the GUI to edit the login auto-created the file I have now.


The screen I now have shows a photo with pillars. Can't find the photo's home ... but it's on my drive "somewhere" smile

Offline

#6 2021-09-21 22:18:43

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: Login screen

If you install lightdm-gtk-greeter-settings, you will get a gui to configure things.

Offline

#7 2021-09-22 00:27:16

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Re: Login screen

I had lightdm-gtk-greeter-settings installed. It's an option in the xfce settings manager. Running it from a terminal works the same.

I have cleaned up my lightdm directory. It now only has the lightdm.conf and users.conf files and a lightdm.conf.d directory. The single file in there is the file 10_lightdm-gtk-greeter.conf. The settings editor will find this file and modify it. No problem there.

But, when the login is presented it appears that the image I request is displayed for a second and then lightdm loads a different image. I have no idea where lightdm is getting the idea that my image is no good (it is fine!) or where it is getting the filename for its choice.

The man page for lightdm doesn't show any other files for config. I also read https://wiki.ubuntu.com/LightDM and that's not helping either.

Ideas?

Offline

#8 2021-09-22 01:23:36

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: Login screen

Maybe it's using AccountsService. Look at your config file in /var/lib/AccountsService/users.

Offline

#9 2021-09-22 03:14:35

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Re: Login screen

ToZ wrote:

Maybe it's using AccountsService. Look at your config file in /var/lib/AccountsService/users.

Yes, it is.

bob$ sudo systemctl status accounts-daemon 
● accounts-daemon.service - Accounts Service
     Loaded: loaded (/lib/systemd/system/accounts-daemon.service; disabled; vendor preset>
     Active: active (running) since Tue 2021-09-21 20:09:34 MST; 59s ago
   Main PID: 32049 (accounts-daemon)
      Tasks: 3 (limit: 9294)
     Memory: 3.5M
     CGroup: /system.slice/accounts-daemon.service
             └─32049 /usr/lib/accountsservice/accounts-daemon

Sep 21 20:09:34 Mellowood systemd[1]: Starting Accounts Service...
Sep 21 20:09:34 Mellowood accounts-daemon[32049]: started daemon version 0.6.55
Sep 21 20:09:34 Mellowood systemd[1]: Started Accounts Service.

And, trying to disable that seems to be a hard thing to do smile I have tried both (as root, of course) "systmctl stop accountd-daemon" and "disable...", but I have a feeling that the service is restarting itself. This is getting a bit deep for me. But, looking at the files in /var/lib/AccountsService/users it certainly doesn't appear to have any of the images I'm seeing.

BTW, the image I'm seeing is (apparently) chosen at random at BOOT time ... simply restarting lightdm from a VT using "sudo killall lightdm" restarts lightdm, but the same image is displayed.

Offline

#10 2021-09-22 11:26:11

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: Login screen

Is the image you are trying to use located in your home directory? If so, lightdm won't have access to it (lightdm runs under another process) so perhaps if that is the case, it then uses another image (maybe from /usr/share/backgrounds)? If so, try copying your background image (or use one from /usr/share/backgrounds) and see if that works.

Offline

#11 2021-09-22 16:21:14

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Re: Login screen

The conf file has:

background = /usr/share/backgrounds/there_is_something_human_in_that_stuff_by_Pierre_Cante.jpg

(And, yes, I've tried other images as well). The file is one which must have been installed by the system, not me.

And, the file is readable:

rw-r--r-- 1 root root 1500168 Mar 24 15:09 /usr/share/backgrounds/there_is_something_human_in_that_stuff_by_Pierre_Cante.jpg

Also, lightdm is finding and displaying the file. But after a second or less it displays it's own choice of an image. Maybe it is haunted smile

All this started when I ungraded my Ubuntu from 20.11 to 21.04.

Offline

#12 2021-09-22 22:15:28

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: Login screen

Can you post back the contents of the following files:
- /var/log/lightdm/x-0.log
- /var/log/lightdm/lightdm.log
- /var/log/lightdm/seat0-greeter.log

Maybe there is something in there that will show what is happening.

Offline

#13 2021-09-22 23:21:51

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Re: Login screen

Okay. First off x-0.log:

X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
Build Operating System: linux Ubuntu
Current Operating System: Linux Mellowood 5.11.0-36-generic #40-Ubuntu SMP Fri Sep 17 18:15:22 UTC 2021 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.11.0-36-generic root=UUID=a2ad0af8-bcbb-471b-9162-0e0199304be0 ro quiet splash vt.handoff=7
Build Date: 06 July 2021  10:17:51AM
xorg-server 2:1.20.11-1ubuntu1.1 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.40.0
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 22 16:15:24 2021
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

..........
bob$ sudo cat seat0-greeter.log
** Message: 16:15:25.499: Starting lightdm-gtk-greeter 2.0.8 (Jan  6 2021, 12:50:01)
** Message: 16:15:25.504: [Configuration] Reading file: /usr/share/lightdm/lightdm-gtk-greeter.conf.d/01_ubuntu.conf
Excess arguments.

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.166: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.439: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.466: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.495: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.523: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.551: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.579: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.607: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.635: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.664: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.692: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.720: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.748: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.777: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.805: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.833: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.861: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.890: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.919: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:26.942: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:224033): Gtk-WARNING **: 16:15:37.421: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

** (lightdm-gtk-greeter:224033): WARNING **: 16:15:37.467: [PIDs] Failed to terminate process #224090: No such process

** (lightdm-gtk-greeter:224033): WARNING **: 16:15:37.467: [PIDs] Failed to terminate process #224088: No such process

.......

I don't have a /var/log/lightdm/lightdm.log.

Offline

#14 2021-09-23 02:52:13

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: Login screen

Can you post the output of:

ls -lt /var/log/lightdm

...and the contents of the /usr/share/lightdm/lightdm-gtk-greeter.conf.d/01_ubuntu.conf file?

Offline

#15 2021-09-23 16:11:22

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Re: Login screen

Ahh, we might be getting closer?

# Ubuntu specific defaults
#

[greeter]
background=/usr/share/backgrounds/warty-final-ubuntu.png
theme-name=Ambiance
icon-theme-name=LoginIcons
font-name=Ubuntu 11
xft-antialias=true
xft-dpi=96
xft-hintstyle=slight
xft-rgba=rgb
indicators=~host;~spacer;~session;~language;~a11y;~clock;~power;
clock-format=%d %b, %H:%M


I will try changing things in this to see if it changes anything later tonight.

Offline

#16 2021-09-23 17:03:31

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: Login screen

I think so. You might want to delete that file and see if it helps.

Offline

#17 2021-09-23 17:11:33

peter.48
Member
Registered: 2017-01-31
Posts: 106

Re: Login screen

Have you simply checked if lightdm.service starts up? because if you were testing several DMs, you normally have to manually start the service with

#systemctl start lightdm.service 

Offline

#18 2021-09-25 01:56:59

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Re: Login screen

ToZ wrote:

I think so. You might want to delete that file and see if it helps.

No difference. Somehow lightdm is finding an instruction to display a different image, and to set its own options in the screen. Now, the odd part of this is that the background image to display is chosen at boot ... if I (from a VT) do "sudo killall lightdm" the current lightdm is terminated and a new one starts, but with the same image. Rebooting selects a different image.

I think I'm outliving my welcome here on this ... if nothing else comes up I'll file a bug report with the lightdm folks.

Offline

#19 2021-09-25 02:01:52

Mellowbob
Member
Registered: 2011-10-16
Posts: 278

Re: Login screen

peter.48 wrote:

Have you simply checked if lightdm.service starts up? because if you were testing several DMs, you normally have to manually start the service with

#systemctl start lightdm.service 

Yes, unfortunately, it is smile Just to verify I just did:

 bob$ systemctl -a | grep -i lightdm
  lightdm.service       loaded    active   running   Light Display Manager

Thanks.

Offline

#20 2022-06-15 18:49:47

sh1n0bi
Member
Registered: 2022-06-15
Posts: 2

Re: Login screen

i got around the same problem;

in the /var/lib/AccountsService/users folder you'll have a config file for Bob

as sudo, comment out the line that sets the background image with a #

save and reboot.

Offline

#21 2022-06-15 19:07:33

sh1n0bi
Member
Registered: 2022-06-15
Posts: 2

Re: Login screen

- actually that only worked for the first reboot, after that the file seemed to revert, and the problem returned!

Offline

Board footer

Powered by FluxBB