Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-10-04 15:24:29

gurunixx@gmail.com
Member
Registered: 2021-10-04
Posts: 4

Fedora 33, /usr/lib/systemd/user/xfce4-notifyd.service is gone

I can't find any explanation for this. It's in Fedora RPM for f31, and f32 - but it's gone in f33. Where is it now?

Present: https://rpm.pbone.net/info_idpl_7018984 … 4.rpm.html
Present: https://rpm.pbone.net/info_idpl_7036596 … 4.rpm.html (update?!)
MISSING: https://rpm.pbone.net/info_idpl_7223449 … 4.rpm.html

I searched changelogs for XFCE4 (at https://xfce.org/download/changelogs ) and found nothing. No mention at all.

Is this Fedora-specific? I thought I'd ask here first.

Offline

#2 2021-10-04 16:11:56

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: Fedora 33, /usr/lib/systemd/user/xfce4-notifyd.service is gone

Hello and welcome.

See: https://forum.xfce.org/viewtopic.php?id=14740.
This would be the commit.

Offline

#3 2021-10-04 16:22:41

gurunixx@gmail.com
Member
Registered: 2021-10-04
Posts: 4

Re: Fedora 33, /usr/lib/systemd/user/xfce4-notifyd.service is gone

I installed notification-daemon.x86_64 and it works with my custom wrapper - bold, italic, etc from CSS works fine. Only difference? There's no systemd service definition, so you either need to make one or create a ".desktop" file in ~/.config/autostart so it starts when you login.

I'd used this daemon a few years ago - but it would 'die' - theoretically it would re-activate any time a DBUS message was sent to it - but it didn't work. I ended up having to write a shell program that restarted the turd when it died - I surely do hope it does not work that way this time around. Else I will find some other solution...

It's just annoying that after upgrade from f32 to f33, notifications just quit. No explanation...

Would be nice to know WHAT happened, for others who might go through what I've just gone through. Lost an hour or more to this one - a petty, minor annoyance, at best. UGH.

Offline

#4 2021-10-04 16:32:34

gurunixx@gmail.com
Member
Registered: 2021-10-04
Posts: 4

Re: Fedora 33, /usr/lib/systemd/user/xfce4-notifyd.service is gone

ToZ wrote:

Hello and welcome.

See: https://forum.xfce.org/viewtopic.php?id=14740.
This would be the commit.

That's interesting but not relevant - my problem isn't that the service won't start or any D-BUS problem(s) - the service itself is 'gone':

> l /etc/systemd/system/xfce4-notifyd.service
lrwxrwxrwx 1 root root 43 2020-07-26 15:54 /etc/systemd/system/xfce4-notifyd.service -> /usr/lib/systemd/user/xfce4-notifyd.service
> l /usr/lib/systemd/user/xfce4-notifyd.service
/bin/ls: cannot access '/usr/lib/systemd/user/xfce4-notifyd.service': No such file or directory

The link in /etc is how systemd 'enables' a service. But you already knew that...

I restored that service file from a backup - but it's only one file, which is not enough to define the service. So systemctl reported errors when I attempted to start it. No, they completely removed the systemd service definition in f33.  Those pbone links are nice because they list all the files included in each version - look for '.service' in f32/f32/f33 pages I listed. Only f33 is missing the service definition :-(

Thanks for looking at this, though.

Offline

#5 2021-10-04 17:27:14

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: Fedora 33, /usr/lib/systemd/user/xfce4-notifyd.service is gone

Its not installed because by default it is no longer being built unless the "-enable-dbus-start-daemon" parameter is passed during the build of the app. I'll assume that fedora is not using this parameter during the build since there is no service file.

Last edited by ToZ (2021-10-04 17:27:55)

Offline

#6 2021-10-04 18:29:01

gurunixx@gmail.com
Member
Registered: 2021-10-04
Posts: 4

Re: Fedora 33, /usr/lib/systemd/user/xfce4-notifyd.service is gone

ToZ wrote:

Its not installed because by default it is no longer being built unless the "-enable-dbus-start-daemon" parameter is passed during the build of the app. I'll assume that fedora is not using this parameter during the build since there is no service file.

That helps with understanding. Now with this thread, others who stumble on this will find their own answers. I hope. I'll leave the topic along as that's what I was searching for......

Thanks muchly.

Offline

Board footer

Powered by FluxBB