Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-10-04 13:36:10

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

XFCE 4.14/16 black screen after idle or suspend

Hi,
I'm having trouble with having only a black screen and a cursor after coming from suspend or idle. It happens both before and after entering my password, but the latter is more frequent. I'm running both Display power management and Xscreensaver (DPM shuts my screen off and Xscreensaver prevents idle blackout if I'm watching something in fullscreen). That started to happen very often recently, after upgrading XFCE from 4.14 to 4.16 (and then reverting back with timeshift).
EDIT: I've also noticed that blanking the screen and quickly waking it up makes the screen grey, but with same effect.

I have looked up stuff online, but afaik turning off either screensaving option did not change anything. I have also briefly checked posts here, very similiar to mine, but no luck.
My only recovery if that happens is tty and restart lightdm.service, but that's tedious and shuts down my session anyways... Can anyone please help?

I'm running Toshiba Satellite Pro C50 with i5-3230m, 8GB RAM, Intel HD 4000.

Last edited by pizzacutter (2021-10-04 17:50:26)

Offline

#2 2021-10-04 21:56:25

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: XFCE 4.14/16 black screen after idle or suspend

What would be helpful here are log files around the suspend time. You don't mention the distro that you are using, but if it is systemd based, then journalctl would be what you are looking for.

Also, are you using the intel video driver or just the one build into the kernel?

Offline

#3 2021-10-05 08:51:52

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

Hi,
I'm using Xubuntu 20.04 so I think it's systemd.
Since the last edit on my post I have turned off the Xscreensaver and kept the lock function, so far it seems to work okay, I'll update if it goes wrong again.

ToZ wrote:

Also, are you using the intel video driver or just the one build into the kernel?

It should be the kerner driver as there's nothing in "Additional drivers" tab in software & updates.

Last edited by pizzacutter (2021-10-05 09:18:12)

Offline

#4 2021-10-06 12:58:07

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

Alright, it's happened again.
Should I access journalctl right after switch to a different TTY or after restarting lightdm.service?
I'm not quite sure if that makes a difference.

Offline

#5 2021-10-06 17:07:09

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: XFCE 4.14/16 black screen after idle or suspend

Probably after it happens, then prune out all entries about 30 seconds before and 30 seconds after and post them back here.

Offline

#6 2021-10-07 17:45:19

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

Alright, here it is, quite long to be honest. (I have censored some stuff with "...")
Looking at this, I'm not sure there is much use, but let's see.
It's everything from what looks like suspend activation to me logging into the tty3.

okt 07 15:18:18 Xubuntu-TOSHIBA systemd-sleep[5263]:  setting standby to 36 (3 minutes)
okt 07 15:18:18 Xubuntu-TOSHIBA systemd[1]: systemd-suspend.service: Succeeded.
okt 07 15:18:18 Xubuntu-TOSHIBA systemd[1]: Finished Suspend.
okt 07 15:18:18 Xubuntu-TOSHIBA systemd[1]: Stopped target Sleep.
okt 07 15:18:18 Xubuntu-TOSHIBA systemd[1]: Reached target Suspend.
okt 07 15:18:18 Xubuntu-TOSHIBA systemd[1]: Stopped target Suspend.
okt 07 15:18:18 Xubuntu-TOSHIBA systemd-logind[1139]: Operation 'sleep' finished.
okt 07 15:18:18 Xubuntu-TOSHIBA audit[1104]: USER_AVC pid=1104 uid=103 auid=4294967295 ses=4294967295 subj=unconfined msg='apparmor="DENIED" operation="dbus_signal"  bus="system" path="/org/freedesktop/login1" interface="org.freedesktop.login1.Manager" member="PrepareForSleep" name=":1.15" mask="receive" pid=1758 label="snap.bluemail.bluemail" peer_pid=1139 peer_label="unconfined"
                                              exe="/usr/bin/dbus-daemon" sauid=103 hostname=? addr=? terminal=?'
okt 07 15:18:18 Xubuntu-TOSHIBA ModemManager[1194]: <info>  [sleep-monitor] system is resuming
okt 07 15:18:18 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612698.6480] manager: sleep: wake requested (sleeping: yes  enabled: yes)
okt 07 15:18:18 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612698.6482] device (enp3s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
okt 07 15:18:18 Xubuntu-TOSHIBA kernel: audit: type=1107 audit(1633612698.643:72): pid=1104 uid=103 auid=4294967295 ses=4294967295 subj=unconfined msg='apparmor="DENIED" operation="dbus_signal"  bus="system" path="/org/freedesktop/login1" interface="org.freedesktop.login1.Manager" member="PrepareForSleep" name=":1.15" mask="receive" pid=1758 label="snap.bluemail.bluemail" peer_pid=1139 peer_label="unconfined"
                                         exe="/usr/bin/dbus-daemon" sauid=103 hostname=? addr=? terminal=?'
okt 07 15:18:18 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612698.6523] device (wlp2s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
okt 07 15:18:18 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612698.6725] device (p2p-dev-wlp2s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
okt 07 15:18:18 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612698.6732] manager: NetworkManager state is now DISCONNECTED
okt 07 15:18:18 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612698.7294] sup-iface[0x56497a1f0a00,wlp2s0]: supports 4 scan SSIDs
okt 07 15:18:18 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612698.7304] device (wlp2s0): supplicant interface state: starting -> ready
okt 07 15:18:18 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612698.7305] device (p2p-dev-wlp2s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
okt 07 15:18:18 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612698.7310] device (wlp2s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
okt 07 15:18:19 Xubuntu-TOSHIBA upowerd[1638]: treating change event as add on /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.6981] policy: auto-activating connection '...' (...)
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.6991] device (wlp2s0): Activation: starting connection '...' (...)
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.6993] device (wlp2s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7000] manager: NetworkManager state is now CONNECTING
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7006] device (wlp2s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7012] device (wlp2s0): Activation: (wifi) access point '...' has security, but secrets are required.
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7013] device (wlp2s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7066] device (wlp2s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7072] device (wlp2s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7078] device (wlp2s0): Activation: (wifi) connection '...' has security, and secrets exist.  No new secrets needed.
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7078] Config: added 'ssid' value '...'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7079] Config: added 'scan_ssid' value '1'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7079] Config: added 'bgscan' value 'simple:30:-65:300'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7079] Config: added 'key_mgmt' value 'WPA-EAP WPA-EAP-SHA256 FT-EAP FT-EAP-SHA384'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7079] Config: added 'password' value '<hidden>'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7080] Config: added 'eap' value 'PEAP'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7080] Config: added 'fragment_size' value '1266'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7080] Config: added 'phase2' value 'auth=MSCHAPV2'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7080] Config: added 'ca_cert' value '/etc/ssl/certs/DigiCert_Assured_ID_Root_CA.pem'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7080] Config: added 'identity' value '...'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7081] Config: added 'anonymous_identity' value '...'
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7081] Config: added 'proactive_key_caching' value '1'
okt 07 15:18:19 Xubuntu-TOSHIBA kernel: wlp2s0: authenticate with ...
okt 07 15:18:19 Xubuntu-TOSHIBA wpa_supplicant[1142]: wlp2s0: SME: Trying to authenticate with ... (SSID='...' freq=2437 MHz)
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7279] device (wlp2s0): supplicant interface state: ready -> authenticating
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7282] device (p2p-dev-wlp2s0): supplicant management interface state: ready -> authenticating
okt 07 15:18:19 Xubuntu-TOSHIBA kernel: wlp2s0: send auth to ... (try 1/3)
okt 07 15:18:19 Xubuntu-TOSHIBA wpa_supplicant[1142]: wlp2s0: Trying to associate with ... (SSID='...' freq=2437 MHz)
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7359] device (wlp2s0): supplicant interface state: authenticating -> associating
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7360] device (p2p-dev-wlp2s0): supplicant management interface state: authenticating -> associating
okt 07 15:18:19 Xubuntu-TOSHIBA kernel: wlp2s0: authenticated
okt 07 15:18:19 Xubuntu-TOSHIBA kernel: wlp2s0: associate with ... (try 1/3)
okt 07 15:18:19 Xubuntu-TOSHIBA wpa_supplicant[1142]: wlp2s0: Associated with ...
okt 07 15:18:19 Xubuntu-TOSHIBA wpa_supplicant[1142]: wlp2s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
okt 07 15:18:19 Xubuntu-TOSHIBA kernel: wlp2s0: RX AssocResp from ... (capab=0x431 status=0 aid=1)
okt 07 15:18:19 Xubuntu-TOSHIBA kernel: wlp2s0: associated
okt 07 15:18:19 Xubuntu-TOSHIBA wpa_supplicant[1142]: wlp2s0: CTRL-EVENT-EAP-STARTED EAP authentication started
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7498] device (wlp2s0): supplicant interface state: associating -> associated
okt 07 15:18:19 Xubuntu-TOSHIBA NetworkManager[1105]: <info>  [1633612699.7499] device (p2p-dev-wlp2s0): supplicant management interface state: associating -> associated
okt 07 15:18:19 Xubuntu-TOSHIBA wpa_supplicant[1142]: wlp2s0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
okt 07 15:18:19 Xubuntu-TOSHIBA wpa_supplicant[1142]: wlp2s0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
okt 07 15:18:21 Xubuntu-TOSHIBA ModemManager[1194]: <info>  [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:1c.1/0000:02:00.0': not supported by any plugin
okt 07 15:18:21 Xubuntu-TOSHIBA ModemManager[1194]: <info>  [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:1c.2/0000:03:00.0': not supported by any plugin
okt 07 15:18:24 Xubuntu-TOSHIBA xfce4-screensaver-dialog[5284]: gkr-pam: unlocked login keyring
okt 07 15:18:32 Xubuntu-TOSHIBA systemd[1]: Started Getty on tty3.

Last edited by pizzacutter (2021-10-07 17:47:08)

Offline

#7 2021-10-07 18:21:20

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: XFCE 4.14/16 black screen after idle or suspend

In your original post, you indicate that you are using Xscreensaver, but in the log file above there is mention of xfce4-screensaver.

Can you confirm which you are using? Perhaps both are active and its a matter of disabling or removing one of them (xfce4-screensaver)?

Offline

#8 2021-10-07 18:55:50

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

I have turned off Xscreensaver as far as screen saving animations go, but I've kept the "Enable Lock Screen" option checked in "Lock Screen" tab of Xscreensaver.

Offline

#9 2021-10-07 19:26:25

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: XFCE 4.14/16 black screen after idle or suspend

If xfce4-screensaver running?

ps -ef | grep screensaver

Offline

#10 2021-10-07 19:36:24

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

Yep, it is. I suppose I'll turn that off and see what happens. Can I maintain screen locking when the display turns off?

Offline

#11 2021-10-07 19:57:35

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: XFCE 4.14/16 black screen after idle or suspend

Try disabling and/or uninstalling xfce4-screensaver if you are not using it. Re-enable Xscreensaver to get back to your previous functionality/setup and see if that makes a difference.

Offline

#12 2021-10-07 20:21:42

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

I have replaced it with light-locker and the effect is so far pretty much as desired. Coming from an idle or a suspend still leaves black screen after entering my password BUT it seems to go away when I move the cursor.

I'll update if anything changes, but thank you so far smile

Last edited by pizzacutter (2021-10-07 20:22:19)

Offline

#13 2021-10-08 09:07:22

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

Nope, I has happened again sad

Meanwhile I have set some lines in /etc/systemd/logind.conf like #HandlePowerKey to ignore (keyboard stopped responding and it keeps stopping responding after login) and also turned off udisk2 support in psensor (I was being asked for authentication almost every login).

Although this time, the cursor had that text-selection icon instead of regular one. Any other ideas what might be wrong? It seems that changing something around screensaving fixes the problem for roughly 1 or 2 days and is rather random.

Last edited by pizzacutter (2021-10-08 09:16:34)

Offline

#14 2021-10-08 11:14:08

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: XFCE 4.14/16 black screen after idle or suspend

After a fresh reboot and login, can you post back the results of:

ps -ef | grep -i screensaver

Offline

#15 2021-10-08 12:05:27

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

There's the screensaver (although it's from xfce).

xpizza      2234    2103  0 13:50 ?        00:00:00 /usr/bin/xfce4-screensaver --no-daemon
xpizza      3758    3744  0 14:03 pts/0    00:00:00 grep --color=auto -i screensaver

As a bonus, Bluetooth got trashed by what appears to be (I know it isn't) uninstalling xfce4-screensaver. It just doesn't turn on and it says that bluetooth daemon is not started (refuses to be started manually)

Last edited by pizzacutter (2021-10-08 14:11:02)

Offline

#16 2021-10-08 15:10:49

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: XFCE 4.14/16 black screen after idle or suspend

for your original issue, if you've uninstalled xfce4-screensaver, try re-installing/enabling xscreensaver again. I think your original issue had some to do with running 2 screensavers.

As for bluetooth, when you uninstalled xfce4-screensaver, did any other packages get uninstalled as well? Also, what does the following say:

sudo systemctl status bluetooth --no-pager -l

Offline

#17 2021-10-08 16:49:29

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

sudo systemctl status bluetooth --no-pager -l

says it's running alright. It seems to have fixed itself (?), and to note, I have rebooted a few times to check. Perhaps it's related to something else like power saver. I wonder, may Slimbook battery saver cause some of these weird troubles like black screen? It's related in my opinion.

Last edited by pizzacutter (2021-10-08 17:07:55)

Offline

#18 2021-10-08 18:09:23

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: XFCE 4.14/16 black screen after idle or suspend

pizzacutter wrote:

I wonder, may Slimbook battery saver cause some of these weird troubles like black screen? It's related in my opinion.

Perhaps you could uninstall it and see if the problem resolves itself?

Offline

#19 2021-10-09 09:35:25

pizzacutter
Member
Registered: 2021-10-02
Posts: 12

Re: XFCE 4.14/16 black screen after idle or suspend

It seems like neither the xfce4-screensaver nor slimbook battery saver have anything to do with my problem. I wonder what else may have gone wrong.
Before the problems started, I have updated xfce using

sudo add-apt-repository ppa:xubuntu-dev/staging
#and 
sudo apt full-upgrade

but I have reverted afterwards with timeshift to a few days before. To be honest, the only thing that I can think of is some sort of mess left by the update-restore move.

Last edited by pizzacutter (2021-10-09 09:36:23)

Offline

Board footer

Powered by FluxBB