Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-11-19 19:57:22

bjoern
Member
Registered: 2021-11-16
Posts: 7

Status Tray doesn't show all tray icons

Hi all,

I use XFCE 4.16 in Debian stable. The status tray plugin doesn't show all tray icons. The settings if the status tray plugin shows all programs:

Screenshot-from-2021-11-19-20-48-11.png

But on the tray area I only see the network manager and Nextcloud, all the others are not visible.

I also tried the indicator plugin instead of the status tray plugin. With the indicator plugin I see all tray icons but not the network manager. So both solutions are not really satisfying.


Any ideas?

Thanks!
Björn

Offline

#2 2021-11-19 22:19:57

CwF
Member
Registered: 2018-01-28
Posts: 189

Re: Status Tray doesn't show all tray icons

Try the 'Notification Area' instead.

Offline

#3 2021-11-19 23:23:21

bjoern
Member
Registered: 2021-11-16
Posts: 7

Re: Status Tray doesn't show all tray icons

I can't find a "notification aera" plugin. Do you know then package I have to install? The only additional plugin I could find was "xfce4-sntray-plugin" but this one also misses the network manager icon

Offline

#4 2021-11-20 00:47:56

CwF
Member
Registered: 2018-01-28
Posts: 189

Re: Status Tray doesn't show all tray icons

It's not a separate package, but internal. On a panel, add new items and select from that list. Should be there.

Offline

#5 2021-11-20 05:01:51

KBar
Member
Registered: 2021-11-05
Posts: 82

Re: Status Tray doesn't show all tray icons

This post might be of help to you.

Offline

#6 2021-11-21 13:31:59

bjoern
Member
Registered: 2021-11-16
Posts: 7

Re: Status Tray doesn't show all tray icons

KBar wrote:

This post might be of help to you.

I think that's not the same. As you can see in my screenshot above all programs are listed in the system tray plugin settings but they don't show up.

What I now also noticed, while playing around by adding/removing stuff from the autostart and re-login I manged that almost all apps showed up (one or two are always missing). But for each re-login this can change. First I thought that it might be a timing issue. That apps are sometimes loaded before the tray icon plugin and therefore they don't show up.

But than starting the missed app later from the terminal should add them to the tray area but this doesn't happens too. sad

I tried with Signal, which sometimes shows up on login and sometimes not. If it is not in the systray and I start it from the terminal I get this messages:

{"level":30,"time":"2021-11-21T13:27:25.805Z","pid":4955,"hostname":"foo","msg":"System tray service: created"}
{"level":30,"time":"2021-11-21T13:27:25.805Z","pid":4955,"hostname":"foo","msg":"System tray service: updating main window. Previously, there was not a window, and now there is"}
{"level":30,"time":"2021-11-21T13:27:25.805Z","pid":4955,"hostname":"foo","msg":"System tray service: rendering no tray"}
{"level":30,"time":"2021-11-21T13:27:25.805Z","pid":4955,"hostname":"foo","msg":"System tray service: enabling"}
{"level":30,"time":"2021-11-21T13:27:25.805Z","pid":4955,"hostname":"foo","msg":"System tray service: rendering the tray"}
{"level":30,"time":"2021-11-21T13:27:25.805Z","pid":4955,"hostname":"foo","msg":"System tray service: creating the tray"}

All quite strange.

Last edited by bjoern (2021-11-21 13:41:10)

Offline

#7 2021-11-21 17:50:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,300

Re: Status Tray doesn't show all tray icons

Is there any commonality among the programs that don't work? Like are they all QT-based?

Do any of these bug reports look like they are related:
- https://gitlab.xfce.org/xfce/xfce4-panel/-/issues/102
- https://gitlab.xfce.org/xfce/xfce4-panel/-/issues/243
- https://gitlab.xfce.org/xfce/xfce4-panel/-/issues/450

Offline

#8 2021-11-22 08:51:29

bjoern
Member
Registered: 2021-11-16
Posts: 7

Re: Status Tray doesn't show all tray icons

ToZ wrote:

Is there any commonality among the programs that don't work? Like are they all QT-based?

Unfortunately not.

The programs which fail most of the time are:

* Telegram (afaik Qt, but not installed with a package manager  but with their setup script in my home-directory)
* Signal (Electron)
* Element (Electron)

Programs which work most of the time:

* Nextcloud (Qt)
* keepassXC (Qt)
* Network Manager Applet (Gtk)

Offline

#9 2021-11-22 09:19:01

KBar
Member
Registered: 2021-11-05
Posts: 82

Re: Status Tray doesn't show all tray icons

What if you tick the boxes under Status Notifiers? Will they (re)appear in Systray Icons?

Offline

#10 2021-11-22 11:41:23

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,300

Re: Status Tray doesn't show all tray icons

You can also run the systray panel plugin in debug mode. Since this happens on login, we'll need to get creative.

  1. Create the file /usr/local/bin/xfce4-panel

  2. Add the following content:

    #!/bin/sh
    export PANEL_DEBUG=systray
    PANEL_DEBUG=systray /usr/bin/xfce4-panel > ~/.xfce4-panel.log 2>&1
  3. make the file executable

  4. log out and back in again

If the icons are missing, have a look at, and feel free to post back, the contents of ~/.xfce4-panel.log. Maybe something in the log file to identify the issue.

Offline

#11 2021-11-23 20:41:29

bjoern
Member
Registered: 2021-11-16
Posts: 7

Re: Status Tray doesn't show all tray icons

Hi ToZ,

I tried what you suggested. The panel and the whole system loads way slower during login but at the end all tray icons are there. Which brings me back to the idea I had before that it might be a race condition issue when the program gets started before the tray icon applet is added to the panel. But it makes sense only particularly. Because if a tray icon is not added correctly during login I can kill and re-start the application as often as I want and it doesn't get added to the tray area. If it would be a race condition at login time, all apps should always show up on the tray applet if I start them manually from a running system.

After multiple re-boots and re-logins where all icons where shown I remove the manually created xfce4-panel file again. Re-boot and some tray icons are missed again.

That's the log during the "succesfull" logins:

$ cat .xfce4-panel.log 
xfce4-panel(main): version 4.16.2 on gtk+ 3.24.24 (3.24.24), glib 2.66.8 (2.66.7)

(xfce4-panel:1862): xfce4-panel-CRITICAL **: 21:34:30.258: Name org.xfce.Panel lost on the message dbus, exiting.
xfce4-panel(systray): socket networkmanager applet[0x5561c9b86710] (composited=true, relative-bg=false
xfce4-panel(systray): added networkmanager applet[0x5561c9b86710] icon
xfce4-panel(systray): requested cells=1, rows=1, row_size=16, children=1
xfce4-panel(systray): allocate rows=1, icon_size=16, w=16, h=26, horiz=true, border=0
xfce4-panel(systray): allocated ibus panel[0x5561c9b86230] at (0,5;16,16)
xfce4-panel(systray): allocated networkmanager applet[0x5561c9b86710] at (-9999,-9999;16,16)
xfce4-panel(systray): requested cells=2, rows=1, row_size=16, children=2
xfce4-panel(systray): allocate rows=1, icon_size=16, w=34, h=26, horiz=true, border=0
xfce4-panel(systray): allocated ibus panel[0x5561c9b86230] at (0,5;16,16)
xfce4-panel(systray): allocated networkmanager applet[0x5561c9b86710] at (18,5;16,16)

(wrapper-2.0:1817): Gtk-CRITICAL **: 21:34:34.010: gtk_widget_set_accel_path: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed

(wrapper-2.0:1817): Gtk-CRITICAL **: 21:34:34.011: gtk_widget_add_accelerator: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed

(wrapper-2.0:1817): Gtk-CRITICAL **: 21:34:34.014: gtk_widget_set_accel_path: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed

(wrapper-2.0:1817): Gtk-CRITICAL **: 21:34:34.014: gtk_widget_add_accelerator: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed
xfce4-panel(main): terminate panel for session manager
xfce4-panel(application): saving /panels/panel-1: ids=false, providers=true
xfce4-panel(application): saving /panels/panel-2: ids=false, providers=true
xfce4-panel(external): whiskermenu-24: plugin unrealized; quitting child
xfce4-panel(external): pulseaudio-8: plugin unrealized; quitting child
xfce4-panel(external): power-manager-plugin-9: plugin unrealized; quitting child
xfce4-panel(external): notification-plugin-10: plugin unrealized; quitting child
xfce4-panel(external): xfce4-clipman-plugin-14: plugin unrealized; quitting child
xfce4-panel(external): systray-6: plugin unrealized; quitting child
xfce4-panel(systray): removed networkmanager applet[0x5561c9b86710] icon
xfce4-panel(systray): removed ibus panel[0x5561c9b86230] icon
xfce4-panel(systray): unregistered manager
xfce4-panel(systray): rgba visual is 0x5561c97f80a0
xfce4-panel(systray): registered manager on screen 0
xfce4-panel(application): finalized
xfce4-panel(systray): unregistered manager

(wrapper-2.0:1817): Gtk-CRITICAL **: 21:35:15.449: gtk_widget_remove_accelerator: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed

(wrapper-2.0:1817): Gtk-CRITICAL **: 21:35:15.449: gtk_widget_remove_accelerator: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed

Last edited by bjoern (2021-11-23 20:43:04)

Offline

#12 2021-11-23 23:43:44

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,300

Re: Status Tray doesn't show all tray icons

Might be worth it to create a bug report. As a workaround, adjust the previous script to add a small delay in startup:

#!/bin/bash

sleep 3s
/usr/bin/xfce4-panel $@

..see if it helps.

Offline

Board footer

Powered by FluxBB