Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-11-24 03:16:03

PlusNine
Member
Registered: 2021-11-23
Posts: 3

PulseAudio does not save device preferences

I've been trying XFCE running on openSUSE Leap for a couple days on my desktop, and every time I shutdown and startup my computer again, the input and output devices that I selected are "forgotten", I have to go into the audio mixer every time I start my computer again and set the devices to the correct ones. I've tried a number of solutions including advice from here: https://wiki.archlinux.org/title/PulseAudio/Examples as well as here: https://askubuntu.com/questions/294512/ … pulseaudio and neither method of forcing the default device is at all effective. I suspect that this is entirely PulseAudio's fault, because I also notice during startup that the devices I want to be the defaults are not listed for at least 10 seconds after the desktop is shown. Is there any possibility that PulseAudio is not setting the default devices correctly because it can't see them soon enough? I'm at a loss on how to troubleshoot this issue from here, any help would be appreciated.

Offline

#2 2021-11-24 08:36:50

KBar
Member
Registered: 2021-11-05
Posts: 82

Re: PulseAudio does not save device preferences

What version of Xfce and PulseAudio are you running?

Could try taking a screenshot before and after selecting the correct devices in Audio mixer? Right after you log in, run the following command:

pavucontrol &

It will open Audio mixer. Take a couple of screenshots showcasing how the devices don't appear in the list for 10 seconds. Press Alt+PrtSc to capture the active window. A new window will appear. From Actions, select Host on Imgur and post the links here.

Thanks.

Offline

#3 2021-11-24 19:25:47

PlusNine
Member
Registered: 2021-11-23
Posts: 3

Re: PulseAudio does not save device preferences

So I'm running XFCE 4.16 and PulseAudio 14.2 rebootstrapped. This is what PulseAudio shows on startup:
TInRoDe.png
and this is what PulseAudio shows after it finds everything
izOGktE.png

I want the HyperX analog stereo to be my default output and JLAB microphone to be my default input, but those are the two devices that are not found when the DE loads

Offline

#4 2021-11-25 06:08:23

KBar
Member
Registered: 2021-11-05
Posts: 82

Re: PulseAudio does not save device preferences

I see. I think what we have got to do first is to pinpoint what PulseAudio is actually doing at startup. We're going to have to disable the server from starting automatically. Open its startup configuration file at ~/.config/pulse/client.conf (per-user) or /etc/pulse/client.conf (system-wide). In it, uncomment the line

; autospawn = yes

by removing the leading semicolon and space like so:

autospawn = yes

There is also /etc/pulse/client.conf.d/01-enable-autospawn.conf. Check if it is available and not empty. On my system, it appears as a broken symbolic link to /run/pulseaudio-enable-autospawn.

Next, reboot the system. It should not spawn automatically when you log in. To start the server manually, invoke it with the following command:

pulseaudio

We don't want to daemonize it yet. We just want to see if it exhibits a similar behavior. Start the server and check if your devices are loaded correctly and in a timely manner.

pulseaudio(1), pulse-client.conf(5), Running PulseAudio.

Offline

Board footer

Powered by FluxBB