Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-03-31 23:34:17

scootergrisen
Member
Registered: 2019-01-29
Posts: 6

Hardware button turns on Bluetooth but not wi-fi

I have a laptop with a hardware button to turn off wireless stuff or whatever it is for.
Like Wi-Fi and Bluetooth.

On the panel i have XApp Status plugin.
It shows me Bluetooth and network.

With the hardware button set to enable wireless stuff i can disable bluetooth and wi-fi by right clicking the icons.
But when if i use the hardware button to disable and then enable bluetooth will be turned on while wi-fi will remain off.

So at least it is inconsistent.

So either keep what the user selected in the software or also enable wi-fi when the hardware button is switched to enable.

Offline

#2 2022-04-01 01:21:10

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: Hardware button turns on Bluetooth but not wi-fi

From https://wiki.archlinux.org/title/Networ … n/Wireless:

Hardware buttons to toggle wireless cards are handled by a vendor specific kernel module, frequently these are WMI modules. Particularly for very new hardware models, it happens that the model is not fully supported in the latest stable kernel yet. In this case it often helps to search the kernel bug tracker for information and report the model to the maintainer of the respective vendor kernel module, if it has not happened already.

Try running "rfkill" before and after pressing the button to see if both are blocked and then released. If not, check the configuration options of your wireless/bluetooth combo card driver or wmi module to see if there something there you can set.

Offline

#3 2022-04-02 16:55:38

scootergrisen
Member
Registered: 2019-01-29
Posts: 6

Re: Hardware button turns on Bluetooth but not wi-fi

:~$ rfkill
ID TYPE      DEVICE                 SOFT      HARD
 0 bluetooth tpacpi_bluetooth_sw blocked unblocked
 1 wlan      phy0                blocked unblocked
:~$ rfkill
ID TYPE      DEVICE                 SOFT    HARD
 0 bluetooth tpacpi_bluetooth_sw blocked blocked
 1 wlan      phy0                blocked blocked
:~$ rfkill
ID TYPE      DEVICE                   SOFT      HARD
 0 bluetooth tpacpi_bluetooth_sw unblocked unblocked
 1 wlan      phy0                unblocked unblocked
 4 bluetooth hci0                unblocked unblocked

Despite saying SOFT unblocked for both bluetooth and wlan at the end the only one that is enabled at the end is bluetooth.

Is blocked and disabled two different things?

If i disable wi-fi from the panel rfkill will say blocked. But it can also say unblocked while being disabled.



Could be the software i have to show the network status on the panel is quite old.
Maybe its called something like NetworkManager status panel application 1.8.24
www.gnome.org/projects/NetworkManager/

It's in the XApp Status plugin area.


I have no idea on how to "check the configuration options of your wireless/bluetooth combo card driver or wmi module".

Offline

#4 2022-04-02 17:19:09

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: Hardware button turns on Bluetooth but not wi-fi

Is there anything in your logs when you block and then unblock? If your distro is systemd-based then run the following:

sudo journalctl -f

...then press the hardware button, wait about 5 seconds, press it again, wait another 5 seconds, then post back all the output that was displayed.

Also, when you press the button and the wifi doesn't come back on, does running the following command enable it again?

sudo systemctl restart NetworkManager

And finally, in the NetworkManager settings, do you have auto-connect (connect automatically) enabled?

Offline

Board footer

Powered by FluxBB