Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-05-02 18:53:40

oldcastle
Member
Registered: 2020-05-12
Posts: 7

Help! XFCE doesn't respect window position. Openbox does.

Hey,

I'm running MuLab 9 demo on Linux via Wine. Everything works fine, except for one issue. When you open ML9, and right-click on any track head and then click on "Choose Target Module" as in the image, the window goes on and off instantly. It likes that the new window that should pop us stays behind the main window.

Why do I think there is something to do with XFCE? Because if I use Openbox, I can keep that window on top, holding CTRL or SHIFT when I click on "Choose Target Module". That works! But it doesn't have the same effect with XFCE.

Vfverwe.png

Any thoughts?

Thank you

Offline

#2 2022-05-02 22:03:15

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: Help! XFCE doesn't respect window position. Openbox does.

Try disabling the compositor (Settings Manager > Window Manager Tweaks > compositor tab) to see if that makes a difference.

Offline

#3 2022-05-03 06:46:30

oldcastle
Member
Registered: 2020-05-12
Posts: 7

Re: Help! XFCE doesn't respect window position. Openbox does.

Thanks, but it didn't work. I know that is something to do with the Window Manager, but I haven't figured out what is yet.

Offline

#4 2022-05-03 10:17:58

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: Help! XFCE doesn't respect window position. Openbox does.

Does this no longer work? Which options do you have checked on the Grahpics tab?

Offline

#5 2022-05-03 11:22:26

oldcastle
Member
Registered: 2020-05-12
Posts: 7

Re: Help! XFCE doesn't respect window position. Openbox does.

That's the thing. If I uncheck the option "Allow the window manager to control the windows", it works ok. But then I lose the task bar and the ability to use ALT-TAB. However, with Openbox I don't need to do that. I can keep  "Allow the window manager to control the windows" checked and everything works fine.

Offline

#6 2022-05-03 23:46:48

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: Help! XFCE doesn't respect window position. Openbox does.

Which distro and version of xfwm4 are you running?

xfwm4 -V

Also, is xfwm4 your current window manager:

ps -ef | grep xfwm4

Offline

#7 2022-05-04 07:22:44

oldcastle
Member
Registered: 2020-05-12
Posts: 7

Re: Help! XFCE doesn't respect window position. Openbox does.

For me, it seems something to do of losing focus.


Operating System: EndeavourOS
Kernel Version: 5.15.36-1-lts (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-8565U CPU @ 1.80GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
xfwm4: 4.16.1-3

Wine: wine-staging 7.7-1

can you replicate the issue?

Last edited by oldcastle (2022-05-04 07:48:26)

Offline

#8 2022-05-04 11:09:25

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: Help! XFCE doesn't respect window position. Openbox does.

I installed the program to have a look and yes, I can replicate the problem. It works if you set winecfg to not allow the window manager to manage the program, but then as you state, you are unable to switch applications.

What worked for me was to enable the "emulate a virtual desktop" option and set the desktop size to the size of my monitor resolution. This way the menus work and you can still Alt-Tab.

Offline

#9 2022-05-04 13:50:17

oldcastle
Member
Registered: 2020-05-12
Posts: 7

Re: Help! XFCE doesn't respect window position. Openbox does.

Yes, that is another way to get it working. But still, not the best.

Thanks for helping.

Offline

#10 2022-05-04 22:29:31

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: Help! XFCE doesn't respect window position. Openbox does.

Perhaps you can create a bug report to see what the developer says.

Offline

Board footer

Powered by FluxBB