Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-05-09 07:14:14

xendistar
Member
Registered: 2011-11-07
Posts: 20

[Solved] Workspaces not working correctly

The desktop workspace has stopped working correctly on my Laptop I have a Lenonvo laptop with an external 23" screen running Mint XFCE. I have set the display to span both monitors, when viewed in Display in Setting. The 23" is at the top and the laptop sit underneath and I can move files between the two desktop without issue.

Last week for some reason my laptop lost the external screen resolution which I had to reset and is now working correctly. But Workspace is not. To start with I normally only have two workspaces, and despite all my setting say 2 it is giving me 4 workspaces, also if I am on work space 1 and I click on work space 2 then I would expect to be given two clear desktop , but what I get is if I have Google Chrome open on the external monitor and I move to workspace 2 Chrome move to that desktop as well, thunderbird which is open on the laptop screen stays put.

I know in settings >> Workspace right click on the window across the top the menu give you an option "only on this workspace" I can untick and click always on visible workspace but that make no difference. Is there a configuration file I can hack to get the correct setting and operation of the workspaces.

Last edited by xendistar (2022-05-10 07:59:31)

Offline

#2 2022-05-09 16:38:50

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: [Solved] Workspaces not working correctly

Is xfwm4 managing your desktop? Is the process running? What happens if you

xfwm4 —replace

Also useful might be a copy of your ~/.xsession-errors log file if your distro uses one.

Offline

#3 2022-05-09 17:08:34

xendistar
Member
Registered: 2011-11-07
Posts: 20

Re: [Solved] Workspaces not working correctly

I believe I am using xfwm4 but when I run the command I got an error with xfwm4 -replace but xfwm4 -r worked well.

Still have 4 workspaces showing despite have selected only two but now if I change workspaces without open windows following the workspace

My .xsession-error log is as follows

dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/mit/.Xauthority
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting XDG_CONFIG_DIRS=/etc/xdg/xdg-xfce:/etc/xdg
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session1
dbus-update-activation-environment: setting LANGUAGE=en_GB:en
dbus-update-activation-environment: setting DESKTOP_SESSION=xfce
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting PWD=/home/mit
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=xfce
dbus-update-activation-environment: setting LOGNAME=mit
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting XAUTHORITY=/home/mit/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/mit
dbus-update-activation-environment: setting GDM_LANG=en_GB
dbus-update-activation-environment: setting HOME=/home/mit
dbus-update-activation-environment: setting IM_CONFIG_PHASE=1
dbus-update-activation-environment: setting LANG=en_GB.UTF-8
dbus-update-activation-environment: setting XDG_CURRENT_DESKTOP=XFCE
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting XDG_SESSION_CLASS=user
dbus-update-activation-environment: setting USER=mit
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting SHLVL=1
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting GTK3_MODULES=xapp-gtk3-module
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/xfce4:/home/mit/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share:/usr/share
dbus-update-activation-environment: setting PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
dbus-update-activation-environment: setting GDMSESSION=xfce
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting _=/usr/bin/dbus-update-activation-environment
xfce4-session-Message: 17:58:14.805: SSH authentication agent is already running
gpg-agent: a gpg-agent is already running - not starting a new one

** (wrapper-2.0:39427): WARNING **: 17:58:15.589: could not get output property

** (wrapper-2.0:39427): WARNING **: 17:58:15.595: could not get output property

(gkrellm:39442): GLib-CRITICAL **: 17:58:15.607: g_strstr_len: assertion 'haystack != NULL' failed

(wrapper-2.0:39429): Gtk-WARNING **: 17:58:15.618: Attempting to add a widget with type GtkToggleButton to a container of type XfcePanelPlugin, but the widget is already inside a container of type XfcePanelPlugin, please remove the widget from its existing container first.

(polkit-gnome-authentication-agent-1:39444): GLib-CRITICAL **: 17:58:15.620: g_variant_new_string: assertion 'string != NULL' failed

(polkit-gnome-authentication-agent-1:39444): polkit-gnome-1-WARNING **: 17:58:15.622: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(wrapper-2.0:39426): Gtk-WARNING **: 17:58:15.642: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 30

(wrapper-2.0:39421): Gtk-WARNING **: 17:58:15.656: Negative content width -2 (allocation 1, extents 2x1) while allocating gadget (node button, owner GtkToggleButton)
/usr/bin/xfce-autostart-wm:13: PyGIDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for "schema" or use a class specific constructor. See: https://wiki.gnome.org/PyGObject/InitializerDeprecations
  settings = Gio.Settings("com.linuxmint.desktop")

(wrapper-2.0:39428): Gtk-WARNING **: 17:58:15.746: Negative content width -2 (allocation 1, extents 2x1) while allocating gadget (node button, owner PulseaudioButton)

(wrapper-2.0:39429): Gtk-WARNING **: 17:58:15.786: Negative content width -2 (allocation 1, extents 2x1) while allocating gadget (node button, owner GtkToggleButton)

** (xfce4-volumed:39511): WARNING **: 17:58:15.828: Binding 'XF86AudioRaiseVolume' failed!

** (xfce4-volumed:39511): WARNING **: 17:58:15.842: Binding 'XF86AudioLowerVolume' failed!

** (xfce4-volumed:39511): WARNING **: 17:58:15.849: Binding 'XF86AudioMute' failed!

(wrapper-2.0:39427): Gtk-WARNING **: 17:58:15.895: Negative content width -2 (allocation 1, extents 2x1) while allocating gadget (node button, owner PowerManagerButton)

(wrapper-2.0:39423): Gtk-WARNING **: 17:58:15.895: Negative content width -2 (allocation 1, extents 2x1) while allocating gadget (node button, owner GtkToggleButton)

** (xfce4-screensaver:39475): WARNING **: 17:58:15.970: screensaver already running in this session
qt5ct: using qt5ct plugin
qt5ct: D-Bus system tray: yes
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 179, resource id: 10485934, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 180, resource id: 10485934, major code: 20 (GetProperty), minor code: 0

(wrapper-2.0:39422): LIBDBUSMENU-GLIB-WARNING **: 17:58:16.317: Getting layout failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownObject: No such object path '/NO_DBUSMENU'
/usr/bin/window-manager-launcher:15: PyGIDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for "schema" or use a class specific constructor. See: https://wiki.gnome.org/PyGObject/InitializerDeprecations
  settings = Gio.Settings("com.linuxmint.desktop")

(xfdesktop:39418): GLib-CRITICAL **: 17:58:24.683: g_variant_new_string: assertion 'string != NULL' failed
Working directory "/home/mit/[Invalid UTF-8]" does not exist. It won't be used when spawning "thunderbird".
(xfdesktop:39418): GLib-CRITICAL **: 17:58:32.359: g_variant_new_string: assertion 'string != NULL' failed
Working directory "/home/mit/[Invalid UTF-8]" does not exist. It won't be used when spawning "/usr/bin/google-chrome-stable".[40315:40315:0509/175834.895816:ERROR:password_sync_bridge.cc(340)] Passwords datatype error was encountered: Failed to load entries from password store. Encryption service failure.

(metacity:39576): metacity-WARNING **: 17:58:37.842: STACK_OP_ADD: window 0x5800005 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.842: STACK_OP_ADD: window 0x5800005 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.863: STACK_OP_ADD: window 0x5800036 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.863: STACK_OP_ADD: window 0x5800036 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.863: STACK_OP_ADD: window 0x5800038 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.863: STACK_OP_ADD: window 0x5800038 already in stack
JavaScript error: resource:///modules/ActivityManager.jsm, line 129: NS_ERROR_NOT_AVAILABLE: 

(xfdesktop:39418): GLib-CRITICAL **: 17:58:40.720: g_variant_new_string: assertion 'string != NULL' failed
Working directory "/home/mit/[Invalid UTF-8]" does not exist. It won't be used when spawning "/usr/bin/google-chrome-stable".
(xfce4-display-settings:41548): Gtk-WARNING **: 18:00:56.569: Content added to the action area of a dialog using header bars

(xfce4-display-settings:41548): Gtk-WARNING **: 18:00:56.570: Content added to the action area of a dialog using header bars

(xfwm4-workspace-settings:41561): Gtk-WARNING **: 18:01:01.580: Content added to the action area of a dialog using header bars

(xfwm4-workspace-settings:41561): Gtk-WARNING **: 18:01:01.581: Content added to the action area of a dialog using header bars

Offline

#4 2022-05-09 23:44:47

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: [Solved] Workspaces not working correctly

xendistar wrote:

(metacity:39576): metacity-WARNING **: 17:58:37.842: STACK_OP_ADD: window 0x5800005 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.842: STACK_OP_ADD: window 0x5800005 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.863: STACK_OP_ADD: window 0x5800036 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.863: STACK_OP_ADD: window 0x5800036 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.863: STACK_OP_ADD: window 0x5800038 already in stack

(metacity:39576): metacity-WARNING **: 17:58:37.863: STACK_OP_ADD: window 0x5800038 already in stack

According to your log file, you are using metacity - another window manager (not xfwm4). You should look at uninstalling metacity if you don't intend on using it as your window manager. If you do want to use metacity, then you'll need to look at the program for workspace management options.

Offline

#5 2022-05-10 07:59:07

xendistar
Member
Registered: 2011-11-07
Posts: 20

Re: [Solved] Workspaces not working correctly

Never realised I was using metacity WM, but having swapped back to XFWM4 I have properly operating workspaces, thanks for your help.

Offline

Board footer

Powered by FluxBB