Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-06-06 00:54:19

Mellowbob
Member
Registered: 2011-10-16
Posts: 281

Android Phone

I've got an android phone (moto g) and none of my file browsers will display thumbnails with it ... just unhelpful <jpg> icons.

So, I connected the phone to my wife's computer (Linux Mint) and it works just fine. Connected my wife's phone to my computer and it's the same issue.

So, most likely not the phones. I've tried thunar. nemo and pcfileman and get the same results. I logged into a different account on this computer and, yes, get the same results.

What is going on?

Offline

#2 2022-06-06 01:41:08

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: Android Phone

In Thunar's Preferences > Display tab, do you have the Show Thumbnails set up to always and no size limit?

Offline

#3 2022-06-06 01:54:45

Mellowbob
Member
Registered: 2011-10-16
Posts: 281

Re: Android Phone

It was, in Thunar, set to <local files only>. Changing to <always> does NOT make a difference.

I'm not a big thunar fan, but that is besides the point. I think this problem is with all the file managers on my system. And users.

I updated today from ubuntu 21.10 to 22.04 and that has not made a difference. Also, tried with different desktops other than xfce4 and get the same annoying results smile

Offline

#4 2022-06-06 02:13:30

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: Android Phone

I'll focus on Xfce.

Is the tumberld process running when trying to view thumbnails?

Try deleting the ~/.cache/thumbnails folder and logging out and back in again.

Do you have a ~/.config/tumbler/tumbler.rc file? If so, post back its contents. If not, post back the contents of /etc/xdg/tumbler/tumbler.rc

Offline

#5 2022-06-06 02:34:33

Mellowbob
Member
Registered: 2011-10-16
Posts: 281

Re: Android Phone

I should add that the problem seems to be limited to my phone. I have other image files on the computer and their thumbs display fine in thunar and nemo.

When running thunar, tumblerd is present in my system monitor. State==sleeping.

I've deleted the ~/.cache/thumbnails a couple of times now. No changes.

There is no  ~/.config/tumbler/tumbler.rc; however here is the /etc/xdg/tumbler/tumbler.rc:

###
# [TypeNameOfPlugin]
# Disabled:    Set to true to avoid loading the plugin. By default all
#              plugins are loaded.
# Priority:    Priority of the plugin if more plugins support the same
#              uri-scheme / mime-type combination.
# Locations:   ;-separated path list the plugin will be used in. If the
#              source file is not a child of one of the locations, the
#              plugin won't be used and another plugin with a lower
#              priority will be tried.
#              Absolute paths, environment variables, ~/ and ~username/
#              are allowed. Leave empty to allow all locations.
# Excludes:    ;-separated path list the plugin will not be used in.
#              Absolute paths, environment variables, ~/ and ~username/
#              are allowed. Leave empty to exclude nothing. Please note
#              that paths in Excludes precede those in Locations.
# MaxFileSize: Maximum size of the source file the plugin will still
#              try to generate a plugin for. The size is in bytes,
#              0 disabled the check.
#
# For more information see https://docs.xfce.org/xfce/tumbler/start
###

###
# Image Thumbnailers
###

# Jpeg thumbnailer (from exif data if possible)
[JPEGThumbnailer]
Disabled=false
Priority=3
Locations=
Excludes=
MaxFileSize=209715200

# Supports all type GdkPixbuf supports
[PixbufThumbnailer]
Disabled=false
Priority=2
Locations=
Excludes=
MaxFileSize=209715200

# RAW image files using libopenraw
[RawThumbnailer]
Disabled=false
Priority=1
Locations=
Excludes=
MaxFileSize=209715200

###
# Video Thumbnailers
###

# Download cover from omdbapi.com or themoviedb.org if an
# API key is given. This plugin is disabled because it
# sends your (private) movie names over the internet.
[CoverThumbnailer]
Disabled=true
Priority=3
Locations=~/movies
Excludes=
MaxFileSize=0
#APIKey=your-api-key-from-themoviedb.org

# ffmpegthumbnailer plugin
[FfmpegThumbnailer]
Disabled=false
Priority=2
Locations=
Excludes=
MaxFileSize=2147483648

# GStreamer plugin
[GstThumbnailer]
Disabled=false
Priority=1
Locations=
Excludes=
MaxFileSize=2147483648

###
# Other Thumbnailers
###

# FreeType thumbnailer
[FontThumbnailer]
Disabled=false
Priority=1
Locations=
Excludes=
MaxFileSize=209715200


# PDF/PS thumbnailer
[PopplerThumbnailer]
Disabled=false
Priority=1
Locations=
Excludes=
MaxFileSize=209715200

# Open document thumbnailer (ODF)
[OdfThumbnailer]
Disabled=false
Priority=1
Locations=
Excludes=
MaxFileSize=209715200

# thumbnailers provided by .thumbnailer desktop files
[DesktopThumbnailer]
Disabled=false
Priority=1
Locations=
Excludes=
MaxFileSize=2147483648

# Epub thumbnailer
[EpubThumbnailer]
Disabled=false
Priority=1
Locations=
Excludes=
MaxFileSize=209715200

Offline

#6 2022-06-06 10:01:54

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: Android Phone

Are you and your wife running the same version of Xfce and thunar?

Also, see: https://gitlab.xfce.org/xfce/thunar/-/issues/298.

Offline

#7 2022-06-06 17:13:27

Mellowbob
Member
Registered: 2011-10-16
Posts: 281

Re: Android Phone

No, different versions.

On my system I have
   thunar 4.16.10 (Xfce 4.16)
and on hers it's
   thunar 1.8.14 (Xfce 4.14)

But, until yesterday I think we had the same xfce ... I just upgraded from ubuntu 21.10 to 22.04.

I scouring the web I see a few similar problems ... but they deal with mtp and we are not using this on android phones anymore ... my phone doesn't have the connection option, it's just "file transfer".

I've tried some other FMs besides thunar: nemo, nautilus and PCmanFM all present the same problem. Dolphin will not read the phone at all. Tried with plasma and gnome desktops and get the same problem.

Offline

#8 2022-06-06 17:34:22

Mellowbob
Member
Registered: 2011-10-16
Posts: 281

Re: Android Phone

Doing a bit more sleuthing and I did find this bug report which sounds similar.

https://bugs.launchpad.net/ubuntu/+sour … ug/1665602

But it is from over 5 years ago smile

Offline

Board footer

Powered by FluxBB