Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-06-11 21:25:19

HippoMan
Member
Registered: 2017-12-11
Posts: 7

Disabling all notification sounds, all the time?

I'm running Xubuntu 20.04.4 which utilizes Xfce4.

I'd like to permanently disable all desktop notification sounds. I still want the notification popups, and I still want all other audio to be played. The only sounds that I want to always be blocked are desktop notification sounds.

Is there any way I can accomplish this?

Thank  you in advance for any help and suggestions.

Last edited by HippoMan (2022-06-11 21:27:35)

Offline

#2 2022-06-11 23:37:27

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 8,939

Re: Disabling all notification sounds, all the time?

That's interesting. Xfce doesn't have any notification sounds by default, except for maybe the beep when logging out if the pcspkr driver is loaded. Specifically which notification sounds are you referring to?

Offline

#3 2022-06-11 23:57:41

HippoMan
Member
Registered: 2017-12-11
Posts: 7

Re: Disabling all notification sounds, all the time?

I've been assuming that this is Xfce4 functionality, but I guess that is not the case.

Whenever any application posts a notification, I get a little popup window at the upper right of my screen, and it's accompanied by a sound.

This is not application-specific. I get notifications from several different browsers and several other applications, and these notifications all behave identically: same notification popup. same look and feel, same behavior, and same sound.

Can you or anyone else here think of what other linux software might be managing these popups?

Oh ... and I have not enabled the "Notification Plugin" that is offered for the panel.

Offline

#4 2022-06-12 00:06:38

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 8,939

Re: Disabling all notification sounds, all the time?

Try running "pavucontrol", and on the Playback tab, turn the System Sounds volume right down. Does that help?

Maybe also post back the output of:

xfconf-query -c xsettings -lv

...to see if you've got system sounds enabled and a sound theme set.

Edit: and also:

ps -ef| grep -E 'notif|dunst'

Last edited by ToZ (2022-06-12 00:07:38)

Offline

#5 2022-06-12 00:27:02

HippoMan
Member
Registered: 2017-12-11
Posts: 7

Re: Disabling all notification sounds, all the time?

Thank you very much. I can lower the volume level of the system sounds via "pavucontrol", and it indeed also lowers the volume of those notification sounds. However, I don't want to lower the volume of *all* audio nor disable it. I just want to get rid of those notification sounds that I described.  If I'm listening to something on line (for example), I want the system volume to be at a normal level. But then, any notifications which migh pop up make a very annoying sound. I want to get rid of those notification sounds completely, so I can keep audio enabled for other reasons, without being annoyed by those notifications.

As you can see in the command outputs below, "/Net/EnableEventSounds" and "/Net/EnableInputFeedbackSounds" are set to "false", and /Net/SoundThemeName" is "default". And you can also see that "xfce4-notifyd" is running.

% xfconf-query -c xsettings -lv
/Gdk/WindowScalingFactor        1
/Gtk/ButtonImages               true
/Gtk/CanChangeAccels            false
/Gtk/ColorPalette               black:white:gray50:red:purple:blue:light blue:green:yellow:orange:lavender:brown:goldenrod4:dodger blue:pink:light green:gray10:gray30:gray75:gray90
/Gtk/CursorThemeName            Human
/Gtk/CursorThemeSize            24
/Gtk/DecorationLayout           menu:minimize,maximize,close
/Gtk/FontName                   Noto Sans 8
/Gtk/IconSizes                  gtk-button=16,16
/Gtk/KeyThemeName               
/Gtk/MenuBarAccel               F10
/Gtk/MenuImages                 true
/Gtk/MonospaceFontName          Monospace 8
/Gtk/ToolbarIconSize            3
/Gtk/ToolbarStyle               icons
/Net/CursorBlink                false
/Net/CursorBlinkTime            1200
/Net/DndDragThreshold           8
/Net/DoubleClickDistance        5
/Net/DoubleClickTime            400
/Net/EnableEventSounds          false
/Net/EnableInputFeedbackSounds  false
/Net/FallbackIconTheme          gnome
/Net/IconThemeName              elementary-xfce-dark
/Net/SoundThemeName             default
/Net/ThemeName                  Greybird
/Xfce/LastCustomDPI             96
/Xft/Antialias                  1
/Xft/DPI                        -1
/Xft/Hinting                    1
/Xft/HintStyle                  hintslight
/Xft/Lcdfilter                  lcddefault
/Xft/RGBA                       rgb
% ps -ef| grep -E 'notif|dunst'
me         2273    1894  0 16:12 ?        00:00:00 /usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd
me       211781    2805  0 20:22 pts/3    00:00:00 grep -E notif|dunst

Last edited by HippoMan (2022-06-12 00:27:46)

Offline

#6 2022-06-12 01:02:15

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 8,939

Re: Disabling all notification sounds, all the time?

HippoMan wrote:

Thank you very much. I can lower the volume level of the system sounds via "pavucontrol", and it indeed also lowers the volume of those notification sounds. However, I don't want to lower the volume of *all* audio nor disable it. I just want to get rid of those notification sounds that I described.  If I'm listening to something on line (for example), I want the system volume to be at a normal level. But then, any notifications which migh pop up make a very annoying sound. I want to get rid of those notification sounds completely, so I can keep audio enabled for other reasons, without being annoyed by those notifications.

The "System sounds" refers to the notification sounds you here. If you start up a media player or browser, you'll see a entry of its own that will be different from the System Sounds. In fact, you can turn system sounds right down and it won't affect the sounds of any media players.

I'm curious though of specifically which apps and which browsers/web pages are generating these sounds? They may have options to disable sounds in their configuration settings.

Offline

#7 2022-06-12 02:30:46

HippoMan
Member
Registered: 2017-12-11
Posts: 7

Re: Disabling all notification sounds, all the time?

I realize now that turning "System Sounds" down to zero using pavucontrol indeed allows me to still listen to sounds from normal media. I accidentally tested that incorrectly when I tried earlier.

However, I am still getting the loud and annoying notification sounds, even when pavucontrol has the system sound level set to zero.

But now that I consider your question, I'm thinking that perhaps the app which is generating those notification sounds might be Google Chrome itself. I will investigate further.

I will also test Firefox and some other applications, and I will report back later, probably tomorrow.

Thank you again for all your help!

Offline

#8 2022-06-12 14:28:12

HippoMan
Member
Registered: 2017-12-11
Posts: 7

Re: Disabling all notification sounds, all the time?

I finally figured this out. It's indeed Chrome which is playing those annoying notification sounds, and this has nothing to do with Xfce4. And in Google's infinite "wisdom", they do not permit notification sounds to be turned off within Chrome. The Chrome notifications themselves can be turned on and off, but if those notifications are turned on, then the sounds will also be turned on. And these annoying sounds go through the normal audio stream, which means that I cannot disable those Chrome notification sounds unless I also disable all other audio.

The sole reason I use Chrome under linux is to enable me to run LINE Messenger on my linux box, since a Chrome plug-in seems to be the only way to get LINE working under linux (I've never been able to get it working under Wine). So, I now have to figure out a better way to solve the LINE-Messenger-under-linux problem.

Anyway, I'm sorry for the false alarm here, and I thank you very much for your help and feedback.

Offline

#9 2022-06-13 22:40:41

Skaperen
Member
From: right by Jesus, our Saviour
Registered: 2013-06-15
Posts: 667

Re: Disabling all notification sounds, all the time?

i have to regularly re-login my wifi.  they dump all routes for each user about 30 minutes after they login.  so i wrote a couple Python3 scripts to watch for loss of reachability.  then it disconnects my from the wifi and connects me back on, again (for another 30 minutes).  i get a notification for the disconnect and another for the connect.  they are fast enough for YouTube videos to play right through (99% do).  i get no sounds from either of these.  i think Xfce has nothing to do with these notifications otherwise i'd ask how to turn on sound and describe that i did nothing to make them silent on my Xubuntu 20.04.4 LTS system.

not that much to complain about for free wifi where i live.

Last edited by Skaperen (2022-06-13 22:41:59)

Offline

#10 2022-06-15 03:31:46

rogue_ronin
Member
Registered: 2015-03-03
Posts: 19

Re: Disabling all notification sounds, all the time?

HippoMan wrote:

I finally figured this out. It's indeed Chrome which is playing those annoying notification sounds, and this has nothing to do with Xfce4. And in Google's infinite "wisdom", they do not permit notification sounds to be turned off within Chrome. The Chrome notifications themselves can be turned on and off, but if those notifications are turned on, then the sounds will also be turned on. And these annoying sounds go through the normal audio stream, which means that I cannot disable those Chrome notification sounds unless I also disable all other audio.

The sole reason I use Chrome under linux is to enable me to run LINE Messenger on my linux box, since a Chrome plug-in seems to be the only way to get LINE working under linux (I've never been able to get it working under Wine). So, I now have to figure out a better way to solve the LINE-Messenger-under-linux problem.

Anyway, I'm sorry for the false alarm here, and I thank you very much for your help and feedback.

If you make Chrome notifications use native Linux notifications, maybe having System sounds muted in PulseAudio will cause them to be muted?

https://www.addictivetips.com/ubuntu-li … ome-linux/

Overlong tutorial for what you want, but TL;DR: go to chrome://flags and search "notifications" and enable native.

Luck!

Offline

Board footer

Powered by FluxBB