Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-06-20 11:23:05

Sadfa
Member
Registered: 2021-03-27
Posts: 46

(SOLVED) Thunar NOT updating after changing option in the XML file

Hi friends,

I change a setting in the ~/.config/xfce4/xfconf/xfce-perchannel-xml/thunar.xml file but the changes don't propagate to the Thunar application itself.

I've tried:

thunar -q
mv ~/.config/Thunar ~/.config/Thunar.bak

# Then clicking Thunar icon on the desktop to relaunch it.

But to no avail. I know that I can change it in the GUI and that works but I'd like to adopt this change on the command line.

Thanks

EDIT : --q to -q

Last edited by Sadfa (2022-06-20 19:13:17)

Offline

#2 2022-06-20 11:25:41

KBar
Moderator
Registered: 2021-11-05
Posts: 444

Re: (SOLVED) Thunar NOT updating after changing option in the XML file

You need to kill the Xfconf daemon first. This unloads the current applied configuration. This doc explains it better than I can.

Last edited by KBar (2022-06-20 11:25:54)


Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Offline

#3 2022-06-20 19:03:09

Sadfa
Member
Registered: 2021-03-27
Posts: 46

Re: (SOLVED) Thunar NOT updating after changing option in the XML file

Thanks for the tip re xfconf, Kbar!

I simply went here and learned how to change the configuration of a property:

https://docs.xfce.org/xfce/xfconf/xfconf-query

The one-liner looked like this:

xfconf-query -c thunar -p /<PROPERTY_NAME> -s <NEW_VALUE>

Solved smile

EDIT: Recommendation that a comment be added the XML files that says, "To access and/or configure settings, see https://docs.xfce.org/xfce/xfconf/start … ation_data

Last edited by Sadfa (2022-06-20 19:12:25)

Offline

Board footer

Powered by FluxBB