Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-06-28 15:56:02

kitjackson
Member
Registered: 2022-06-28
Posts: 5

[SOLVED] Problem with initializing xfce?

Operating System: Debian GNU/Linux 11 (bullseye)
Kernel: Linux 5.10.0-15-amd64
xfce 4.16.2

Something isn't always completing properly when xfce starts.  The xfce panel appears correctly (I've got one panel across the top of the screen) but desktop icons don't appear at all. 

When I start an application from the menu such as Mousepad or Thunar they start but are incorrectly placed, always appearing in the top left hand corner of the screen on top of the panel.  The buttons for minmize, maximize and close the application don't appear in any application and the windows are not sizable. 

Logging on as another user does work OK and the desktop and applications appear and behave as expected.  It looks like the initialization file for this user has got screwed up.  Can I just delete something and hope it gets restored properly?  What files are likely to be causing the trouble?

Cross posted to formus.debian.net

Last edited by KBar (2022-07-02 20:11:22)

Offline

#2 2022-06-28 20:45:39

KBar
Moderator
Registered: 2021-11-05
Posts: 529

Re: [SOLVED] Problem with initializing xfce?

Hello and welcome to our forum!

kitjackson wrote:

Something isn't always completing properly when xfce starts.  The xfce panel appears correctly (I've got one panel across the top of the screen) but desktop icons don't appear at all.

Did you enable them in the Desktop app? Could you please share the output of the following:

xfconf-query --channel xfce4-desktop --property /desktop-icons --list --verbose

Next, let's confirm that you don't have Nautilus or other conflicting file managers installed:

cat /proc/"$(dbus-send --dest=org.freedesktop.DBus --print-reply=literal /org/freedesktop/DBus org.freedesktop.DBus.GetConnectionUnixProcessID string:"$(dbus-send --dest=org.freedesktop.DBus --print-reply=literal /org/freedesktop/DBus org.freedesktop.DBus.GetNameOwner string:"org.freedesktop.FileManager1" | awk '{print $1}')" | awk '{print $2}')"/cmdline; echo
pgrep --list-full xfdesktop

The first one should output Thunar or something similar, the second command has to print out successfully.

When I start an application from the menu such as Mousepad or Thunar they start but are incorrectly placed, always appearing in the top left hand corner of the screen on top of the panel.

Try running the following:

xfconf-query -c thunar -p /last-window-height --reset
xfconf-query -c thunar -p /last-window-width -r
xfconf-query -c thunar -p /last-window-maximized -r
xfconf-query -c xfwm4 -p /general/placement_ratio -r
xfconf-query -c xfwm4 -p /general/placement_mode -r

The buttons for minmize, maximize and close the application don't appear in any application and the windows are not sizable.

Did you try selecting a theme in the Window Manager app? Share the output of the following:

xfconf-query -c xfwm4 -p /general/theme

Also, tell us your GTK theme, i.e. the one in the Appearance menu, which is also accessible with:

xfconf-query -c xsettings -p /Net/ThemeName

Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Online

#3 2022-06-29 09:01:01

kitjackson
Member
Registered: 2022-06-28
Posts: 5

Re: [SOLVED] Problem with initializing xfce?

Thanks for your helpful reply KBar.  Here's the output from the suggested commands:-

kit@Lenovo:~$ xfconf-query --channel xfce4-desktop --property /desktop-icons --list --verbose
Channel "xfce4-desktop" contains no properties.
kit@Lenovo:~$ cat /proc/"$(dbus-send --dest=org.freedesktop.DBus --print-reply=literal /org/freedesktop/DBus org.freedesktop.DBus.GetConnectionUnixProcessID string:"$(dbus-send --dest=org.freedesktop.DBus --print-reply=literal /org/freedesktop/DBus org.freedesktop.DBus.GetNameOwner string:"org.freedesktop.FileManager1" | awk '{print $1}')" | awk '{print $2}')"/cmdline; echo
/usr/bin/Thunar--daemon
kit@Lenovo:~$ pgrep --list-full xfdesktop
828 xfdesktop --display :0.0 --sm-client-id 28f100aa5-44d6-4e35-a9d5-51803b0af122
kit@Lenovo:~$ 
kit@Lenovo:~$ xfconf-query -c thunar -p /last-window-height --reset
kit@Lenovo:~$ xfconf-query -c thunar -p /last-window-width -r
kit@Lenovo:~$ xfconf-query -c thunar -p /last-window-maximized -r
kit@Lenovo:~$ xfconf-query -c xfwm4 -p /general/placement_ratio -r
kit@Lenovo:~$ xfconf-query -c xfwm4 -p /general/placement_mode -r
kit@Lenovo:~$ 
kit@Lenovo:~$ xfconf-query -c xfwm4 -p /general/theme
Default
kit@Lenovo:~$ xfconf-query -c xsettings -p /Net/ThemeName
Xfce

Is the output from the first command suspicious?

Note that if I log on as a different user (which behaves correctly) and then use 'Switch User' from the default shutdown options to log in as user 'kit' then the desktop appears correctly, the desktop icons appear, all the buttons appear in an application windows and the application windows are all resizable as user 'kit'.  Does that give you any clues?

Last edited by KBar (2022-06-29 10:10:16)

Offline

#4 2022-06-29 10:14:10

KBar
Moderator
Registered: 2021-11-05
Posts: 529

Re: [SOLVED] Problem with initializing xfce?

Please, don't just copy and paste and be done with it. Put a little extra effort and wrap terminal output in code tags.

As far as the problem itself goes, you don't have the /desktop-icons property in the xfce4-desktop channel. Let's check one more thing before we proceed further:

xfconf-query -c xfce4-desktop -lv

Make sure to wrap any output in code tags. For instructions, see.


Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Online

#5 2022-06-29 10:44:56

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: [SOLVED] Problem with initializing xfce?

Also check to make sure that xfwm4 is running or restart with:

xfwm4 --replace

Offline

#6 2022-06-30 15:30:34

kitjackson
Member
Registered: 2022-06-28
Posts: 5

Re: [SOLVED] Problem with initializing xfce?

OK KBar, done.  Thanks,  I wondered how you got your posts looking like that.

kit@Lenovo:~$  xfconf-query -c xfce4-desktop -lv
/backdrop/screen0/monitor0/brightness                   0
/backdrop/screen0/monitor0/color1                       <<UNSUPPORTED>>
/backdrop/screen0/monitor0/color2                       <<UNSUPPORTED>>
/backdrop/screen0/monitor0/color-style                  1
/backdrop/screen0/monitor0/image-path                   /usr/share/images/desktop-base/default
/backdrop/screen0/monitor0/image-show                   true
/backdrop/screen0/monitor0/last-image                   /usr/share/images/desktop-base/default
/backdrop/screen0/monitor0/last-single-image            /usr/share/images/desktop-base/default
/backdrop/screen0/monitor1/brightness                   0
/backdrop/screen0/monitor1/color1                       <<UNSUPPORTED>>
/backdrop/screen0/monitor1/color2                       <<UNSUPPORTED>>
/backdrop/screen0/monitor1/color-style                  1
/backdrop/screen0/monitor1/image-path                   /usr/share/images/desktop-base/default
/backdrop/screen0/monitor1/image-show                   true
/backdrop/screen0/monitor1/last-image                   /usr/share/images/desktop-base/default
/backdrop/screen0/monitor1/last-single-image            /usr/share/images/desktop-base/default
/backdrop/screen0/monitorHDMI-1/workspace0/color-style  1
/backdrop/screen0/monitorHDMI-1/workspace0/image-style  5
/backdrop/screen0/monitorHDMI-1/workspace0/last-image   /usr/share/images/desktop-base/default
/backdrop/screen0/monitorHDMI-1/workspace1/color-style  1
/backdrop/screen0/monitorHDMI-1/workspace1/image-style  5
/backdrop/screen0/monitorHDMI-1/workspace1/last-image   /usr/share/images/desktop-base/default
/backdrop/screen0/monitorHDMI-1/workspace2/color-style  1
/backdrop/screen0/monitorHDMI-1/workspace2/image-style  5
/backdrop/screen0/monitorHDMI-1/workspace2/last-image   /usr/share/images/desktop-base/default
/backdrop/screen0/monitorHDMI-1/workspace3/color-style  1
/backdrop/screen0/monitorHDMI-1/workspace3/image-style  5
/backdrop/screen0/monitorHDMI-1/workspace3/last-image   /usr/share/images/desktop-base/default
kit@Lenovo:~$ 

Offline

#7 2022-06-30 15:41:28

kitjackson
Member
Registered: 2022-06-28
Posts: 5

Re: [SOLVED] Problem with initializing xfce?

Hello ToZ,  I've got

kit@Lenovo:~$ xfwm4 --help
Usage:
  xfwm4 [OPTION…] [ARGUMENTS...]

Help Options:
  -h, --help                        Show help options
  --help-all                        Show all help options
  --help-gtk                        Show GTK Options
  --help-sm-client                  Show session management options

Application Options:
  -c, --compositor=on|off           Set the compositor mode
  -b, --vblank=off|xpresent|glx     Set the vblank mode
  -r, --replace                     Replace the existing window manager
  -V, --version                     Print version information and exit
  --display=DISPLAY                 X display to use

so presumably xfwm4 is running.  However

kit@Lenovo:~$ xfwm4 --replace

does re-instate the lost desktop icons, the buttons in the application windows and enables application windows to respect the positioning of the top panel.

So the next question is where do I look next to ensure that xfwm4 starts properly as soon as this user logs on?

Offline

#8 2022-06-30 16:21:28

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: [SOLVED] Problem with initializing xfce?

The first thing to try would be to delete your sessions cache in case it is messed up. While not logged in, go to a tty (Ctrl+Alt+F2), log in, and issue these commands:

cd ~/.cache
rm -rf sessions

Then go back to your graphical logon (or restart the computer) and see if that fixes it.

Offline

#9 2022-07-01 06:52:52

kitjackson
Member
Registered: 2022-06-28
Posts: 5

Re: [SOLVED] Problem with initializing xfce?

Thanks ToZ, clearing the sessions in ~/.cache fixes it.  Have you any idea how it happens that the sesions get corrupted?

Offline

#10 2022-07-01 12:11:57

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,050

Re: [SOLVED] Problem with initializing xfce?

Xfce is capable of session saving. Either manual by yourself, or through settings in Session and Startup > Current Session. I believe xfwm4 crashed and you logged out, the session got saved without xfwm4, and caused your problem. Just a hunch though as we didn't have a look at what was active in your faulty session.

Offline

#11 2022-07-01 14:26:08

KBar
Moderator
Registered: 2021-11-05
Posts: 529

Re: [SOLVED] Problem with initializing xfce?

Feels good to learn something new.

Thanks, ToZ!


Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Online

#12 2022-07-02 04:47:42

Skaperen
Member
From: right by Jesus, our Saviour
Registered: 2013-06-15
Posts: 695

Re: [SOLVED] Problem with initializing xfce?

> Feels good to learn something new.

"The first day you don't learn something new is also the first day you are no longer living" --Skaperen

Offline

Board footer

Powered by FluxBB