Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-09-15 14:09:44

Tabespe
Member
Registered: 2019-12-04
Posts: 99

[solved] Alt+Tab, exclude a programme

Hello,

I can go through all my windows with the key combination Alt+Tab.

There are two programmes I want to exclude, so that this programme will not be triggered through Alt+Tab. (For example "Calculator").

Is there any config where I can add this programme?
Or can I make this excludes via GUI?

Would appreciate some answer. Thank you.

Last edited by Tabespe (2022-09-17 06:32:06)

Offline

#2 2022-09-15 17:58:51

KBar
Moderator
Registered: 2021-11-05
Posts: 639

Re: [solved] Alt+Tab, exclude a programme

There isn't a config but you can use wmctrl(1) to do that:

wmctrl -r "WINDOW_TITLE" -b add,skip_pager

If you're launching them with a keyboard shortcut, you can add the above to their command string.


Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Offline

#3 2022-09-15 21:20:17

Tabespe
Member
Registered: 2019-12-04
Posts: 99

Re: [solved] Alt+Tab, exclude a programme

Thank you. I have tried this out.
It looks like this command only works, when I run it after I have started the window/programme, I want to skip. Right?

I have tried to integrate your command into the starter command:
/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=com.github.rajsolai.textsnatcher --file-forwarding com.github.rajsolai.textsnatcher @@u %U @@ && wmctrl -r "TextSnatcher" -b add,skip_pager

But this does not work. It destroys the starter.

(?)

Offline

#4 2022-09-16 05:43:40

KBar
Moderator
Registered: 2021-11-05
Posts: 639

Re: [solved] Alt+Tab, exclude a programme

sh -c "/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=com.github.rajsolai.textsnatcher --file-forwarding com.github.rajsolai.textsnatcher @@u %U @@ && wmctrl -r 'TextSnatcher' -b add,skip_pager"

Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Offline

#5 2022-09-16 06:22:39

Tabespe
Member
Registered: 2019-12-04
Posts: 99

Re: [solved] Alt+Tab, exclude a programme

Thank you. KBar.

But unfortunately this command does not work. It does not exclude "TextSnatcher" from Alt+Tab.

I have also test this simpler command in the galculator starter:
sh -c "galculator && wmctrl -r 'galculator' -b add,skip_pager"

It also does not exclude "galculator" from Alt+Tab list.

Offline

#6 2022-09-16 06:57:39

KBar
Moderator
Registered: 2021-11-05
Posts: 639

Re: [solved] Alt+Tab, exclude a programme

Try launching an app in the background and adding a delay before `wmctrl` then.


Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Offline

#7 2022-09-16 07:05:26

Tabespe
Member
Registered: 2019-12-04
Posts: 99

Re: [solved] Alt+Tab, exclude a programme

What do you mean with "Try launching an app in the background" ?

I have now tried this:
sh -c "galculator && sleep 2 && wmctrl -r 'galculator' -b add,skip_pager"

-> But same issue. Sleep does not help.

Offline

#8 2022-09-16 10:07:27

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,505

Re: [solved] Alt+Tab, exclude a programme

Make sure that Settings Manager > Window Manager Tweaks > Cycling > "Skip Windows that have 'skip_pager'...." is also enabled.

Offline

#9 2022-09-16 12:02:17

Tabespe
Member
Registered: 2019-12-04
Posts: 99

Re: [solved] Alt+Tab, exclude a programme

Yes, this was enabled.

Offline

#10 2022-09-16 14:29:13

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,505

Re: [solved] Alt+Tab, exclude a programme

Try putting the commands in a script like this:

#!/bin/sh

galculator &
sleep 1
wmctrl -r 'galculator' -b add,skip_pager

...and calling the script instead on the Exec= line.

Offline

#11 2022-09-16 20:07:09

Tabespe
Member
Registered: 2019-12-04
Posts: 99

Re: [solved] Alt+Tab, exclude a programme

Thank you @ToZ. This works.

Strange that the same command directly in the starter does not work.

Offline

Board footer

Powered by FluxBB