Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-09-25 14:23:14

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

[solved] After update no icons

Hello,
after one of the last updates all the desktop icons are lost and the context menu with right click does not work anymore. Also some shortcuts (ALT F2) do not work.
If I try the command xfdesktop after 2 minutes the icons appear and the context menu work again but I get an error:

xfdesktop &
[1] 2747
 
(xfdesktop:2747): libxfce4ui-WARNING **: 14:50:17.890: ICE I/O Error

(xfdesktop:2747): libxfce4ui-WARNING **: 14:50:17.890: Disconnected from session manager.

What can I do?

I use the version 4.16

Last edited by Peter_Ziegler (2022-10-16 10:02:27)

Offline

#2 2022-09-25 20:02:11

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: [solved] After update no icons

Which distro are you running?

What was upgraded?

Which version of mesa do you have installed and which video card? How is it set up?

Offline

#3 2022-09-26 11:02:19

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

Re: [solved] After update no icons

Here are some infos about my system

System:
  Host: master Kernel: 5.19.11-1-siduction-amd64 arch: x86_64 bits: 64
    compiler: gcc v: 12.2.0 Desktop: Xfce v: 4.16.1 Distro: siduction - xfce
    base: Debian GNU/Linux bookworm/sid
Machine:
  Type: Desktop Mobo: Gigabyte model: P55-UD3 v: x.x
    serial: <superuser required> BIOS: Award v: F3 date: 07/31/2009
CPU:
  Info: quad core model: Intel Core i7 860 bits: 64 type: MT MCP
    arch: Nehalem rev: 5 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 2398 high: 2798 min/max: N/A cores: 1: 2798 2: 1199
    3: 2798 4: 1199 5: 2798 6: 2798 7: 2798 8: 2798 bogomips: 44769
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: AMD Oland PRO [Radeon R7 240/340 / Radeon 520]
    vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-1 bus-ID: 01:00.0
  Device-2: Logitech HD Webcam C525 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-4:2
  Display: x11 server: X.Org v: 1.21.1.4 with: Xwayland v: 22.1.3 driver:
    X: loaded: amdgpu unloaded: fbdev,modesetting,vesa gpu: amdgpu
    resolution: 1920x1080~60Hz
  OpenGL: renderer: OLAND (oland LLVM 14.0.6 DRM 3.47
    5.19.11-1-siduction-amd64) v: 4.6 Mesa 22.2.0 direct render: Yes

I use a rolling release distro and update it every day, so I cannot say which packages of Xfce were updatet some days ago.

Offline

#4 2022-09-26 11:33:01

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: [solved] After update no icons

My first suggestion would be to delete the ~/.ICEauthority file to see if that helps.

I recall a little while ago on Arch there was a similar error message as a result of a faulty mesa update. Can you try downgrading mesa (not sure how this is done on debian).

I use a rolling release distro and update it every day, so I cannot say which packages of Xfce were updatet some days ago.

Doesn't apt keep a history somewhere? It would be interesting to see if mesa was updated.

Edit: Also helpful would be your Xorg.0.log file.

Is this a regular computer install or is it a VM or remote install?

Last edited by ToZ (2022-09-26 11:36:08)

Offline

#5 2022-09-26 12:15:50

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

Re: [solved] After update no icons

After the deletion of ~/.ICEauthority the icons appear 2 minutes after boot. A little success. :-) Thanks!

The following mesa and xfce packages were updated the last days:
libglx-mesa0:amd64 (22.2.0~rc3-1, 22.2.0~rc3-2)
libgl1-mesa-glx:amd64 (22.2.0~rc3-1, 22.2.0~rc3-2)
mesa-vulkan-drivers:amd64 (22.2.0~rc3-1, 22.2.0~rc3-2)
libglapi-mesa:amd64 (22.2.0~rc3-1, 22.2.0~rc3-2)
libegl-mesa0:amd64 (22.2.0~rc3-1, 22.2.0~rc3-2)
libgl1-mesa-dri:amd64 (22.2.0~rc3-2, 22.2.0-1)

xfce4-panel:amd64 (4.16.4-1, 4.16.5-1)
libxfce4panel-2.0-4:amd64 (4.16.4-1, 4.16.5-1)
xfce4-pulseaudio-plugin:amd64 (0.4.3-1, 0.4.4-1)
xfce4-notifyd:amd64 (0.6.3-1, 0.6.4-1)
libxfce4ui-2-0:amd64 (4.16.1-1, 4.16.1-1+b1)
libxfce4ui-utils:amd64 (4.16.1-1, 4.16.1-1+b1)

In the Xorg.0.log file I did not find something with mesa or Xfce.

This is a regular installation.

Offline

#6 2022-09-26 13:10:54

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: [solved] After update no icons

Peter_Ziegler wrote:

After the deletion of ~/.ICEauthority the icons appear 2 minutes after boot. A little success. :-)

Can you post back your ~/.xsession-errors log file (if you have one)? Lets see whats going on.

Offline

#7 2022-09-26 15:05:20

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

Re: [solved] After update no icons

~/.xsession-errors after a fresh reboot and 2 minutes until icons reappear:

Xsession: X session started for peter at Mo 26. Sep 17:01:06 CEST 2022
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/peter/.Xauthority
localuser:peter being added to access control list
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting USER=peter
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting HOME=/home/peter
dbus-update-activation-environment: setting DESKTOP_SESSION=lightdm-xsession
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting LOGNAME=peter
dbus-update-activation-environment: setting XDG_SESSION_CLASS=user
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting GDM_LANG=de_DE.utf8
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=de_DE.utf8
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=lightdm-xsession
dbus-update-activation-environment: setting XAUTHORITY=/home/peter/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm/data/peter
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting GDMSESSION=lightdm-xsession
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting PWD=/home/peter
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/
/usr/bin/x-session-manager: X server already running on display :0
/usr/bin/iceauth:  creating new authority file /run/user/1000/ICEauthority
xfce4-session: GNOME compatibility is enabled and gnome-keyring-daemon is found on the system. Skipping gpg/ssh-agent startup.
discover_other_daemon: 1GNOME_KEYRING_CONTROL=/run/user/1000/keyring
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
GNOME_KEYRING_CONTROL=/run/user/1000/keyring
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh

(xfce4-session:1836): xfce4-session-WARNING **: 17:01:08.696: Unable to launch "/usr/lib/gnome-settings-daemon/gnome-settings-daemon-localeexec" (specified by autostart/gnome-settings-daemon.desktop): Kindprozess »/usr/lib/gnome-settings-daemon/gnome-settings-daemon-localeexec« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
GNOME_KEYRING_CONTROL=/run/user/1000/keyring
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh

(tracker-miner-fs-3:2009): Tracker-WARNING **: 17:01:08.746: Unable to get XDG user directory path for special directory &DOCUMENTS. Ignoring this location.

(tracker-miner-fs-3:2009): Tracker-WARNING **: 17:01:08.746: Unable to get XDG user directory path for special directory &MUSIC. Ignoring this location.

(tracker-miner-fs-3:2009): Tracker-WARNING **: 17:01:08.746: Unable to get XDG user directory path for special directory &PICTURES. Ignoring this location.

(tracker-miner-fs-3:2009): Tracker-WARNING **: 17:01:08.746: Unable to get XDG user directory path for special directory &VIDEOS. Ignoring this location.

(tracker-miner-fs-3:2009): Tracker-WARNING **: 17:01:08.746: Unable to get XDG user directory path for special directory &DOWNLOAD. Ignoring this location.

(tracker-miner-fs-3:2009): Tracker-WARNING **: 17:01:08.747: Unable to get XDG user directory path for special directory &DOCUMENTS. Ignoring this location.

(tracker-miner-fs-3:2009): Tracker-WARNING **: 17:01:08.747: Unable to get XDG user directory path for special directory &MUSIC. Ignoring this location.

(tracker-miner-fs-3:2009): Tracker-WARNING **: 17:01:08.747: Unable to get XDG user directory path for special directory &PICTURES. Ignoring this location.

(tracker-miner-fs-3:2009): Tracker-WARNING **: 17:01:08.747: Unable to get XDG user directory path for special directory &VIDEOS. Ignoring this location.

(wrapper-2.0:1977): Gtk-WARNING **: 17:01:08.907: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)

(tracker-miner-fs-3:2009): Tracker-CRITICAL **: 17:01:09.794: Could not request DBus name 'org.freedesktop.Tracker3.Miner.Files': D-Bus service name:'org.freedesktop.Tracker3.Miner.Files' is already taken, perhaps the application is already running?
mounted /org/freedesktop/UDisks2/block_devices/sdd1 on /media/peter/2E3A-45E4
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
[1996:1996:0926/170129.276028:ERROR:CONSOLE(0)] "Uncaught (in promise) Error: A listener indicated an asynchronous response by returning true, but the message channel closed before a response was received", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[1996:1996:0926/170129.276130:ERROR:CONSOLE(0)] "Uncaught (in promise) Error: A listener indicated an asynchronous response by returning true, but the message channel closed before a response was received", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)

(xfdesktop:1973): libxfce4ui-WARNING **: 17:02:59.542: ICE I/O Error

(xfdesktop:1973): libxfce4ui-WARNING **: 17:02:59.542: Disconnected from session manager.

Edit: use code tags

Last edited by KBar (2022-09-26 15:10:22)

Offline

#8 2022-09-26 18:01:51

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: [solved] After update no icons

Interesting. You are still getting the ICE error. I have a feeling this is related to mesa and your video driver, but I'm not familiar enough with either to advise on how to fix it.

Looking at your log file, you appear to be mounting a block device (sdd1) - perhaps this is the cause of the delay? Can you comment that out and try again?

Try creating a second test account on your computer and logging in from there to see if the problem persists.

Offline

#9 2022-09-27 12:50:16

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

Re: [solved] After update no icons

The device sdd1 is not the problem, it is a stick with decryption data for my hard disks.

With a new user account there are no problems, all works as expected.

Offline

#10 2022-09-27 12:52:38

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: [solved] After update no icons

Could you post the comparator .xsession-errors file from the working account so we can compare them?

Offline

#11 2022-09-27 13:09:21

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

Re: [solved] After update no icons

Xsession: X session started for gast at Di 27. Sep 15:01:31 CEST 2022
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1001/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/gast/.Xauthority
localuser:gast being added to access control list
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting USER=gast
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting HOME=/home/gast
dbus-update-activation-environment: setting DESKTOP_SESSION=lightdm-xsession
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1001/bus
dbus-update-activation-environment: setting LOGNAME=gast
dbus-update-activation-environment: setting XDG_SESSION_CLASS=user
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session1
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1001
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=de_DE.utf8
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=lightdm-xsession
dbus-update-activation-environment: setting XAUTHORITY=/home/gast/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm/data/gast
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting GDMSESSION=lightdm-xsession
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1001/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting PWD=/home/gast
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/
/usr/bin/x-session-manager: X server already running on display :0
/usr/bin/iceauth:  creating new authority file /run/user/1001/ICEauthority
xfce4-session-Message: 15:01:32.381: SSH authentication agent is already running
gpg-agent: Ein gpg-agent läuft bereits - ein weiterer wird nicht gestartet

[01mHP Linux Imaging and Printing System (ver. 3.22.6)[0m
[01mSystem Tray Status Service ver. 2.0[0m

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


System Tray monitors the HP device status and Displays

[01mUsage: hp-systray [MODE] [OPTIONS][0m


[01m[MODE][0m
  Run in graphical    -u or --gui (Default)                                 
  UI mode:                                                                  

[01m[OPTIONS][0m
  Use Qt5:            --qt5 (Default)                                       
  Set the logging     -l<level> or --logging=<level>                        
  level:                                                                    
                      <level>: none, info*, error, warn, debug (*default)   
  Run in debug mode:  -g (same as option: -ldebug)                          
  This help           -h or --help                                          
  information:                                                              

  Startup even if no  -x or --force-startup                                 
  hplip CUPS queues                                                         
  are present:                                                              

[31;01merror: option -s not recognized[0m

(xfce4-session:2851): xfce4-session-WARNING **: 15:01:33.799: Unable to launch "anydesk --tray" (specified by autostart/anydesk.desktop): Kindprozess »anydesk« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)

(tracker-miner-fs-3:3054): Tracker-WARNING **: 15:01:33.824: Unable to get XDG user directory path for special directory &DOCUMENTS. Ignoring this location.

(tracker-miner-fs-3:3054): Tracker-WARNING **: 15:01:33.824: Unable to get XDG user directory path for special directory &MUSIC. Ignoring this location.

(tracker-miner-fs-3:3054): Tracker-WARNING **: 15:01:33.824: Unable to get XDG user directory path for special directory &PICTURES. Ignoring this location.

(tracker-miner-fs-3:3054): Tracker-WARNING **: 15:01:33.824: Unable to get XDG user directory path for special directory &VIDEOS. Ignoring this location.

(tracker-miner-fs-3:3054): Tracker-WARNING **: 15:01:33.824: Unable to get XDG user directory path for special directory &DOWNLOAD. Ignoring this location.

(tracker-miner-fs-3:3054): Tracker-WARNING **: 15:01:33.824: Unable to get XDG user directory path for special directory &DOCUMENTS. Ignoring this location.

(tracker-miner-fs-3:3054): Tracker-WARNING **: 15:01:33.824: Unable to get XDG user directory path for special directory &MUSIC. Ignoring this location.

(tracker-miner-fs-3:3054): Tracker-WARNING **: 15:01:33.824: Unable to get XDG user directory path for special directory &PICTURES. Ignoring this location.

(tracker-miner-fs-3:3054): Tracker-WARNING **: 15:01:33.824: Unable to get XDG user directory path for special directory &VIDEOS. Ignoring this location.

** (xfce4-screensaver:3057): WARNING **: 15:01:34.010: Bildschirmschoner läuft bereits in dieser Sitzung

[01mHP Linux Imaging and Printing System (ver. 3.22.6)[0m
[01mSystem Tray Status Service ver. 2.0[0m

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

blueman-applet 15.01.34 WARNING  PluginManager:151 __load_plugin: Not loading PPPSupport because its conflict has higher priority

(tracker-miner-fs-3:3054): Tracker-CRITICAL **: 15:01:34.493: Could not request DBus name 'org.freedesktop.Tracker3.Miner.Files': D-Bus service name:'org.freedesktop.Tracker3.Miner.Files' is already taken, perhaps the application is already running?

** (wrapper-2.0:3042): WARNING **: 15:01:34.520: Binding 'XF86AudioLowerVolume' failed!

(wrapper-2.0:3042): pulseaudio-plugin-WARNING **: 15:01:34.520: Could not have grabbed volume control keys. Is another volume control application (xfce4-volumed) running?

(wrapper-2.0:3080): Gtk-WARNING **: 15:01:34.692: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner XfceArrowButton)

(wrapper-2.0:3043): Gtk-WARNING **: 15:01:34.692: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)

(wrapper-2.0:3042): Gtk-WARNING **: 15:01:34.693: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)
blueman-applet 15.01.34 WARNING  TransferService:213 _make_share_path: Failed to get Download dir from XDG
blueman-applet 15.01.34 WARNING  PluginManager:151 __load_plugin: Not loading DhcpClient because its conflict has higher priority
blueman-applet 15.01.34 ERROR    BasePlugin:83 _load     : g-file-error-quark: Keine Berechtigung (2)
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/blueman/plugins/BasePlugin.py", line 77, in _load
    self.on_load()
  File "/usr/lib/python3/dist-packages/blueman/plugins/applet/KillSwitch.py", line 61, in on_load
    channel = GLib.IOChannel.new_file("/dev/rfkill", "r")
gi.repository.GLib.GError: g-file-error-quark: Keine Berechtigung (2)
blueman-applet 15.01.34 ERROR    PluginManager:165 __load_plugin: Failed to load KillSwitch
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/blueman/main/PluginManager.py", line 163, in __load_plugin
    inst._load()
  File "/usr/lib/python3/dist-packages/blueman/plugins/AppletPlugin.py", line 51, in _load
    super()._load()
  File "/usr/lib/python3/dist-packages/blueman/plugins/BasePlugin.py", line 77, in _load
    self.on_load()
  File "/usr/lib/python3/dist-packages/blueman/plugins/applet/KillSwitch.py", line 61, in on_load
    channel = GLib.IOChannel.new_file("/dev/rfkill", "r")
gi.repository.GLib.GError: g-file-error-quark: Keine Berechtigung (2)
Traceback (most recent call last):
  File "/usr/bin/blueman-applet", line 40, in <module>
    app = BluemanApplet()
  File "/usr/lib/python3/dist-packages/blueman/main/Applet.py", line 44, in __init__
    self.Plugins.load_plugin()
  File "/usr/lib/python3/dist-packages/blueman/main/PluginManager.py", line 125, in load_plugin
    self.__load_plugin(cls)
  File "/usr/lib/python3/dist-packages/blueman/main/PluginManager.py", line 163, in __load_plugin
    inst._load()
  File "/usr/lib/python3/dist-packages/blueman/plugins/AppletPlugin.py", line 51, in _load
    super()._load()
  File "/usr/lib/python3/dist-packages/blueman/plugins/BasePlugin.py", line 77, in _load
    self.on_load()
  File "/usr/lib/python3/dist-packages/blueman/plugins/applet/KillSwitch.py", line 61, in on_load
    channel = GLib.IOChannel.new_file("/dev/rfkill", "r")
gi.repository.GLib.GError: g-file-error-quark: Keine Berechtigung (2)
thunar-volman: Nicht unterstützter USB-Gerätetyp »usb«.
thunar-volman: Nicht unterstützter USB-Gerätetyp »usb-storage«.
thunar-volman: Nicht unterstützter USB-Gerätetyp »usb«.
thunar-volman: Nicht unterstützter USB-Gerätetyp »usb-storage«.

(Thunar:2995): thunar-WARNING **: 15:03:41.407: Content type loading failed for .Xauthority-c: Fehler beim Holen der Informationen für Datei »/home/gast/.Xauthority-c«: Datei oder Verzeichnis nicht gefunden
thunar-volman: Unbekannter Blockgerätetyp »disk«.

Offline

#12 2022-09-27 13:26:09

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: [solved] After update no icons

Here is what I see as the main differences between the two. You may want to fix each one individually to see if it fixes the delay issue:

1. "gnome compatibility is enabled"  - go to Settings Manager > Session and Startup > Advanced and uncheck the "Launch Gnome Services at Startup" checkbox

2. "autostart gnome-settings-daemon" - go to Settings Manager > Session and Startup > Application Autostart and uncheck Gnome Settings Daemon

3. "ATTENTION: default value of option mesa_glthread overridden by environment." - do you have something in your startup files (.bashrc, .bash_profile, .profile, .xprofile) that overrides a MESA value? If so, can you disable it temporarily?

4. "libxfce4ui-WARNING **: 17:02:59.542: ICE I/O Error" - try deleting your ~/.cache/sessions folder while not logged into Xfce.

Offline

#13 2022-09-27 14:41:34

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

Re: [solved] After update no icons

It is very strange!
In the startup files I found nothing which seems to override a MESA value.

Sometimes (not always) after a logout and login the icons appear immediately when I delete the ~/.cache/session folder. At a reboot there is no difference if there is this folder or not. In this case the icons appear mostly after 2 minutes but not ever.

The uncheck of the Gnome services and settings does not make a change.

Offline

#14 2022-09-27 18:09:31

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: [solved] After update no icons

Peter_Ziegler wrote:

It is very strange!
In the startup files I found nothing which seems to override a MESA value.

On further investigation, this appears to be related to firefox and is not relevant to your problem.

Sometimes (not always) after a logout and login the icons appear immediately when I delete the ~/.cache/session folder. At a reboot there is no difference if there is this folder or not. In this case the icons appear mostly after 2 minutes but not ever.

The uncheck of the Gnome services and settings does not make a change.

I'm not sure what else to suggest. Since it seems to work fine in another account, maybe it would be easiest to just start using the other account instead of your main one.

Offline

#15 2022-09-28 08:43:52

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

Re: [solved] After update no icons

Also a deletion of ~/.config/xfce4 folder does not make a change in this behaviour.

A change to a new account is not easy in my case because of many individuell settings and the use of some encrypted hard disks.

Offline

#16 2022-09-28 09:59:03

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: [solved] After update no icons

What are the contents of ~/.config/autostart for both the good and bad profiles? Is the bad profile autostarting some program that is causing the delay?

Offline

#17 2022-10-02 09:55:17

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

Re: [solved] After update no icons

I renamed the autostart folder and disabled all the entries in the settings without success. I don't have another idea.

Offline

#18 2022-10-02 16:12:39

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,528

Re: [solved] After update no icons

I'm out of ideas as well. Since it works well with a new user account, maybe the next best step is to start using this other account as your main account.

Offline

#19 2022-10-16 10:10:24

Peter_Ziegler
Member
Registered: 2009-11-18
Posts: 20

Re: [solved] After update no icons

I realized one time that there is a process gvfsd-trash which consumed a lot of CPU power after login. Then when the icon appear (after the command xfdesktop) the process disappear. Then I deleted manually all the .Trash folders on all HDDs/SDDs and the problem is solved except some shortcuts which do not work (ALT F1, ALT F2, ALT F3).
I don't know the correlation between the icon and the process gvfsd-trash.

Last edited by Peter_Ziegler (2022-10-16 10:11:58)

Offline

Board footer

Powered by FluxBB