Xfce Forum

Sub domains
 

You are not logged in.

#1 2023-01-13 22:09:13

eaterofglass
Member
Registered: 2023-01-13
Posts: 3

[SOLVED] xfce4-panel autohiding broken after update

Hi all,

After updating xfce4-panel today from 4.18.0.1 to 4.18.1-1 on Archlinux, I'm having some very strange behaviour with the autohide feature on my panels. With both 'Always' and 'Intelligent' autohide, panels take a comically long time to disappear from view. I haven't timed how long they take to completely disappear, but my bottom panel is currently only halfway off-screen after more than a minute out of focus. This only seems to happen to horizontal panels when they're at the top and bottom of the screen, and to vertical panels when they're on the sides - vertical panels attached to the top/bottom hide properly, as do horizontal panels attached to the sides (I assume this is because in the former case there is a 'sliding' animation but in the latter case the hide is instantaneous).

Is this related to the update or is possibly a coincidence? As a workaround, can I disable the 'sliding' animation and have all panels disappear instantly somehow regardless of orientation and position?

Cheers!

e

Last edited by eaterofglass (2023-01-16 22:38:15)

Offline

#2 2023-01-13 22:36:57

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: [SOLVED] xfce4-panel autohiding broken after update

Hello and welcome.

I'm also running Arch and am not seeing this issue. Do you have anything in ~/.config/gtk-3.0/gtk.css that overrides the popup and popdown speeds? Or alternatively, can you try a different GTK (Appearance) theme to see if its related to the theme?

And finally, are you running any out of band packages like libxfce4ui-nocsd?


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2023-01-13 23:45:29

eaterofglass
Member
Registered: 2023-01-13
Posts: 3

Re: [SOLVED] xfce4-panel autohiding broken after update

Hi!

Thank you for the quick reply. I don't have a gtk.css in ~/.config/gtk-3.0 so I am not overriding the popup/down speeds there. Switching GTK themes to Adwaita solved it though! The problem seems to be happening with the Nordic series of themes.

When switching themes to test this, I found that this doesn't happen immediately after changing the theme/hide setting - the first two or so times, the panel hides properly. From then onwards the popup/popdown slows to a crawl (of course, the problem doesn't occur at all when using Adwaita). Is there some way I can debug this further?

Offline

#4 2023-01-14 01:05:34

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,772

Re: [SOLVED] xfce4-panel autohiding broken after update

I just installed the Nordic theme to test but could not replicate the issue.

To try to debug some more, try running xfce4-panel in debug mode to see if anything is posted:

xfce4-panel -q
PANEL_DEBUG=1 xfce4-panel

Can you also try to downgrade the panel back to 4.18.0 to see if the problem goes away and if so, you may need to create a bug report.

Here are the changes that happened in 4.18.1.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#5 2023-01-16 22:37:48

eaterofglass
Member
Registered: 2023-01-13
Posts: 3

Re: [SOLVED] xfce4-panel autohiding broken after update

Hi,

Thank you very much for your reply. Downgrading didn't help, but when I uninstalled the nordic-* themes, cleared all their config files, then reinstalled them the problem disappeared. I still don't know what went wrong but the xfce4-panel update seems to have been entirely a coincidence. Sorry for the confusion.

Best regards,

e

Offline

Board footer

Powered by FluxBB