Xfce Forum

Sub domains
 

You are not logged in.

#1 2023-01-13 14:09:11

Angex
Member
Registered: 2023-01-13
Posts: 7

Soundcard

Hello,
I am new to Xfce, but like it a lot. smile
One thing disturb me: For example when I empty the Garbage I can not hear the sound. That is with all the things called "Ereignisklänge" in German. In english it is "Event sounds". All others sounds like music, Youtube etc. is working well. So I think it must be something with the order of my 2 Soundcards. One of them is with NVidia HDMI which my Monitor not support. But I think this Event Sounds are directing to this output, which I not hear. So my question is: How can a change the order of this cards?
Hope you can understand my question and therefor sorry for my poor english as it is not my native language.
Greetings
Andreas

Offline

#2 2023-01-13 14:54:27

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,792

Re: Soundcard

Hello and welcome.

Before you start worrying about the soundcards, make sure that event sounds is properly set up. There have been a number of threads on this forum about getting system sounds set up:

- https://forum.xfce.org/viewtopic.php?id=8618
- https://forum.xfce.org/viewtopic.php?id=7199
- https://forum.xfce.org/viewtopic.php?id=7780
- https://forum.xfce.org/viewtopic.php?id=8782
- https://forum.xfce.org/viewtopic.php?id=9094

...to list a few. Have a read through them to see if they help you get system sounds running.

Note: Since Xfce is based on GTK, the sound event system that works in Xfce is libcanberra (an old GTK project). It hasn't been updated since 2012. Some sound events are supported, but it is not as complete as some other DEs.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2023-01-14 21:43:59

Angex
Member
Registered: 2023-01-13
Posts: 7

Re: Soundcard

Was looking at all that stuff. But my english and my knowledge of Linux is not good enough to find a solution to get the event sounds. sad
Anyway, thanks for the helping hand!

Offline

#4 2023-01-14 23:48:21

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 113

Re: Soundcard

Hello, I found this file in in my Linux Lite install, in /sounds/ lite/ folder. They adapted it from ToZ. Maybe you can understand it better.

Thank you very much to the author "Toz"

1. Install some required packages:
sudo apt-get install gnome-session-canberra sox

2. Download the sound theme

3. Extract the file:
tar xzvf Lite.tar.gz

4. Copy the extracted content ("Lite" folder) to your sounds directory:
/usr/share/sounds
(create the "sounds" directory if it does not exist yet)

5. Enable sound events and feedback sounds.

In example in Mate go to Control Center --> Sounds and enable them there; in Xfce it is done by entering in the terminal:
xfconf-query -c xsettings -p /Net/EnableEventSounds -s true
xfconf-query -c xsettings -p /Net/EnableInputFeedbackSounds -s true


6. Set "Lite" as the default sound theme

In example in Mate go to Control Center --> Sounds and set it there; in Xfce it is done by entering in the terminal:
xfconf-query -c xsettings -p /Net/SoundThemeName -s "Lite"

7. Setup the necessary environment variable. Add to the end of ~/.profile:
Code:

GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
export GTK_MODULES

That should be it. Perhaps a logout is needed before it starts working.

--//--

8. For a startup sound, create a new autostart application (Settings Manager or Control Center >> Session and startup >> Application autostart) with the following parameters:
- Name = Login Sound
- Command = canberra-gtk-play -f /usr/share/sounds/Lite/stereo/desktop-login.oga

9. For logout sound, you need override xfce4-session. To do so, with root privliges, create the file /usr/local/bin/xfce4-session with the following content:

#!/bin/bash

# run the real xfce4-session executable
/usr/bin/xfce4-session

# on exit, run my stuff
canberra-gtk-play -f /usr/share/sounds/Lite/stereo/desktop-logout.oga

...and make this file executable:
sudo chmod +x /usr/local/bin/xfce4-session


Linux Mint Xfce 21.1

Offline

#5 2023-01-14 23:56:44

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 113

Re: Soundcard

Instead of Bolearis theme, you can try this Enchanted.

https://www.linux-apps.com/p/1332121


Linux Mint Xfce 21.1

Offline

#6 2023-01-17 23:05:53

Angex
Member
Registered: 2023-01-13
Posts: 7

Re: Soundcard

Very good hint. I installed that dconf-editor (never heard about it before) and the first thing was that 1 of the 2 boxes for the event sounds was not ticked on. Done that and installed that Enchanted stuff. Now I have at least the liitle sound when a hint pops up. Better than nothing smile and all in all it shows to me that in general the sounding could work.

Last edited by Angex (2023-01-17 23:07:33)

Offline

#7 2023-01-18 03:45:03

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 113

Re: Soundcard

I don't see how dconf-editor helped you. Those two boxes are in Settings>Appearence>Settings tab. I also don't know what 'hint pups up' means. You should have more sound, like minimizing, closing windows, opening the whisker menu etc. I guess, your sound system is still not properly set up. You could also have trash empty sound, shut down sound, but they would take scripts and some extra work, but that's the way to learn. It's all up to you, how far you want to go with it.

Last edited by agashamu (2023-01-18 03:48:02)


Linux Mint Xfce 21.1

Offline

#8 2023-01-18 18:46:14

Angex
Member
Registered: 2023-01-13
Posts: 7

Re: Soundcard

Yes, that was the thing: Those two boxes in Settings>Appearence>Settings were ticked, but in dconf wasn't. So in Appearence>Settings it was wrong shown. dconf showed it right, thats what helped.
The 'hint pups up' sound is "dialog-information.oga" but from the free-desktop theme. Thats also strange.
I know that my sound system is not properly setup. Empty trashcan used to be first check for function, but its silence. Wish I could set it all good.

Offline

#9 2023-01-18 19:01:50

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 113

Re: Soundcard

Free-desktop theme will not create enough sounds for you. Xfce will not create trash-can sound, it needs a script to run.
ToZ has sent you several links to see what needs to be done. Are those too hard for you to follow? I sent you a list, step by step instructions. It can't be any easier then that. What is it you are having problems with?


Linux Mint Xfce 21.1

Offline

#10 2023-01-20 21:12:31

Angex
Member
Registered: 2023-01-13
Posts: 7

Re: Soundcard

Yeah, I'm having trouble following that. It starts with the fact that in your list, point 2, a sound theme is to be downloaded. I can't find that.

Offline

#11 2023-01-20 23:03:10

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 113

Re: Soundcard

You have mentioned above that you already downloaded Enchanted. It should be in your /home/download/ folder. You have to extract that file there. You can do it with archive manager, open it with it, click extract. Or you can try right click on it, then click "extract here", if you have this option in your context menu.
Then you have to move the extracted file to /usr/share/sounds/. This should be opened as root to have the proper permission. Then right click on the extracted Enchanted, copy, and paste into /sounds/ folder. That's it.


Linux Mint Xfce 21.1

Offline

#12 2023-01-24 12:29:01

Angex
Member
Registered: 2023-01-13
Posts: 7

Re: Soundcard

Ok, it is more the point 3 in your list: Extract the file:
tar xzvf Lite.tar.gz , that I can not find.

Offline

#13 2023-01-24 19:40:55

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 113

Re: Soundcard

I mentioned it before, I found that instruction in my Linux Lite distro, that list was modified to Linux Lite. So forget about "Lite", you have Enchanted sound theme instead. Replace "lite" everywhere to Enchanted. Sorry, I taught it was understandable.


Linux Mint Xfce 21.1

Offline

#14 2023-01-25 18:15:34

Angex
Member
Registered: 2023-01-13
Posts: 7

Re: Soundcard

No problem. smile
I have activated the Enchanted Sound Theme, but not all sounds can be heard yet.
I guess I'll have to live with it.
Thanks again.

Offline

#15 2023-01-25 18:19:54

agashamu
Member
From: California
Registered: 2021-03-01
Posts: 113

Re: Soundcard

Good! Keep working on it, you will learn more about Xfce!


Linux Mint Xfce 21.1

Offline

Board footer

Powered by FluxBB