Xfce Forum

Sub domains

You are not logged in.

#1 2023-03-16 13:59:12

From: Freiberg (Saxony), Germany
Registered: 2012-09-14
Posts: 10

starting xfce terminal with specific charset


is there a way to start the terminal with specific charset divergent from the one set in the preferences. I didn't find any cmdline option therefore.

Thx for any hint




#2 2023-03-16 19:36:40

Registered: 2023-03-16
Posts: 14

Re: starting xfce terminal with specific charset

Hi there,

I do not know exactly what you mean by charset, as I believe you have to distinguish keyboard and terminal output. This is what I do:

For the keyboard :  I put  >>setxkbmap -layout gb,de -option "caps:swapescape"<< into my .bashrc. This is a systemwide setting. The second  language  can either be activated by a keystroke combination  OR, what I do install the" keyboard layouts plugin" in my panel.
With this setxkbmap command it will show a nice flag and switch between keyboards. If you look at the configuration of that plugin you can see that it changes on application level by default. So the person using it must just open the terminal and click on the flag. The other applications will still use the other keyboard (the flag will switch to show which keyboard is active)

The -option part is optional, just what I have in my bashrc, so I left it, it changes the escape and capslock key. As many programs accept vim shortcuts  it is very handy, like the vimium addon to browse when I do not have a decent mouse. (Sofa). IF I need capslock it is the ESC button.

Messages of the terminal. You can use the locale variable before invoking your terminal.

1) Either build the necessary locale, or download the locales-all package with synaptic
2) before launching the terminal set the variable LANGUAGE=de_DE.UTF-8
This will make the terminal write error messages in German.

If you want to be thorrow you can also set LC_ALL=de_DE.UTF-8 as well. This is important mainly for the collate variable, which determines a sort order as the English collate will not know what to do with an ü and where to put it (after the u, at the end of the alphabet and will perhaps disregard the word/letter completely.) But all other locales settings are also set.
Test with "locale" command to make sure everything is set right with LC_ALL or set the single variables if this works better for you.


Board footer

Powered by FluxBB