Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-06-27 22:13:27

advice1010
Member
Registered: 2023-02-19
Posts: 95

Keep panel hidden when open Whisker Menu [SOLVED]

I think this one is going to be tricky to achieve.
I would like to be able to set my panel to autohide and only be visible when mouse cursor is dragged to bottom of screen, which I am able to do.  Problem is, I would like to be able to have my panel stay hidden when I hit my super key to open up my Whisker Menu, but unfortunately it makes my hidden panel visible until my menu is closed.
I tried this using Whisker center option and I also tried setting a single hotkey (not super key) to open the menu as well, both did not work.
Also this does this on both panel hiding settings “Intelligently" & "Always"

Does anyone know of any way to prevent this from happening.

Thank You

Last edited by advice1010 (2024-06-30 22:24:09)

Offline

#2 2024-06-27 22:33:26

Tamaranch
Member
Registered: 2020-12-31
Posts: 305

Re: Keep panel hidden when open Whisker Menu [SOLVED]

This is an enhancement request you should make to whiskermenu, which can decide whether or not to ask the panel to show up when the menu is shown. With applicationsmenu (shipped with the panel), the panel is shown if the menu is shown at widget, but not if it's shown at pointer (at least for sufficiently recent panel versions).

Offline

#3 2024-06-28 06:27:42

gogogadget
Member
Registered: 2023-03-19
Posts: 21

Re: Keep panel hidden when open Whisker Menu [SOLVED]

advice1010 wrote:

Problem is, I would like to be able to have my panel stay hidden when I hit my super key to open up my Whisker Menu, but unfortunately it makes my hidden panel visible until my menu is closed.

Does anyone know of any way to prevent this from happening.

It works if you launch Whiskermenu at the center of the screen or at the cursor position with :

xfce4-popup-whiskermenu -c

or

xfce4-popup-whiskermenu -p

Xfce+gtk3-classic (no CSD)+Picom

Offline

#4 2024-06-28 08:42:23

Tamaranch
Member
Registered: 2020-12-31
Posts: 305

Re: Keep panel hidden when open Whisker Menu [SOLVED]

Ah yes indeed it works, I should have checked before prompting to open an feature request. There's a warning relating to autohide though, so I wonder if it doesn't work by accident actually. I'll report this on gitlab.

Offline

#5 2024-06-28 11:45:46

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 441

Re: Keep panel hidden when open Whisker Menu [SOLVED]

This is the problem with Whiskermenu being a panel plug-in. It relies on the panel to work, this is why the panel appears when you hit your hotkey. Would be nice if Whiskermenu could be standalone rather than a plug-in.


Siduction
Debian Sid
Xfce 4.18

Offline

#6 2024-06-28 14:34:44

gogogadget
Member
Registered: 2023-03-19
Posts: 21

Re: Keep panel hidden when open Whisker Menu [SOLVED]

Tamaranch wrote:

Ah yes indeed it works, I should have checked before prompting to open an feature request.

I know this, because there was a time I launched whiskermenu at the center of the screen smile, few years ago, I switched to Ulauncher.


Xfce+gtk3-classic (no CSD)+Picom

Offline

#7 2024-06-30 21:32:34

advice1010
Member
Registered: 2023-02-19
Posts: 95

Re: Keep panel hidden when open Whisker Menu [SOLVED]

Ahh thank you guys for all the responses.
My system has this setup a little differently.
First time I tried this it didn't work but I tried this again a different way, using the -c option this time works now.
Thank you guys again for confirming this for me.

Offline

Board footer

Powered by FluxBB