Xfce Forum

Sub domains
 

You are not logged in.

#1 2016-09-03 03:17:38

dtd
Member
Registered: 2011-12-08
Posts: 37

xdm in FreeBSD

I installed FreeBSD 10.3, xorg-7.7_2, xdm-1.1.11_3 and xfce-4.12_1

xdm fails with the error:

   /usr/local/bin/startxfce4: X server already running on display :0
   XDM authorization key matches an existing client!xfce4-session: Cannot open display: .
   Type 'xfce4-session --help' for usage.

So I copied /usr/local/etc/X11/xinit/xinitrc to .xinitrc in my home directory. I have a .xsession file:

    #!/bin/sh
    /usr/bin/ssh-agent /usr/local/bin/startxfce4

This setup works once after a boot. After logging out a subsequent login fails as above. startx and startxfce4 work fine when started from a user login.

The really frustrating part is I fixed this for a FreeBSD 10.1 system running the same xfce and slightly older versions of xorg and xdm. I compared /usr/local/etc/X11 and /usr/local/lib/X11 on both systems and can find nothing different.

So basically, I'm lost; any help greatly appreciated. Sure am sorry I lost my notes sad

Offline

#2 2016-09-03 18:46:05

dtd
Member
Registered: 2011-12-08
Posts: 37

Re: xdm in FreeBSD

I have narrowed this down to what seems to be a bug or an interface problem between xfce and xorg. It seems almost certain this happens only on FreeBSD. Hence ain't gonna get fixed, if for no other reason than AFAIK from google and FreeBSD mailinglists this issue affects a universe of one.

First this issue does not occur for a freshly created user. My userid drags along the menus, desktop configurations, etc, etc from at least xfce 4.10. The issues are around session information not being deleted at logoff. I got a 2nd login to work by deleting .cache/sessions, .dbus and all files and directories related to dbus and .Xauthority stuff. In FreeBSD this is in $home and /tmp/.  Required changes to make this work are not to use hal or dbusd and to comment the last line in /usr/local/lib/X11/xdm/xdm-config as the comment says to do. I think (but am not sure) "!command" is not a comment but "! command: is.

wdm does not work or requires too much research, slim works but needs hal (going away in FreeBSD) and dbusd and has the irritating side-effect of putting 3 virtual devices on the desktop. And, slim has not been updated since 2014.

Anyway we use some of the remote stuff in xdm and it's not going away until Xorg is replaced. My hope is someone can tell me how I can carry forward my desktop and menu setting and (hopefully) delete the offending structure(s).

Offline

#3 2016-09-03 19:14:19

dtd
Member
Registered: 2011-12-08
Posts: 37

Re: xdm in FreeBSD

Well I spoke too soon. I could log in 2 times with the new user and now both ids work the same. That's more logical. That put it on Xorg I thing because it always works with startx or startxfce4 in user land. Sorry for the noise, thought I had made progress

Offline

Board footer

Powered by FluxBB