Xfce Forum

Sub domains

You are not logged in.

#1 2016-11-01 17:42:37

Registered: 2013-02-27
Posts: 9

Window Manager shortcuts do not work with remapped keys

I have used xmodmap to remap some keys. Specifically,

Insert -> Home

But when I press Ctrl+Alt+"Insert (remapped to Home)" the window doesn't move to the next workspace (which it should, as the default behavior)

I've done experimenting, and what I've found is that any command I set from Settings>Keyboard>Application Shortcuts work, and none of the commands set at Settings>Window Manager>Keyboard work (with remapped keys).

Specifically, the settings property (/commands/custom/<Primary><Alt>Home) will work for every command, but the property (/xfwm4/custom/<Primary><Alt>Home) will not for any command.

And this is not just for Insert remapped to Home, it is for any key that has been remapped in X.

I should also add that my Insert key functions perfectly as a Home key in every other scenario and with every other program. What I suspect is happening, is that xfwm is using the keycodes as they are defined directly in the keymap, instead of using keycodes in X that have been processed by xmodmap. That is to say, I think xfwm is using the keycodes which are defined for the virtual console environment instead of using the keycodes which are defined for the X environment.


I just did another test, and it showed more strange behavior. Here is part of my .Xmodmap file:

keycode  11 = 3 at 2 at
keycode  12 = 3 numbersign 3 numbersign

As you can see, I have remapped "2" to "3". I then set <Primary><Alt>3 to fullscreen_key for xfwm. When I pressed Ctrl+Alt+2, it went fullscreen as you would expect. But when I pressed <Ctrl><Alt>3 (the 'real' 3 key) it did not go fullscreen. This made me think that the keyboard shortcuts were being bound to keycodes instead of their values, but then I undid my change in Xmodmap without making any changes to the settings, and Ctrl+Alt+2 no longer worked but Ctrl+Alt+3 had started working. So clearly it's not just based on the keycodes.

Could anyone confirm that this also happens for them and that I'm not just crazy? I think this is a legitimate bug, but I guess it's possible that something is messed up on my my machine, so I'd like someone to confirm first.

Last edited by beardedlinuxgeek (2016-11-01 17:52:19)


Board footer

Powered by FluxBB