Xfce Forum

Sub domains
 

You are not logged in.

#1 2016-12-15 19:46:23

rjflory
Member
Registered: 2014-09-16
Posts: 7

How to disable workspace pager looping

I would very much like to not have the pager loop from last->first or first->last when switching pages with ctrl-alt-arrow keys.

I did see a related post @ http://forum.xfce.org/viewtopic.php?id=7002

but this seemingly correct setting has no effect.  Is this setting broken in XFCE 4.12?

Am running FC24 distro.

ron

Last edited by rjflory (2016-12-15 19:46:49)

Offline

#2 2016-12-15 21:38:55

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 420
Website

Re: How to disable workspace pager looping

I think that settings is for using the mouse wheel. It does change that behaviour, you can't scroll from e.g. (with 4 workspaces)1 to 4 or 4 to 1 without it being selected.  If you are using the keys it will go to whichever workspace you choose.

Offline

#3 2016-12-16 16:19:02

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,702

Re: How to disable workspace pager looping

Try unchecking the other option there (Settings Manager > Window Manager Tweaks > Workspaces), "Wrap workspaces depending on the actual desktop layout". That seems to stop keyboard based looping of workspaces on a default install.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#4 2017-01-03 19:59:41

rjflory
Member
Registered: 2014-09-16
Posts: 7

Re: How to disable workspace pager looping

Sorry, I tried that, but does not work.

Basically, try using   <ctrl>-<alt>-<right-arrow>  to switch to the "next" relative page.  I'd like to make this to stop when i'm in the last/final page, and NOT wrap to the first page.    Same issue happens when switching to "previous" page using  <ctrl>-<alt>-<left-arrow> 
ron

Offline

#5 2017-01-03 20:48:45

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,702

Re: How to disable workspace pager looping

That's interesting. When I uncheck that option, Ctrl+Alt+arrow no longer loops around from the last workspace to the first or vice versa. Can you post back the results of the following command (to check your configuration settings)?

xfconf-query -c xfwm4 -lv

How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#6 2017-01-04 14:05:02

rjflory
Member
Registered: 2014-09-16
Posts: 7

Re: How to disable workspace pager looping

OK, I read and looked a little more carefully this time...

As you requested, I disabled (Settings Manager > Window Manager Tweaks > Workspaces), "Wrap workspaces depending on the actual desktop layout". and this does indeed stop the wrap problem.

But isn't this the wrong config option?  I assumed this one dealt with workspaces spanning several monitors (i.e., "desktop layout").


To me at least, the other option on this dialog  "Window Manager Tweaks -> Workspaces -> Wrap workspaces when the first or last workspace is reached" seems to be the config option that should be considered here (instead).

??

Thanks.

Last edited by rjflory (2017-01-04 14:18:21)

Offline

#7 2017-01-04 20:59:07

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 420
Website

Re: How to disable workspace pager looping

I always took "desktop layout" to mean the number of workspaces and number of rows. I don't see any connection with multiple monitors.

Offline

Board footer

Powered by FluxBB