Xfce Forum

Sub domains
 

You are not logged in.

#1 2016-12-21 23:23:32

IpreferXfce
Member
Registered: 2016-02-25
Posts: 6

Issue with audacity invading another workspace....

Sometimes I want to open up lots of mp3 files in audacity.  Each file opens in a separate window.  But sometimes while I'm waiting for all the files to open up, I switch to a different workspace.  When I do audacity follows me.  Soon I have windows opening up on the workspace I switched to as well as some of them open on the original workspace.  Is there anything I can do to confine a program like audacity to just the one workspace so that I can get other things done on another workspace?

Offline

#2 2016-12-22 01:30:44

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,273

Re: Issue with audacity invading another workspace....

Try setting Settings Manager > Windows Manager Tweaks > Focus tab > "When a window raises itself" to "Do nothing". This should allow the windows to keep opening in the original tab while you cycle around workspaces. The other option is to use something like devilspie.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2016-12-23 00:29:53

rijnsma
Member
From: NL
Registered: 2011-09-05
Posts: 38

Re: Issue with audacity invading another workspace....

It is not only in programs like audacity, I also have it in Vivaldi-browser in some workspace opening tabs opening links of a mailprogram (in another workspace). And not after a fixed number of tabs open, but after some links from certain forums.
Here it looks like it has something to do with news-notification of the feedreader quiterss. So it looks like a bug.
I switched off quiterss notification and checked before that what ToZ wrote. For the moment all goes well.
I hope this can be of help.

Last edited by rijnsma (2016-12-23 00:31:00)

Offline

#4 2016-12-23 17:39:32

rijnsma
Member
From: NL
Registered: 2011-09-05
Posts: 38

Re: Issue with audacity invading another workspace....

Today I was suspicious about my browser (Vivaldi 1.6...).
So I went back to 1.3..
Problem over..! No more disappearance of tabs, no more jumping to a workspace where the link for a tab in Vivaldi has been clicked.
I have posted the problem in the Vivaldi-forum. (But it is also in audacity.)
Could it be something in a compiler the software-developer works with? I keep in mind the post of IpreferXfce .

Offline

#5 2017-01-22 02:03:48

IpreferXfce
Member
Registered: 2016-02-25
Posts: 6

Re: Issue with audacity invading another workspace....

ToZ wrote:

Try setting Settings Manager > Windows Manager Tweaks > Focus tab > "When a window raises itself" to "Do nothing". This should allow the windows to keep opening in the original tab while you cycle around workspaces. The other option is to use something like devilspie.

I tried the first option once and it didn't help.  Do you need to logout and then log back in before it takes effect?

Offline

Board footer

Powered by FluxBB