Xfce Forum

Sub domains

You are not logged in.

#1 2017-02-19 08:22:33

From: surface of planet Earth
Registered: 2013-06-15
Posts: 367

starting Xfce4 unde Xtightvnc fails

the world has changed for me and i am now running Ubuntu (16.04.2 LTS) and Unity.  i'd like to get back to Xfce but for various reasons i can't go into i also need to keep running Unity.   so my idea is to run it under Xtightvnc.   i will also be running some hosts in cloud instances and want to have a desktop ready there and Xfce seems to be a good choice.  i installed Xfce4 via apt-get install. so when i run Xfce under Xtightvnc i get an odd error message that seems to be wrong.  i run /usr/bin/xsetroot under Xtightvnc first to set the background green.  that much works as i do get the solid green background when i connect to it with a vnc client.  then i run /usr/bin/startxfce4.  the logged error messages are:

/usr/bin/startxfce4: X server already running on display :16
Xlib:  extension "RANDR" missing on display ":16".
xfce4-session: Another session manager is already running

well, or course an X server is already running ... i started Xtightvnc on :16

i don't how to deal with extension "RANDR" missing but it doesn't seem to stop things.

the 3rd error may be stopping things.  it doesn't make sense as the X session was just started unless it is looking at :0 by mistake or omission.

i have not tried any other DE yet, as i am unfamiliar with all others but KDE which i know the be rather big.  since a friend of mine uses Cinnamon i thought i might try that and see what works.

Last edited by Skaperen (2017-02-19 08:26:43)


Board footer

Powered by FluxBB