Xfce Forum

Sub domains

You are not logged in.

#1 2017-02-27 05:28:39

Registered: 2017-02-27
Posts: 1

XFCE spinning up all hard drives on login

Hi there,

I'm running lightdm 1.20.0 and xfce 4.12 on Arch. I've set my HDD to spin down on boot (as outlined here). However, whenever I log into XFCE for the first time on a particular boot cycle, something is causing the drive to spin up even though all partitions on the drive are unmounted.

I suspected at first that thunar or synapse was probing all mountpoints, so I unmounted all partitions on the device in question. I don't know how to ensure gvfs isn't to blame. I've tried disabling all of the autostart scripts in the xfce settings manager. I've unchecked the thunar settings for volume management and automounting. I don't know what else to do, and I was wondering if anyone here might any any ideas for what else I can try. Something must be scanning all devices at login in order to make them easier to mount through the GUI, but I don't know where to look.

Unfortunately, I don't have audit in my kernel, so I've been unable to determine which particular process is probing the device.

Thanks in advance for any help you can provide!

Last edited by crendel (2017-02-27 06:34:30)


Board footer

Powered by FluxBB