Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-10-04 21:49:05

SpaceHamster7
Member
Registered: 2017-10-04
Posts: 2

xfce4-panel - anyone have a clue?

Hello everyone I am running Gentoo and
xfce4-panel      4.13.1
has been released on our build list.
It compiles fine without any errors but I am at a total loss figuring this one out as I do not get any debug messages for anything wrong.

The icons will not display only in xfce4-panel

[url=https://i.imgur.com/gvHErdb.png]
  gvHErdbl.png
[/url]

On the desktop they display just fine, and also display fine in whiskers menu

[url=https://i.imgur.com/GcxOllf.png]
  GcxOllfl.png
[/url]

I've tried manually moving the png files to home folder, changing permissions, changing it to jpg, etc...
Also, one other problem cropped up right after the 4.13.1 release. Network Manager applet no longer displays the correct global theme.
So it has an oddball looking background on the panel.

[url=https://i.imgur.com/Rql12zz.png]
  Rql12zzl.png
[/url]

This probably has something to do with internal changes or maybe a change in the way the configuration files work.
If I spent enough time going over the commits I know I can probably track it down but I figure that communities are here to help speed research up, so I am asking if anyone has a clue for possible fixes?

Thank you.

Offline

#2 2017-10-05 12:46:48

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,806

Re: xfce4-panel - anyone have a clue?

The icons will not display only in xfce4-panel

I don't usually use launchers in the panel so I added one and tried to set a custom icon, and you are correct, it does not work. I believe it was this commit that is the culprit. You'll notice that it no longer uses the internal xfce_panel_image_new_from_source() function but rather regular GTK gtk_image_new_from_icon_name(). Which means it uses the icon name to find the appropriate icon via the icon spec.

Ultimately, I believe a bug report should be created as we can no longer use the panel config GUI to use a custom icon (I will create a bug report).

Edit: bug report created: https://bugzilla.xfce.org/show_bug.cgi?id=13900

As a work around, find the proper panel desktop file for the launcher in ~/.config/xfce4/panel/launcher-? and change the icon name so that it is just the name of the icon. For example, I changed "/home/toz/.icons/app.svg" to just "app" and copy the app.svg icon file to ~/.icons.

Also, one other problem cropped up right after the 4.13.1 release. Network Manager applet no longer displays the correct global theme.

I can't replicate this problem using the default Adwaita theme. What theme are you using? Have you tried other themes? Adwaita or Greybird (which has kept up with the xfce4-panel changes during the migration to GTK3) would be good to test with.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Online

Board footer

Powered by FluxBB