Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-11-17 01:20:00

ex-voto
Member
Registered: 2017-11-17
Posts: 3

[Solved] Cannot get some icons working in the launcher

I have a panel with a few launchers which each launch one application. Vim and Firefox work nicely. But, my preferred terminal program, Urxvt, does not have an icon, just a blank area in the panel which highlights when I hover my mouse over it.

I can right click and select the launcher properties, highlight urxvt and click the edit button, and I can select any icon I desire. Regardless of what icon I choose, the launcher does not show anything. The editor dialog does show the icon that ought to display, but, at the end, the launcher does not.

If, however, I try to change the icon for Firefox, for example, it is properly changed.

Also, if I change my icon set to one which seems to have a default icon for Urxvt, then it will show up in the launcher. The icon set I am using which does not have a default icon for Urxvt is Enlightenment-X. I would be okay with this if selecting an icon myself actually worked.

Last edited by ex-voto (2017-11-18 01:10:12)

Offline

#2 2017-11-17 02:36:41

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 3,893

Re: [Solved] Cannot get some icons working in the launcher

Hello and welcome.

Can you tell us what version of Xfce and xfce4-panel you are using?

Also, post back the results of:

xfconf-query -c xfce4-panel -lv

...as well as

for file in ~/.config/xfce4/panel/launcher*/*; do echo "###FILE=$file"; cat $file; done

...so we can see the content of the launcher files.

And one more thing, the content of ~/.gtkrc-2.0.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2017-11-17 11:07:04

ex-voto
Member
Registered: 2017-11-17
Posts: 3

Re: [Solved] Cannot get some icons working in the launcher

Hello! Thank you for your reply. Here is the information you requested. I'm running Arch Linux. I do not know which package is the one for Xfce, so here are a bunch. I believe the panel I'm having problems with is panel 2.

jlm@mcp:~/downloads 58> pacman -Ss xfce  | grep installed
extra/exo 0.11.5-1 (xfce4) [installed]
extra/garcon 0.6.1-1 (xfce4) [installed]
extra/gtk-xfce-engine 2.10.1-1 (xfce4) [installed]
extra/libxfce4util 4.12.1-1 [installed]
extra/thunar 1.6.12-1 (xfce4) [installed]
extra/thunar-volman 0.8.1-2 (xfce4) [installed]
extra/tumbler 0.2.0-1 (xfce4) [installed]
extra/xfce4-appfinder 4.12.0-4 (xfce4) [installed]
extra/xfce4-panel 4.12.1-1 (xfce4) [installed]
extra/xfce4-power-manager 1.6.0.41.g9daecb5-1 (xfce4) [installed]
extra/xfce4-session 4.12.1-7 (xfce4) [installed]
extra/xfce4-settings 4.12.1-1 (xfce4) [installed]
extra/xfce4-terminal 0.8.6-1 (xfce4) [installed]
extra/xfconf 4.12.1-4 (xfce4) [installed]
extra/xfwm4 4.12.4-1 (xfce4) [installed]
extra/xfwm4-themes 4.10.0-2 (xfce4) [installed]
jlm@mcp:~/downloads 59> xfconf-query -c xfce4-panel -lv
/configver                                    2
/panels                                       <<UNSUPPORTED>>
/panels/panel-1/length                        100
/panels/panel-1/plugin-ids                    <<UNSUPPORTED>>
/panels/panel-1/position                      p=6;x=0;y=0
/panels/panel-1/position-locked               true
/panels/panel-1/size                          30
/panels/panel-2/background-alpha              0
/panels/panel-2/background-color              <<UNSUPPORTED>>
/panels/panel-2/background-style              0
/panels/panel-2/disable-struts                false
/panels/panel-2/enter-opacity                 100
/panels/panel-2/leave-opacity                 49
/panels/panel-2/length                        1
/panels/panel-2/length-adjust                 true
/panels/panel-2/mode                          0
/panels/panel-2/plugin-ids                    <<UNSUPPORTED>>
/panels/panel-2/position                      p=12;x=1254;y=1575
/panels/panel-2/position-locked               true
/plugins/plugin-1                             applicationsmenu
/plugins/plugin-11                            launcher
/plugins/plugin-11/items                      <<UNSUPPORTED>>
/plugins/plugin-11/show-label                 false
/plugins/plugin-13                            separator
/plugins/plugin-13/style                      1
/plugins/plugin-15                            separator
/plugins/plugin-15/expand                     true
/plugins/plugin-15/style                      0
/plugins/plugin-16                            launcher
/plugins/plugin-16/items                      <<UNSUPPORTED>>
/plugins/plugin-17                            mixer
/plugins/plugin-17/command                    xfce4-mixer
/plugins/plugin-17/enable-keyboard-shortcuts  true
/plugins/plugin-17/sound-card                 HDAIntelAlsamixer
/plugins/plugin-17/track                      Master
/plugins/plugin-2                             actions
/plugins/plugin-3                             tasklist
/plugins/plugin-4                             pager
/plugins/plugin-5                             clock
/plugins/plugin-5/digital-format              %a, %b %e %I:%M %p
/plugins/plugin-6                             systray
/plugins/plugin-6/names-visible               <<UNSUPPORTED>>
/plugins/plugin-8                             separator
/plugins/plugin-8/style                       1
/plugins/plugin-9                             launcher
/plugins/plugin-9/items                       <<UNSUPPORTED>>
jlm@mcp:~/downloads 60> for file in ~/.config/xfce4/panel/launcher*/*; do echo "###FILE=$file"; cat $file; done###FILE=/home/jlm/.config/xfce4/panel/launcher-11/15108790052.desktop
[Desktop Entry]
Hidden=false
Exec=/usr/bin/urxvt -bg black -fg white -cr red --color4 SteelBlue3 --color12 SteelBlue1 -fn 9x15 -title mcp -sr -sl 2000
Icon=utilities-terminal
Type=Application
NoDisplay=false
Version=1.0
StartupNotify=false
StartupWMClass=
GenericName[en_US]=
Comment=An unicode capable rxvt clone
DBusActivatable=false
Categories=System;TerminalEmulator;
Terminal=true
Name=urxvt
GenericName=
Icon[en_US]=/usr/share/pixmaps/steam.png
Name[en_US]=urxvt
Comment[en_US]=An unicode capable rxvt clone
X-XFCE-Source=file:///home/jlm/.local/share/applications/urxvt.desktop
Path=
###FILE=/home/jlm/.config/xfce4/panel/launcher-16/14841790726.desktop
[Desktop Entry]
Name=GVim
GenericName=Text Editor
Comment=Edit text files
TryExec=gvim
Exec=gvim -f %F
Terminal=false
Type=Application
Keywords=Text;editor;
Icon=gvim
Categories=Utility;TextEditor;
StartupNotify=true
MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
X-XFCE-Source=file:///usr/share/applications/gvim.desktop
###FILE=/home/jlm/.config/xfce4/panel/launcher-9/15108790684.desktop
[Desktop Entry]
Version=1.0
Name=Firefox
GenericName=Web Browser
Comment=Browse the Web
Exec=/usr/lib/firefox/firefox %u
Icon=firefox
Terminal=false
Type=Application
MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
StartupNotify=true
StartupWMClass=Firefox
Categories=Network;WebBrowser;
Keywords=web;browser;internet;
Actions=new-window;new-private-window;
X-XFCE-Source=file:///usr/share/applications/firefox.desktop

Path=

[Desktop Action new-window]
Name=New Window
Name[en_US]=New Window
Exec=/usr/lib/firefox/firefox --new-window %u

[Desktop Action new-private-window]
Name=New Private Window
Name[en_US]=New Private Window
Exec=/usr/lib/firefox/firefox --private-window %u
jlm@mcp:~/downloads 61> cat ~/.gtkrc-2.0
.gtkrc-2.0      .gtkrc-2.0.bak  
jlm@mcp:~/downloads 61> cat ~/.gtkrc-2.0
# DO NOT EDIT! This file will be overwritten by LXAppearance.
# Any customization should be done in ~/.gtkrc-2.0.mine instead.

include "/home/jlm/.gtkrc-2.0.mine"
gtk-theme-name="delorean-dark-theme-P-3.9"
gtk-icon-theme-name="oxygen"
gtk-font-name="Linux Libertine Display O 10"
gtk-cursor-theme-name="Adwaita"
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_BOTH
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintfull"
gtk-xft-rgba="rgb"
jlm@mcp:~/downloads 62> cat /home/jlm/.gtkrc-2.0.mine
cat: /home/jlm/.gtkrc-2.0.mine: No such file or directory

Offline

#4 2017-11-17 14:51:56

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 3,893

Re: [Solved] Cannot get some icons working in the launcher

Everything looks okay there.

I downloaded and installed the icon theme and it appears to be an issue with the icon theme itself. I didn't look to find out what the issue exactly was, but the theme itself inherits from:

Inherits=Mint-X,RAVE-X,Faenza,hicolor

Try installing the Mint-X icon theme - it will provide/override the missing icon.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#5 2017-11-18 01:09:32

ex-voto
Member
Registered: 2017-11-17
Posts: 3

Re: [Solved] Cannot get some icons working in the launcher

Thanks a lot. That works and now the icons show up. Oddly, though, if I try to change the icon, it retains the default terminal icon, and does not accept the one I have selected, despite the fact that it shows up properly in the dialog box. I'm not too concerned about that, at least I have something to click on.

Offline

Board footer

Powered by FluxBB