Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-02-17 10:50:20

eskimos
Member
Registered: 2015-10-02
Posts: 5

[Solved] xfwm4 doesn't load at login

I wanted to test different options and I used 'kwin_x11 --replace'. But then I used 'xfwm4 --replace'. The problem is that now every time I log in to Xfce I have no window manager active at all and I need to repeat this command 'xfwm4 --replace' every time I log in to Xfce. What to do to have xfwm4 active permanently, at every login?
In .xinitrc I have: 'startkde' value. When I am in Xfce I want xfwm4 but when I am in Plasma KDE I want kwin. At least untill I decide to have one desktop environment.

Last edited by eskimos (2018-02-19 12:52:24)

Offline

#2 2018-02-17 12:49:44

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,015

Re: [Solved] xfwm4 doesn't load at login

Menu / Settings / Session and Startup, then go to the Application Autostart tab and add an entry for xfwm4 --replace , maybe? Or (re-)enable xfwm's entry if one already exists?


BtW, I have read many times that installing one or more desktop environments on top of what the distro already provides by default tends to create issues. I suppose this is one of them.

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#3 2018-02-19 12:51:54

eskimos
Member
Registered: 2015-10-02
Posts: 5

Re: [Solved] xfwm4 doesn't load at login

I have solution:
Don't use option to save sessions. Make sure you don't have option to save session marked in settings Session and Startup and delete the content of /home/user_name/.cache/sessions.

Offline

Board footer

Powered by FluxBB