Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-05-02 18:27:23

lowin
Member
Registered: 2018-05-02
Posts: 2

[Solved] How to stop xfsettingsd to change my monitor settings

Hello. I'm using a dual monitor setup.
I have my xorg.conf to configure my monitors exactly the way I want them, and it works great in lightdm login screen
However, when I log into xfce, xfsettingsd loads per user setting for monitors and change the settings, Which is not what I want.
I changed the monitor settings in the display settings program, and now it works almost fine. but now when I turn one of the displays off, the other screen goes blank for a few seconds and changes display settings again and messing with the desktop icon placements (the 2 monitors are not the same resolution), which repeats when I turn the second monitor on again.

I realized this won't happen when I kill xfsettingsd daemon, but killing it has some other unwanted side effects that I don't wish to deal with.
Is there a way to just disable Xfce's monitor management and leave it to xorg.conf? I considered patching xfsettingsd, but I don't know what code to change for least amount of side effects/potential problems.

I appreciate any help. thank you

Last edited by lowin (2018-05-03 06:44:29)

Offline

#2 2018-05-02 23:54:38

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,046

Re: [Solved] How to stop xfsettingsd to change my monitor settings

Hello and welcome.

lowin wrote:

Is there a way to just disable Xfce's monitor management and leave it to xorg.conf?

Unfortunately no.

I considered patching xfsettingsd, but I don't know what code to change for least amount of side effects/potential problems.

The display module requires xrandr to function. In configure.ac.in there is a check for xrandr:

dnl ***********************************
dnl *** Optional support for Xrandr ***
dnl ***********************************
XDT_CHECK_OPTIONAL_PACKAGE([XRANDR], [xrandr], [1.2.0],
                           [xrandr], [Xrandr support])

As a test, I changed the "1.2.0" to a non-existent version "10.2.0" and rebuilt the package (commenting out the lines didn't help). As expected, the display module didn't work anymore. But I am unable to test the full functionality with dual monitors.

To do this properly, you should probably create an enhancement request to see if the developer will consider making the xrandr functionality optional at build time.

Offline

#3 2018-05-03 06:44:09

lowin
Member
Registered: 2018-05-02
Posts: 2

Re: [Solved] How to stop xfsettingsd to change my monitor settings

I did what you said and disabled xrandr support. now xfce doesn't touch my monitors at all.
Thank you.

I suppose an even more proper solution will be adding a setting in xfconf to disable display support at runtime. maybe even a checkbox in the display setting window. Unfortunately I don't have much free time to study the code and supply the patch right now. I'll do it once I can get familiar with the code in the coming months.

In the meantime, forcefully disabling xrandr support is a good workaround.
Thank you again

Offline

#4 2018-11-14 17:04:58

poleguy
Member
Registered: 2018-11-14
Posts: 2

Re: [Solved] How to stop xfsettingsd to change my monitor settings

I have a similar problem. When my dual DisplayPort monitors wake up from sleep or are power cycled it resets the desktop and I get duplicated displays (mirrored).

It seems related to this: https://forum.xfce.org/viewtopic.php?id=10951

And then to this:
https://bugzilla.xfce.org/show_bug.cgi?id=11107

I haven't gone and debugged this, but the code there seems to set crtc->x and crtc->y to 0,0 which is wrong, because these are not "new outputs" they are just being turned back on. Very disappointing.

Although this is not directly related to your case, the solution might be the same: Having a 'disable monitor management' option would be great.

This automatic stuff is fine until it's not.

This may force me to learn how to compile xfce... (Is there a tutorial?)

Can I encourage you to investigate adding a patch? How can I help?

Nick

Offline

#5 2018-11-14 17:46:37

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,046

Re: [Solved] How to stop xfsettingsd to change my monitor settings

Hello and welcome to the forums, @poleguy.

I would first encourage you to try, if possible, the latest git version of xfce4-settings. There have been numerous patches/fixes/enhancements added to it. Some of them are described here:
- https://simon.shimmerproject.org/2018/1 … play-land/
- https://simon.shimmerproject.org/2018/1 … s-release/

If you would like to pursue the option of a patch, the recommended method is to create a bug report (https://bugzilla.xfce.org/) to see if the developer is interested. Providing a patch would be helpful.

Offline

#6 2018-11-19 08:57:36

poleguy
Member
Registered: 2018-11-14
Posts: 2

Re: [Solved] How to stop xfsettingsd to change my monitor settings

Ah, thanks for the links... I didn't realize this was actively being worked on.

Well, after a bit of a learning curve I managed to recompile xfce4-display-settings from git.

It sort-of fixes it.

If I set "Configure new displays when connected" and "Automatically enable profiles when new display is connected" it will no longer come up mirrored. However it puts a selection dialog box on the screen after the display comes back on. If I don't select "configure new displays when connected" it gets rid of the dialog box pop-up but it mirrors the displays.

For a real fix to my problem, I think there needs to be an option to have it configure the displays, use the profiles, but not show the dialog box.

Now that I have the source building I wonder if I could make a fix to make that happen on my own. Or maybe I can get the attention of Simon Steinbeiß...

Thanks!

Offline

#7 2018-11-19 14:13:34

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,046

Re: [Solved] How to stop xfsettingsd to change my monitor settings

poleguy wrote:

Or maybe I can get the attention of Simon Steinbeiß...

One way to do this is via a bug report.

Offline

Board footer

Powered by FluxBB