Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-07-03 20:58:10

trk204
Member
Registered: 2018-03-15
Posts: 8

[SOLVED] Missing menu icons in applications menu for custom entries

Hey guys,  running debian stretch with xfce 4.12.

When adding some custom xdg compliant menu entries,  then menu structure appears fine in the menu,  only to have a no icon available image for the menu entries.

Currently running the tango icon theme,  all other icons are working.

The custom .directory entries have Icon= declared.  The icon file permissions are correct and can be displayed via whatever means you want.  The icon name is currently the complete location of the file,  not just the icon name ie /opt/data/share/images/mm48.gif

Do I need to configure some custom icons in the tango theme for these to shop up in the menu?

FWIW these menu entries are working fine in KDE plasma,  I'm just looking into moving us into xfce.

Thanks!

Last edited by trk204 (2018-07-04 14:11:11)

Offline

#2 2018-07-04 00:11:18

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,421

Re: [SOLVED] Missing menu icons in applications menu for custom entries

I can replicate the issue on 4.12 but not on the newer 4.13 development releases, so the issue has probably been fixed. What version of garcon are you running?

As a workaround, place the icon file in ~/.icons and specify the icon as name only. Example:

Icon=xmms

Links will also work if you don't want to copy file.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2018-07-04 14:10:53

trk204
Member
Registered: 2018-03-15
Posts: 8

Re: [SOLVED] Missing menu icons in applications menu for custom entries

Awesome,  thanks for the assist.  I'll try the local icons directory.  If that doesn't work,  it's not a show stopper.

Offline

Board footer

Powered by FluxBB