Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-07-14 11:43:17

afg984
Member
Registered: 2018-07-14
Posts: 2

"Set as wallpaper" from thunar context menu does not work

The "Set as wallpaper" option from thunar context menu (right click on image) does not work.
It modifies the property:
channel xfce4-desktop; /backdrop/screen0/monitor0/image-path

However, the desktop uses the image at:
channel xfce4-desktop; /backdrop/screen0/monitor0/workspace0/last-image

Environment:
Arch Linux
Only 1 workspace

> thunar --version
Thunar 1.8.1git-f5147445 (Xfce 4.12)

Copyright (c) 2004-2015
	The Thunar development team. All rights reserved.

Written by Benedikt Meurer <benny@xfce.org>.

Please report bugs to <http://bugzilla.xfce.org/>.
> xfdesktop --version
This is xfdesktop version 4.12.4, running on Xfce 4.12.
Built with GTK+ 2.24.32, linked with GTK+ 2.24.32.
Build options:
    Desktop Menu:        enabled
    Desktop Icons:       enabled
    Desktop File Icons:  enabled

Is it working as intended or should I report it as a bug?
I recall in previous versions it would at least set the wallpaper in the first workspace.

Offline

#2 2018-07-14 12:26:45

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,211

Re: "Set as wallpaper" from thunar context menu does not work

Hello and welcome.

I believe that thunar 1.8x requires xfdesktop 4.13x (which supports the new thunarx-3 API) for this functionality to work properly. It's not easy right now to upgrade xfdesktop on Arch because of the incompatibility between many of the supporting libraries and other Xfce components (you basically have to go all in development 4.13 or stay on 4.12). The major components will work, like thunar, but some of it's functionalities won't.

As a workaround, you can create a custom action for the "Set as wallpaper" functionality that changes the correct xfconf value. If you want to eliminate the errant menu entry, just rename the "/usr/lib/thunarx-3/thunar-wallpaper-plugin.so", to a file not ending in .so, for now.

Last edited by ToZ (2019-02-25 23:47:24)

Offline

#3 2018-07-14 13:08:29

afg984
Member
Registered: 2018-07-14
Posts: 2

Re: "Set as wallpaper" from thunar context menu does not work

Oh, never thought about that. Really appreciate the detailed explanation!

Offline

#4 2019-01-13 11:47:57

k-3.14
Member
From: Rhineland
Registered: 2017-02-18
Posts: 116

Re: "Set as wallpaper" from thunar context menu does not work

Thank you ToZ for the explanation and workaround.

Just stumbled over this issue here with DEBIAN Buster (testing).
And xfdesktop4 4.13 is still far away (at the moment in DEBIAN experimental).

Offline

#5 2019-02-25 22:27:31

tkarch
Member
From: Germany
Registered: 2019-02-25
Posts: 1

Re: "Set as wallpaper" from thunar context menu does not work

ToZ wrote:

If you want to eliminate the errant menu entry, just rename the "/usr/lib/thunarx-3/thunar-wallpaper-plugin.so" file for now.

I've renamed the file to thunar-wallpaper-plugin-disabled.so, and logged out and in again, but the menu entry in thunar is still there. Any advice? Adding my own custom command for setting the wallpaper worked nicely - thanks.

-- Update --
sorry, stupid me ... figured it out ... renamed again to "thunar-wallpaper-plugin-disabled" (without the .so) worked ... Menu entry gone now smile

Last edited by tkarch (2019-02-25 22:32:10)

Offline

#6 2019-02-25 23:46:37

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,211

Re: "Set as wallpaper" from thunar context menu does not work

Sorry, I was unclear. Yes you need to rename it to something without the .so extension. I'll edit my post above.

BTW, welcome to the forums.

Offline

Board footer

Powered by FluxBB