Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-07-26 12:02:09

Spass
Member
From: Poland
Registered: 2016-12-07
Posts: 85
Website

[+] How to fix MIME types? "Run" as default action for HTML/CSS files

Hello. I have an issue with HTML and CSS files in Thunar 1.6.15 on Xubuntu 18.04 (I had the same issue on 17.10 before the upgrade). The default action for those files is "Run", double-clicking those files does nothing. I need to use "Open with". In xfce4-mime-settings I see Firefox as a default application for text/html and Geany as a default for text/css. Also in the terminal I see:

$ xdg-mime query default text/html
firefox.desktop
$ xdg-mime query default text/css
geany.desktop

How can I fix that / get rid of that "Run"?

Last edited by Spass (2018-07-26 13:50:36)


xubuntu-pl (Polish Xubuntu Community)

Offline

#2 2018-07-26 13:36:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,824

Re: [+] How to fix MIME types? "Run" as default action for HTML/CSS files

You must have "/misc-exec-shell-scripts-by-default" set to true and the html file with execute permissions. Removing the execute permission from those files should remove the Run option.

Offline

#3 2018-07-26 13:50:14

Spass
Member
From: Poland
Registered: 2016-12-07
Posts: 85
Website

Re: [+] How to fix MIME types? "Run" as default action for HTML/CSS files

Yes, that was it. I have no idea why all those files were executable. But simply changing chmod -x fixed the issue. Thanks ToZ.


xubuntu-pl (Polish Xubuntu Community)

Offline

Board footer

Powered by FluxBB