Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-08-24 00:10:19

johnywhy
Member
Registered: 2011-10-09
Posts: 151

How to Fix "Not authorized to control networking" for Desktop User?

When logged in as Admin user, i can connect/disconnect using nm-applet.
But when logged in as Desktop user, i can see the nm-applet in panel, but "disconnect" is grayed out. If i click anything, i get "Not authorized to control networking".

i applied this config in

/etc/polkit-1/localauthority/10-vendor.d/org.freedesktop.NetworkManager.pkla
[nm-applet]
Identity=unix-group:netdev
Action=org.freedesktop.NetworkManager.*
ResultActive=yes
ResultAny=yes
ResultInactive=no

and i ensured the user is a member of netdev.
https://askubuntu.com/a/708262

But still cannot connect/disconnect with nm-applet. Also tried

Action=NetworkManager

, but no luck.

i confirmed polkit agent is running

$ ps -ef | grep polkit-gnome
johny     1292  1150  0 16:39 ?        00:00:00 /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
johny     2065  2054  0 16:45 pts/0    00:00:00 grep --color=auto polkit-gnome

But maybe i don't need the agent? "if you use gnome-shell, you do not need /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 because gnome-shell has its own agent incorporated" https://bbs.archlinux.org/viewtopic.php … 2#p1099562

i noticed "NetworkManager" is not listed when i do pkaction. Should it be?

Not sure if this is related, but I'm getting

$ pkaction -v -a org.freedesktop.NetworkManager.settings.modify.system
No action with action id org.freedesktop.NetworkManager.settings.modify.system

https://mail.gnome.org/archives/network … 00039.html

NetworkManager appears to be running, as Mint connects to previously-stored wiki on boot, and In Task Manager, i see
NetworkManager --no-daemon
nm-applet

Maybe i need to use

/etc/dbus-1/system.d/NetworkManager.conf

? Something like:

        <policy group="network">
                <allow send_destination="org.freedesktop.NetworkManager"/>
                <allow send_interface="org.freedesktop.NetworkManager"/>
        </policy>

https://gist.github.com/gsongsong/36fc7 … b391cb98f9
https://developer.gnome.org/NetworkMana … .conf.html
https://superuser.com/questions/219108/ … 140#219140

Or, maybe need to use

Action=org.freedesktop.NetworkManager.settings.modify.system

https://bugs.launchpad.net/ubuntu/+sour … omments/41
But i thought the asterisk in my first try, above, would cover this.

Or, add "ck-launch-session" to my .xinitrc file?
https://www.linuxquestions.org/question … ost4230988

Or, remove "ck-launch-session" from my .xinitrc file?
https://bbs.archlinux.org/viewtopic.php … 9#p1099639

Or, change my login manager?
"Changed login manager, seems to have sorted it."
https://bbs.archlinux.org/viewtopic.php … 5#p1084865

Or, use 'network' group, instead of 'netdev'?
https://wiki.archlinux.org/index.php/Ne … ermissions

Or, 'plugdev' group?
https://www.linuxquestions.org/question … ost4461109

I noticed the Admin user is not a member of netdev:

$ id patty 
uid=1001(patty) gid=1001(patty) groups=1001(patty),4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),27(sudo),29(audio),30(dip),44(video),46(plugdev),115(lpadmin),120(scanner),128(sambashare)

This comment seems to indicate i can add a new connection as non-root, but it won't be available to all users. However, when i try, everything in "Network Connections" app is disabled.
https://bugs.launchpad.net/ubuntu/+sour … comments/4

Or, something like

/lib/udev/rules.d/70-usb-modeswitch.rules
to get networking with my Aldi/Medion Mobile Huawei E173:

# own udev rules for Aldi/Medion Huawei E173
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1446", RUN+="/usr/sbin/usb_modeswitch -v 12d1 -p 1446 -M '55534243123456780000000000000011062000000100000000000000000000'"
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1436", RUN+="/bin/bash -c 'modprobe option && echo 12d1 1436 > /sys/bus/usb-serial/drivers/option1/new_id'"

https://bugs.launchpad.net/ubuntu/+sour … comments/4

Last edited by johnywhy (2018-08-24 00:26:03)


Mint 19 xfce, 4.15.0-29-generic #31-Ubuntu SMP, x86_64 x86_64 x86_64 GNU/Linux

Offline

#2 2018-08-24 02:28:27

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,839

Re: How to Fix "Not authorized to control networking" for Desktop User?

johnywhy wrote:

Not sure if this is related, but I'm getting

$ pkaction -v -a org.freedesktop.NetworkManager.settings.modify.system
No action with action id org.freedesktop.NetworkManager.settings.modify.system

https://mail.gnome.org/archives/network … 00039.html

Looks like something is wrong with polkit. Is polkitd running?

On a Mint Live CD, I get:

$ pkaction -v -a org.freedesktop.NetworkManager.settings.modify.system
org.freedesktop.NetworkManager.settings.modify.system:
  description:       Modify network connections for all users
  message:           System policy prevents modification of network settings for all users
  vendor:            NetworkManager
  vendor_url:        http://www.gnome.org/projects/NetworkManager
  icon:              nm-icon
  implicit any:      auth_admin_keep
  implicit inactive: auth_admin_keep
  implicit active:   auth_admin_keep

What does the following return?

loginctl

...and:

loginctl show-session cX

...where "cX" is the session id identified in the previous command.

Offline

#3 2018-08-24 03:02:05

johnywhy
Member
Registered: 2011-10-09
Posts: 151

Re: How to Fix "Not authorized to control networking" for Desktop User?

$ loginctl
   SESSION        UID USER             SEAT             TTY             
        c2       1000 johny            seat0                            

1 sessions listed.
$ loginctl show-session c2
Id=c2
User=1000
Name=johny
Timestamp=Thu 2018-08-23 17:52:28 PDT
TimestampMonotonic=1068325972
VTNr=7
Seat=seat0
Display=:0
Remote=no
Service=lightdm
Desktop=xfce
Scope=session-c2.scope
Leader=955
Audit=0
Type=x11
Class=user
Active=yes
State=active
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
LockedHint=no

Mint 19 xfce, 4.15.0-29-generic #31-Ubuntu SMP, x86_64 x86_64 x86_64 GNU/Linux

Offline

#4 2018-08-24 03:04:00

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,839

Re: How to Fix "Not authorized to control networking" for Desktop User?

ps -ef | grep polkitd

?

Offline

#5 2018-08-24 06:29:52

johnywhy
Member
Registered: 2011-10-09
Posts: 151

Re: How to Fix "Not authorized to control networking" for Desktop User?

$ loginctl
   SESSION        UID USER             SEAT             TTY             
        c2       1000 johny            seat0                            

1 sessions listed.
$ loginctl show-session c2
Id=c2
User=1000
Name=johny
Timestamp=Thu 2018-08-23 20:00:50 PDT
TimestampMonotonic=54700649
VTNr=7
Seat=seat0
Display=:0
Remote=no
Service=lightdm
Desktop=xfce
Scope=session-c2.scope
Leader=969
Audit=0
Type=x11
Class=user
Active=yes
State=active
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
LockedHint=no

Mint 19 xfce, 4.15.0-29-generic #31-Ubuntu SMP, x86_64 x86_64 x86_64 GNU/Linux

Offline

Board footer

Powered by FluxBB