Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-09-26 21:22:56

schnappi
Member
Registered: 2018-04-16
Posts: 15

[Resolved] Serious issue

Running Arch. Update almost daily. When turned on computer today after logging in as user the wallpaper was blank, can not right click, minimize or maximize windows (visual buttons completely missing), and the taskbar icons look strange (especially network manager icon).

On a positive note everything still works. Minus minimize or ability to close anything though...

Everything had been running great for about a year updating daily. Not sure if Arch forum would have been better choice. Came here because nothing wrong until login as a user. The user login screen displays wallpaper. The issue really only starts once XFCE starts.

Hopefully can solve this. Assuming the fix is not too bad still glad switched from Windows. Just hoping it doesn’t become an issue where no one knows what happened.

Last edited by schnappi (2018-10-27 18:28:32)

Offline

#2 2018-09-26 21:34:19

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,019

Re: [Resolved] Serious issue

Description seems like your window manager crashed. Try running xfwm from a terminal window to see if things change.

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#3 2018-09-26 22:30:20

mint4all
Member
From: America
Registered: 2018-08-21
Posts: 64

Re: [Resolved] Serious issue

Greetings!

Just to be clear -- I am not familiar with your Arch distro (our moderator, ToZ, is quite the expert on that), but have dealt with a number of XFCE quirks myself ... One of the "gotcha"s is xfce's feature of "saving" a session upon logout. Though quite useful at times (mostly for static apps, ie. xfce-terminal), it can create havoc when a system update conflicts with apps that were left "open" upon a logout, screen lock, susppend, or hibernate.

A simple way to remove THAT potential source of problems: delete any "saved" session file(s) left behind in your system's ~/.config/.sessions folder. In addition, there are 2 other places where the option to have xfce save your session must be turned off; but let's tackle this one step at a time ...

Aside from that, do you backup your system with something like "timeshift", or an equivalent, that would enable you to roll back any unwanted updates?

Good luck, M4A


Linux Mint 18.3-xfce & Linux Mint 19-xfce  -- Dell Precision T1500 Desktops -- Toshiba Satellite Laptop -- Family & Community Support re. Linux

Offline

#4 2018-09-27 01:06:37

schnappi
Member
Registered: 2018-04-16
Posts: 15

Re: [Resolved] Serious issue

Running xfwm4 resolved.

What can be done, short of putting xfwm4 in .profile or as an Xfce startup command to ensure the windows manager starts correctly?

Offline

#5 2018-09-27 02:06:18

mint4all
Member
From: America
Registered: 2018-08-21
Posts: 64

Re: [Resolved] Serious issue

schnappi wrote:

Running xfwm4 resolved.

What can be done, short of putting xfwm4 in .profile or as an Xfce startup command to ensure the windows manager starts correctly?

Afaik -- unless this got messed up -- your window manager SHOULD auto-start at login time. This is controlled via xfce's settings manager, as you can see ...Xfwm_Auto_Startup.png
Since your system appears to NOT autostart it, somehow your system-settings got messed up, imho.

Could you check this out? And if my take is correct, re-activate THAT autostart control? Thanks.


Linux Mint 18.3-xfce & Linux Mint 19-xfce  -- Dell Precision T1500 Desktops -- Toshiba Satellite Laptop -- Family & Community Support re. Linux

Offline

#6 2018-10-27 18:28:00

schnappi
Member
Registered: 2018-04-16
Posts: 15

Re: [Resolved] Serious issue

The forum going down resulted to delayed response. Thank you for help. Running "xfwm4" resolved. Next time restarted the problem did not occur again. However, the problem was occurring after restarts until ran "xfwm4."

Offline

#7 2018-10-27 21:53:30

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 497
Website

Re: [Resolved] Serious issue

schnappi wrote:

The forum going down resulted to delayed response. Thank you for help. Running "xfwm4" resolved. Next time restarted the problem did not occur again. However, the problem was occurring after restarts until ran "xfwm4."

That sounds like a sessions issue. In Settings - Session and Startup - Sessions use the clear saved sessions option. Then check that save session isn't selected when you log out.

Offline

Board footer

Powered by FluxBB