Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-05-11 14:39:39

NewtSoup
Member
Registered: 2019-05-11
Posts: 12

Hello from Ruth

Hi there,

I'm NewtSoup / Ruth.  I'm an older gamer running Linux Mint 19 with the XFCE Desktop.  I went with XCFE over Cinnamon becuase I needed something lightweight and full featured and Cinnamon kept on freaking out with it's GLCompositing : Fuzzy Desktop Text which also crashes games as it turns out

So here I am, new to XFCE - I have a question about volume controls which I'm sure crops up often it but I won't post that in this thread ( I installed the pulse audio volume control - but still a niggle is present )

Offline

#2 2019-05-11 14:59:49

MrEen
Member
Registered: 2019-04-19
Posts: 77

Re: Hello from Ruth

Hi Ruth, and welcome to the forum.

One nice thing about Mint's version of Xfce when you have pavucontrol installed is the sound icon in the panel will open pavucontrol when you left click and choose Sound Settings...  No need to open the Menu or a terminal window to get to it.

Offline

#3 2019-05-11 15:13:06

NewtSoup
Member
Registered: 2019-05-11
Posts: 12

Re: Hello from Ruth

I did

sudo apt install xfce4-pulseaudio-plugin

then

added keyboard shortcuts for volume up 5% and down 5% on master volume

This works, however it ignores my USB headset volume controls and when I play games the sound comes out of the speakers still rather htan going through my USB headset even when I have the output set to headphones.  Neither will the keyboard shortcuts change the volume when the output is set to USB headphones

Audio for Netflix and Amazon etc still come out Headphones but Xplayer audio comes out of the speakers.  I'm thinking I don't have the right plugin installed.

Last edited by NewtSoup (2019-05-11 15:19:18)

Offline

#4 2019-05-11 15:26:05

MrEen
Member
Registered: 2019-04-19
Posts: 77

Re: Hello from Ruth

I want to make sure I understand. I sound going through the speakers AND the headphones, or just the speakers?

Also, let's see what options are available on the USB headset. In the terminal run aplay -l and take note of the card number for the USB device. Then run amixer -c # replacing # with the card number from the aplay output.

Offline

#5 2019-05-11 15:32:45

NewtSoup
Member
Registered: 2019-05-11
Posts: 12

Re: Hello from Ruth

MrEen wrote:

I want to make sure I understand. I sound going through the speakers AND the headphones, or just the speakers?

Also, let's see what options are available on the USB headset. In the terminal run aplay -l and take note of the card number for the USB device. Then run amixer -c # replacing # with the card number from the aplay output.

Yep.  When I have the sound output set to headphones the sound from streaming services in the browser comes through the headphones but the sound from all other applications  games / media players etc comes through the speakers regardless.

Offline

#6 2019-05-11 15:43:36

MrEen
Member
Registered: 2019-04-19
Posts: 77

Re: Hello from Ruth

Okay. It sounds like you have the Built-in Audio set as the default device and somehow changed the browser output to the headset. Was this a clean install, or did you save your home directory from your cinnamon install?

You can change the output of currently playing sounds on the Playback tab of pavucontrol. The default sound icon can open that as I said in my first post, or the xfce-pulseaudio-plugin can by left clicking on it and choosing Audio mixer...

The Output Devices tab can set the default device to whichever you want by highlighting the check mark next to the appropriate device.

Offline

#7 2019-05-11 15:49:55

NewtSoup
Member
Registered: 2019-05-11
Posts: 12

Re: Hello from Ruth

If I change the output device when watching streaming on headphones to speakers ( built in audio) the output from the web streams switched to speakers as expected.

It's only applications that refuse to switch sound devices.

When I switched to XFCE I did not reinstall mint or remove cinnamon first.  Cinnamon is still installed as an option to go back to.

It's probably something really simple but I only learn stuff about linux as issues occur.  This bit is all new to me, so thank you for your patience.

Offline

#8 2019-05-11 15:54:11

MrEen
Member
Registered: 2019-04-19
Posts: 77

Re: Hello from Ruth

Open something in Xplayer. While it is playing, go to the Playback tab and switch Xplayer's output from Built-in Audio.. to USB..

Does that work?

Offline

#9 2019-05-11 15:58:00

MrEen
Member
Registered: 2019-04-19
Posts: 77

Re: Hello from Ruth

This might help as well. Delete the files in /home/YourUserName/.config/pulse then run

pulseaudio -k

in the terminal. This will generate a fresh set of pulseaudio config files. You'll probably need to restart everything that plays sound after that.

Last edited by MrEen (2019-05-11 15:59:23)

Offline

#10 2019-05-11 16:14:51

NewtSoup
Member
Registered: 2019-05-11
Posts: 12

Re: Hello from Ruth

With the sound sent to speakers I stated XPlayer - the sound from the video came through the speakers.  I then switched the sound to headphones and the sound switched to headphones.

I have deleted all the config file and run the command you suggest.

I then switched the sound to headphones and started x player - the sound came through headphones as expected.
I then started Elite Dangerous and the sound came through headphones as expected

Switching the sound to speakers worked as expected with Elite running
Switching the sound back to headphones worked as expected with Elite running.

All good so far - Thank you so much

I had to reset the keyboard shortcuts for the keyboard volume controls
amixer set Master 5%+  <press key>
and so forth

The volume controls work for speakers but not while the output is piped to headphones.

Definitely made progress though smile The important thing is I won't be disturbing my neighbours when I come home from work and start playing Games and Watching Movies at 2am smile

Last edited by NewtSoup (2019-05-11 16:19:06)

Offline

#11 2019-05-11 16:31:40

NewtSoup
Member
Registered: 2019-05-11
Posts: 12

Re: Hello from Ruth

Forgive me if I don't respond for a few hours.  I am off to work for the evening.

Offline

#12 2019-05-11 18:59:17

MrEen
Member
Registered: 2019-04-19
Posts: 77

Re: Hello from Ruth

NewtSoup wrote:

I had to reset the keyboard shortcuts for the keyboard volume controls
amixer set Master 5%+  <press key>
and so forth

The volume controls work for speakers but not while the output is piped to headphones.

With that amixer command, you are changing the Master volume level of card 0, the default sound card which in your case is your built-in sound card.

Your USB Headset is a separate sound device that has it's own controls (if any.) Run this in the terminal:

aplay -l

then find the card number of the USB device. Here's one for comparison:

card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC221 Analog [ALC221 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: CODEC [USB Audio CODEC], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

In this case, the USB device is card #2. To find out what simple mixer options are available, you'd then run:

amixer -c 2 

At this point, it depends what options are available to figure out how to raise the volume, but it will certainly start with:

amixer -c 2 set ...

I think you'll be able to figure out what you need, but don't be afraid to ask if you need more assistance.

Offline

#13 2019-05-11 23:34:48

NewtSoup
Member
Registered: 2019-05-11
Posts: 12

Re: Hello from Ruth

I'm a dunce I'm afraid:

aplay -1 gives

card 2: P780 [Plantronics GameCom 780], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
ruth@ruth-mint:~$ 

So I know card 2 is my headset

amixer -c 2 says:

ruth@ruth-mint:~$ amixer -c 2 
Simple mixer control 'PCM Capture Source',0
  Capabilities: enum
  Items: 'Mic' 'Line' 'IEC958 In'
  Item0: 'Mic'
Simple mixer control 'Line',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 27
  Front Left: Capture 0 [0%] [-16.00dB] [off]
  Front Right: Capture 0 [0%] [-16.00dB] [off]
Simple mixer control 'Mic',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 27
  Front Left: Capture 26 [96%] [10.00dB] [on]
  Front Right: Capture 26 [96%] [10.00dB] [on]
Simple mixer control 'IEC958 In',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
ruth@ruth-mint:~$

and only tells me about capture / in

so I do:

 
ruth@ruth-mint:~$ amixer -c 2 controls
numid=8,iface=MIXER,name='PCM Capture Source'
numid=5,iface=MIXER,name='Line Capture Switch'
numid=6,iface=MIXER,name='Line Capture Volume'
numid=3,iface=MIXER,name='Mic Capture Switch'
numid=4,iface=MIXER,name='Mic Capture Volume'
numid=7,iface=MIXER,name='IEC958 In Capture Switch'
numid=2,iface=PCM,name='Capture Channel Map'
numid=1,iface=PCM,name='Playback Channel Map'
ruth@ruth-mint:~$

and still can't find anything that will affect playback volume.

However I have found this in a reddit thread

amixer -q -D pulse sset Master 5%+ unmute
amixer -q -D pulse sset Master 5%- unmute
amixer -q -D pulse sset Master toggle

which makes the keyboard volume controls respond to whatever I have set to the default device at the time and has the added bonus of making the volume control on my headset work as well.  This is what I was trying to do all along big_smile

Not sure exactly how all this fits together so if you have time I'd love a brief explanation as I love learning this stuff but I'm slower at figuring stuff out these days.

Also, Mr Een.  I've seen your name elsewhere.  I think on the KSP forums?  ( I'm the same NewtSoup )

Last edited by NewtSoup (2019-05-11 23:35:57)

Offline

#14 2019-05-12 01:47:58

MrEen
Member
Registered: 2019-04-19
Posts: 77

Re: Hello from Ruth

Nice reddit find. The important thing is you got it working the way you wanted.

I'm a liitle surprised at that amixer -c 2 output, as it's entirely for the mic, but I don't have a USB headset myself, so it may be completely normal. It's not my usual way of toggling/adjusting audio devices, so I'm not really the one to help explain it all. wiki.archlinux.org is usually a great site for sound stuff, but amixer is only covered for unmuting that I could find.

I assisted you on the Mint forum about a week after you joined there and I post there a lot, usually on sound issues.

Anyway, again, welcome! smile

Offline

#15 2019-05-12 04:12:34

NewtSoup
Member
Registered: 2019-05-11
Posts: 12

Re: Hello from Ruth

Well, thanks again MrEen.  If you ever end up playing KSP I'll be glad to give you return advice big_smile

Offline

Board footer

Powered by FluxBB