Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-08-13 21:15:03

The Loko
Member
Registered: 2015-01-23
Posts: 4

[Solved] Game can't recover mouse on XFCE 4.14 after Alt+Tab

Hi!
Since I upgraded the desktop to 4.14 (Arch Linux) when playing ETLegacy if Alt+Tab is used then the mouse doesn't work in game (the game cursor doesn't move, and the desktop one is shown), and the game starts running slow (like limited to 10FPS), but the keyboard works fine.

It doesn't matter if the game is on full screen or windowed. I tried to reproduce this behavior with other games or full screen apps but it never happens.
The problem is "solved" downgrading XFCE or using another WM/DE.

What could be the reason? How could I start debugging this?
Thanks

Last edited by The Loko (Today 18:56:22)

Offline

#2 2019-08-13 23:48:20

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,667

Re: [Solved] Game can't recover mouse on XFCE 4.14 after Alt+Tab

Does this happen with any other apps?

I guess the best way to troubleshoot this would be to do a git bisect to try to identify the offending commit. At least point to the culprit. Creating a bug report might also get the attention of the developer.

Offline

#3 Today 18:55:44

The Loko
Member
Registered: 2015-01-23
Posts: 4

Re: [Solved] Game can't recover mouse on XFCE 4.14 after Alt+Tab

Thanks!
After bisecting xfwm4 I noticed that the culprit was another package I upgraded that day, SDL libraries, downgrading that one the game works fine on XFCE 4.14!

Offline

Board footer

Powered by FluxBB