Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-08-19 18:33:45

daunbailo
Member
From: Italy
Registered: 2015-11-22
Posts: 26

Catfish doesn't take configuration

Hi there,
every time I open catfish to make a search I have to select all options I need as File Type (left column), in content, exact match and so on.
There is a way to fix this issue?

Many thanks

Offline

#2 2019-08-19 20:30:39

alcornoqui
Member
Registered: 2014-07-28
Posts: 473

Re: Catfish doesn't take configuration

According to the manual, "in content" and "exact match" are command line flags, so you can change the command in the launcher (or whatever you use to launch the program, such as Thunar context menu/custom action).

So, instead of launching "catfish", you'd do:

catfish --exact --fulltext

As for file type, it seems like there's no command line flag, but I think the option only filters the displayed results, the actual search is the same.

Hopefully someone more knowledgeable can tell us if we can use the config file (in ~/.config/catfish/catfish.rc) to make those options permanent without adding the flags.

Edit: Changed wrong link

Last edited by alcornoqui (2019-08-19 20:32:44)

Offline

#3 2019-08-19 22:27:36

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,886

Re: Catfish doesn't take configuration

alcornoqui wrote:

Hopefully someone more knowledgeable can tell us if we can use the config file (in ~/.config/catfish/catfish.rc) to make those options permanent without adding the flags.

Doesn't look like you can. However, you can create an alias and use that:

alias catfish='catfish --exact --fulltext'

Offline

Board footer

Powered by FluxBB